blob: 15cf6f5ccad82a40de714d52ddbe176f6ae48a0d [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Flex (The Fast Lexical Analyzer)"
2DESCRIPTION = "Flex is a fast lexical analyser generator. Flex is a tool for generating programs that recognize \
3lexical patterns in text."
4HOMEPAGE = "http://sourceforge.net/projects/flex/"
5SECTION = "devel"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00006LICENSE = "BSD-3-Clause & LGPL-2.0-or-later"
Patrick Williams213cb262021-08-07 19:21:33 -05007LICENSE:${PN}-libfl = "BSD-3-Clause"
Andrew Geissler82c905d2020-04-13 13:39:40 -05008
9DEPENDS = "${@bb.utils.contains('PTEST_ENABLED', '1', 'bison-native flex-native', '', d)}"
10BBCLASSEXTEND = "native nativesdk"
11
William A. Kennington IIIac69b482021-06-02 12:28:27 -070012LIC_FILES_CHKSUM = "file://COPYING;md5=e4742cf92e89040b39486a6219b68067 \
13 file://src/gettext.h;beginline=1;endline=17;md5=9c05dda2f58d89b850c399cf22e1a00c"
Andrew Geissler82c905d2020-04-13 13:39:40 -050014
Andrew Geissler87f5cff2022-09-30 13:13:31 -050015SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/flex-${PV}.tar.gz \
Andrew Geissler82c905d2020-04-13 13:39:40 -050016 file://run-ptest \
17 file://0001-tests-add-a-target-for-building-tests-without-runnin.patch \
18 ${@bb.utils.contains('PTEST_ENABLED', '1', '', 'file://disable-tests.patch', d)} \
19 file://0001-build-AC_USE_SYSTEM_EXTENSIONS-in-configure.ac.patch \
Andrew Geisslerb7d28612020-07-24 16:15:54 -050020 file://check-funcs.patch \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060021 file://0001-Emit-no-line-directives-if-gen_line_dirs-is-false.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050022 "
23
24SRC_URI[md5sum] = "2882e3179748cc9f9c23ec593d6adc8d"
25SRC_URI[sha256sum] = "e87aae032bf07c26f85ac0ed3250998c37621d95f8bd748b31f15b33c45ee995"
26
Andrew Geissler87f5cff2022-09-30 13:13:31 -050027GITHUB_BASE_URI = "https://github.com/westes/flex/releases"
Andrew Geissler82c905d2020-04-13 13:39:40 -050028
Andrew Geissler5199d832021-09-24 16:47:35 -050029# Disputed - yes there is stack exhaustion but no bug and it is building the
30# parser, not running it, effectively similar to a compiler ICE. Upstream no plans to address
31# https://github.com/westes/flex/issues/414
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000032CVE_CHECK_IGNORE += "CVE-2019-6293"
Andrew Geissler5199d832021-09-24 16:47:35 -050033
Andrew Geissler87f5cff2022-09-30 13:13:31 -050034inherit autotools gettext texinfo ptest github-releases
Andrew Geissler82c905d2020-04-13 13:39:40 -050035
36M4 = "${bindir}/m4"
Patrick Williams213cb262021-08-07 19:21:33 -050037M4:class-native = "${STAGING_BINDIR_NATIVE}/m4"
Andrew Geissler82c905d2020-04-13 13:39:40 -050038EXTRA_OECONF += "ac_cv_path_M4=${M4} ac_cv_func_reallocarray=no"
39EXTRA_OEMAKE += "m4=${STAGING_BINDIR_NATIVE}/m4"
40
41EXTRA_OEMAKE += "${@bb.utils.contains('PTEST_ENABLED', '1', 'FLEX=${STAGING_BINDIR_NATIVE}/flex', '', d)}"
42
Patrick Williams213cb262021-08-07 19:21:33 -050043do_install:append:class-native() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050044 create_wrapper ${D}/${bindir}/flex M4=${M4}
45}
46
Patrick Williams213cb262021-08-07 19:21:33 -050047do_install:append:class-nativesdk() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050048 create_wrapper ${D}/${bindir}/flex M4=${M4}
49}
50
51PACKAGES =+ "${PN}-libfl"
52
Patrick Williams213cb262021-08-07 19:21:33 -050053FILES:${PN}-libfl = "${libdir}/libfl.so.* ${libdir}/libfl_pic.so.*"
Andrew Geissler82c905d2020-04-13 13:39:40 -050054
Patrick Williams213cb262021-08-07 19:21:33 -050055RDEPENDS:${PN} += "m4"
56RDEPENDS:${PN}-ptest += "bash gawk make"
Andrew Geissler82c905d2020-04-13 13:39:40 -050057
58do_compile_ptest() {
59 oe_runmake -C ${B}/tests -f ${B}/tests/Makefile top_builddir=${B} INCLUDES=-I${S}/src buildtests
60}
Andrew Geissler615f2f12022-07-15 14:00:58 -050061PTEST_PARALLEL_MAKE = ""
Andrew Geissler82c905d2020-04-13 13:39:40 -050062
63do_install_ptest() {
64 mkdir -p ${D}${PTEST_PATH}/build-aux/
65 cp ${S}/build-aux/test-driver ${D}${PTEST_PATH}/build-aux/
66 cp -r ${S}/tests/* ${D}${PTEST_PATH}
67 cp -r ${B}/tests/* ${D}${PTEST_PATH}
68 sed -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
69 -e 's|${DEBUG_PREFIX_MAP}||g' \
70 -e 's:${HOSTTOOLS_DIR}/::g' \
71 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
72 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \-e 's/^Makefile:/_Makefile:/' \
73 -e 's/^srcdir = \(.*\)/srcdir = ./' -e 's/^top_srcdir = \(.*\)/top_srcdir = ./' \
74 -e 's/^builddir = \(.*\)/builddir = ./' -e 's/^top_builddir = \(.*\)/top_builddir = ./' \
75 -e 's:${UNINATIVE_LOADER}:${base_bindir}/false:g' \
76 -i ${D}${PTEST_PATH}/Makefile
77}
78# The uninative loader is different on i386 & x86_64 hosts. Since it is only
79# being replaced with /bin/false anyway, it doesn't need to be part of the task
80# hash
81do_install_ptest[vardepsexclude] += "UNINATIVE_LOADER"
82
83# Not Apache Flex, or Adobe Flex, or IBM Flex.
84CVE_PRODUCT = "flex_project:flex"