blob: caf6f60479acba8b364ea32ed20b8953704cced5 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "Library provides support for the Tag Image File Format \
3(TIFF), a widely used format for storing image data. This library \
4provide means to easily access and create TIFF image files."
5HOMEPAGE = "http://www.libtiff.org/"
Brad Bishop19323692019-04-05 15:28:33 -04006LICENSE = "BSD-2-Clause"
7LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf"
8
9CVE_PRODUCT = "libtiff"
10
Andrew Geissler615f2f12022-07-15 14:00:58 -050011SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
Patrick Williams92b42cb2022-09-03 06:53:57 -050012 file://0001-fix-the-FPE-in-tiffcrop-415-427-and-428.patch \
13 file://CVE-2022-34526.patch \
Andrew Geissler87f5cff2022-09-30 13:13:31 -050014 file://CVE-2022-2953.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050015 "
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000016
Andrew Geissler78b72792022-06-14 06:47:25 -050017SRC_URI[sha256sum] = "917223b37538959aca3b790d2d73aa6e626b688e02dcda272aec24c2f498abed"
Brad Bishop19323692019-04-05 15:28:33 -040018
19# exclude betas
20UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
21
William A. Kennington IIIac69b482021-06-02 12:28:27 -070022# Tested with check from https://security-tracker.debian.org/tracker/CVE-2015-7313
23# and 4.3.0 doesn't have the issue
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000024CVE_CHECK_IGNORE += "CVE-2015-7313"
Andrew Geissler78b72792022-06-14 06:47:25 -050025# These issues only affect libtiff post-4.3.0 but before 4.4.0,
26# caused by 3079627e and fixed by b4e79bfa.
27CVE_CHECK_IGNORE += "CVE-2022-1622 CVE-2022-1623"
28
29# Issue is in jbig which we don't enable
30CVE_CHECK_IGNORE += "CVE-2022-1210"
William A. Kennington IIIac69b482021-06-02 12:28:27 -070031
Brad Bishop19323692019-04-05 15:28:33 -040032inherit autotools multilib_header
33
34CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
35
36PACKAGECONFIG ?= "cxx jpeg zlib lzma \
37 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
38
39PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
Andrew Geissler78b72792022-06-14 06:47:25 -050040PACKAGECONFIG[jbig] = "--enable-jbig,--disable-jbig,jbig,"
Brad Bishop19323692019-04-05 15:28:33 -040041PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
42PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
43PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
44
45# Convert single-strip uncompressed images to multiple strips of specified
46# size (default: 8192) to reduce memory usage
47PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
48
49# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
50PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
51
52# Control picking up YCbCr subsample info. Disable to support files lacking
53# the tag
54PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
55
56# Support a mechanism allowing reading large strips (usually one strip files)
57# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
58PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
59
60PACKAGES =+ "tiffxx tiff-utils"
Patrick Williams213cb262021-08-07 19:21:33 -050061FILES:tiffxx = "${libdir}/libtiffxx.so.*"
62FILES:tiff-utils = "${bindir}/*"
Brad Bishop19323692019-04-05 15:28:33 -040063
Patrick Williams213cb262021-08-07 19:21:33 -050064do_install:append() {
Brad Bishop19323692019-04-05 15:28:33 -040065 oe_multilib_header tiffconf.h
66}
67
Andrew Geissler4ed12e12020-06-05 18:00:41 -050068BBCLASSEXTEND = "native nativesdk"