blob: e30df0b3e9e4422fb25b113f570c62239dc4df66 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "Library provides support for the Tag Image File Format \
3(TIFF), a widely used format for storing image data. This library \
4provide means to easily access and create TIFF image files."
5HOMEPAGE = "http://www.libtiff.org/"
Brad Bishop19323692019-04-05 15:28:33 -04006LICENSE = "BSD-2-Clause"
7LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf"
8
9CVE_PRODUCT = "libtiff"
10
Andrew Geissler615f2f12022-07-15 14:00:58 -050011SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
Patrick Williams92b42cb2022-09-03 06:53:57 -050012 file://0001-fix-the-FPE-in-tiffcrop-415-427-and-428.patch \
13 file://CVE-2022-34526.patch \
14 "
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000015
Andrew Geissler78b72792022-06-14 06:47:25 -050016SRC_URI[sha256sum] = "917223b37538959aca3b790d2d73aa6e626b688e02dcda272aec24c2f498abed"
Brad Bishop19323692019-04-05 15:28:33 -040017
18# exclude betas
19UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
20
William A. Kennington IIIac69b482021-06-02 12:28:27 -070021# Tested with check from https://security-tracker.debian.org/tracker/CVE-2015-7313
22# and 4.3.0 doesn't have the issue
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000023CVE_CHECK_IGNORE += "CVE-2015-7313"
Andrew Geissler78b72792022-06-14 06:47:25 -050024# These issues only affect libtiff post-4.3.0 but before 4.4.0,
25# caused by 3079627e and fixed by b4e79bfa.
26CVE_CHECK_IGNORE += "CVE-2022-1622 CVE-2022-1623"
27
28# Issue is in jbig which we don't enable
29CVE_CHECK_IGNORE += "CVE-2022-1210"
William A. Kennington IIIac69b482021-06-02 12:28:27 -070030
Brad Bishop19323692019-04-05 15:28:33 -040031inherit autotools multilib_header
32
33CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
34
35PACKAGECONFIG ?= "cxx jpeg zlib lzma \
36 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
37
38PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
Andrew Geissler78b72792022-06-14 06:47:25 -050039PACKAGECONFIG[jbig] = "--enable-jbig,--disable-jbig,jbig,"
Brad Bishop19323692019-04-05 15:28:33 -040040PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
41PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
42PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
43
44# Convert single-strip uncompressed images to multiple strips of specified
45# size (default: 8192) to reduce memory usage
46PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
47
48# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
49PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
50
51# Control picking up YCbCr subsample info. Disable to support files lacking
52# the tag
53PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
54
55# Support a mechanism allowing reading large strips (usually one strip files)
56# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
57PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
58
59PACKAGES =+ "tiffxx tiff-utils"
Patrick Williams213cb262021-08-07 19:21:33 -050060FILES:tiffxx = "${libdir}/libtiffxx.so.*"
61FILES:tiff-utils = "${bindir}/*"
Brad Bishop19323692019-04-05 15:28:33 -040062
Patrick Williams213cb262021-08-07 19:21:33 -050063do_install:append() {
Brad Bishop19323692019-04-05 15:28:33 -040064 oe_multilib_header tiffconf.h
65}
66
Andrew Geissler4ed12e12020-06-05 18:00:41 -050067BBCLASSEXTEND = "native nativesdk"