blob: 73d933a0025b2cadd538649f3008c8dce217b44d [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Very high-quality data compression program"
2DESCRIPTION = "bzip2 compresses files using the Burrows-Wheeler block-sorting text compression algorithm, and \
3Huffman coding. Compression is generally considerably better than that achieved by more conventional \
4LZ77/LZ78-based compressors, and approaches the performance of the PPM family of statistical compressors."
Brad Bishop220d5532018-08-14 00:59:39 +01005HOMEPAGE = "https://sourceware.org/bzip2/"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05006SECTION = "console/utils"
7LICENSE = "bzip2"
Brad Bishop96ff1982019-08-19 13:50:42 -04008LIC_FILES_CHKSUM = "file://LICENSE;beginline=4;endline=37;md5=600af43c50f1fcb82e32f19b32df4664"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05009
Brad Bishop96ff1982019-08-19 13:50:42 -040010SRC_URI = "https://sourceware.org/pub/${BPN}/${BPN}-${PV}.tar.gz \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050011 file://configure.ac;subdir=${BP} \
12 file://Makefile.am;subdir=${BP} \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060013 file://run-ptest \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060014 "
Brad Bishop96ff1982019-08-19 13:50:42 -040015SRC_URI[md5sum] = "67e051268d0c475ea773822f7500d0e5"
16SRC_URI[sha256sum] = "ab5a03176ee106d3f0fa90e381da478ddae405918153cca248e682cd0c4a2269"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050017
Brad Bishop96ff1982019-08-19 13:50:42 -040018UPSTREAM_CHECK_URI = "https://www.sourceware.org/pub/bzip2/"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080019UPSTREAM_VERSION_UNKNOWN = "1"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050020
Patrick Williamsc124f4f2015-09-15 14:41:29 -050021PACKAGES =+ "libbz2"
22
23CFLAGS_append = " -fPIC -fpic -Winline -fno-strength-reduce -D_FILE_OFFSET_BITS=64"
24
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025inherit autotools update-alternatives ptest relative_symlinks
Patrick Williamsc124f4f2015-09-15 14:41:29 -050026
27ALTERNATIVE_PRIORITY = "100"
Brad Bishop19323692019-04-05 15:28:33 -040028ALTERNATIVE_${PN} = "bunzip2 bzcat bzip2"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050029
30#install binaries to bzip2-native under sysroot for replacement-native
31EXTRA_OECONF_append_class-native = " --bindir=${STAGING_BINDIR_NATIVE}/${PN}"
32
33do_install_ptest () {
Patrick Williamsc124f4f2015-09-15 14:41:29 -050034 sed -i -e "s|^Makefile:|_Makefile:|" ${D}${PTEST_PATH}/Makefile
35}
36
37FILES_libbz2 = "${libdir}/lib*${SOLIBS}"
38
Brad Bishop393846f2019-05-20 12:24:11 -040039RDEPENDS_${PN}-ptest += "make"
40
Patrick Williamsc124f4f2015-09-15 14:41:29 -050041PROVIDES_append_class-native = " bzip2-replacement-native"
42BBCLASSEXTEND = "native nativesdk"