blob: 9b2e41690a739571b2bb2b8ec8b210c54b3b6c7e [file] [log] [blame]
Rick Altherr4d9fd232016-12-08 12:21:49 -08001DESCRIPTION = "Small image capable of booting a device. The kernel includes \
2the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \
3first 'init' program more efficiently."
Ed Tanous9936f862022-09-19 09:13:20 -07004LICENSE = "MIT"
5# Needed for the set_user_group functions to succeed
6DEPENDS += "shadow-native"
7
8inherit core-image
9
10export IMAGE_BASENAME = "obmc-phosphor-initramfs"
11
12BAD_RECOMMENDATIONS += "busybox-syslog"
13
14PACKAGE_INSTALL = "${VIRTUAL-RUNTIME_base-utils} base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} ${INIT_PACKAGE}"
15PACKAGE_INSTALL:remove = "shadow"
Rick Altherr4d9fd232016-12-08 12:21:49 -080016
Adriana Kobylak0998d1e2020-06-03 16:22:42 -050017# Init scripts
18INIT_PACKAGE = "obmc-phosphor-initfs"
Patrick Williams12fc9392021-08-06 09:16:53 -050019INIT_PACKAGE:df-phosphor-mmc = "phosphor-mmc-init"
Rick Altherr4d9fd232016-12-08 12:21:49 -080020# Do not pollute the initrd image with rootfs features
William A. Kennington III60301252019-09-23 12:27:48 -070021IMAGE_FEATURES = "read-only-rootfs"
Rick Altherr4d9fd232016-12-08 12:21:49 -080022IMAGE_LINGUAS = ""
Rick Altherr4d9fd232016-12-08 12:21:49 -080023IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
Rick Altherr4d9fd232016-12-08 12:21:49 -080024IMAGE_ROOTFS_SIZE = "8192"
25IMAGE_ROOTFS_EXTRA_SPACE = "0"
Richard Marian Thomaiyar48423842018-10-03 10:47:25 +053026PACKAGE_EXCLUDE = "shadow"