blob: 77d0c3fca63cf66df433adf12c1dc8c7c1274a36 [file] [log] [blame]
Adriana Kobylak30ca4fc2016-01-30 10:41:48 -06001SUMMARY = "Network DBUS object"
2DESCRIPTION = "Network DBUS object"
3HOMEPAGE = "http://github.com/openbmc/phosphor-networkd"
Brad Bishop75f03872018-11-03 09:41:57 -07004LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
Matthew Barth0c9d4d22016-10-24 12:51:20 -05006DEPENDS += "systemd"
Patrick Williams4b32c9a2020-03-31 16:43:15 -05007DEPENDS += "sdbusplus ${PYTHON_PN}-sdbus++-native"
Adriana Kobylak1b7cb122018-10-01 14:02:44 -05008DEPENDS += "sdeventplus"
Patrick Williamsce14ef62020-06-09 21:00:08 -05009DEPENDS += "phosphor-dbus-interfaces"
Ratan Gupta153a6dc2017-04-28 10:12:54 +053010DEPENDS += "phosphor-logging"
Ratan Gupta7a5340b2018-03-20 15:26:20 +053011DEPENDS += "libnl"
William A. Kennington IIId2781452020-06-14 02:59:44 -070012DEPENDS += "stdplus"
Ed Tanous9936f862022-09-19 09:13:20 -070013SRCREV = "61ef4f2b0c1336c78f28252a17f172957ea4c3e7"
Jiaqing Zhao124fdf32022-07-15 09:27:00 +080014PACKAGECONFIG ??= "uboot-env default-link-local-autoconf default-ipv6-accept-ra persist-mac"
William A. Kennington IIIef047e22021-05-18 13:56:14 -070015PACKAGECONFIG[uboot-env] = "-Duboot-env=true,-Duboot-env=false,,${UBOOT_ENV_RDEPENDS}"
16PACKAGECONFIG[default-link-local-autoconf] = "-Ddefault-link-local-autoconf=true,-Ddefault-link-local-autoconf=false,,"
17PACKAGECONFIG[default-ipv6-accept-ra] = "-Ddefault-ipv6-accept-ra=true,-Ddefault-ipv6-accept-ra=false,,"
18PACKAGECONFIG[nic-ethtool] = "-Dnic-ethtool=true,-Dnic-ethtool=false,,"
19PACKAGECONFIG[sync-mac] = "-Dsync-mac=true,-Dsync-mac=false,nlohmann-json,"
Asmitha Karunanithi6ccf04f2021-07-23 07:40:13 -050020PACKAGECONFIG[hyp-nw-config] = "-Dhyp-nw-config=true, -Dhyp-nw-config=false,,"
Jiaqing Zhao124fdf32022-07-15 09:27:00 +080021PACKAGECONFIG[persist-mac] = "-Dpersist-mac=true, -persist-mac=false,,"
Ed Tanous9936f862022-09-19 09:13:20 -070022PV = "1.0+git${SRCPV}"
23PR = "r1"
24
25SRC_URI += "git://github.com/openbmc/phosphor-networkd;branch=master;protocol=https"
Benjamin Faire46e4c12020-04-15 16:27:18 -070026
Adriana Kobylak30ca4fc2016-01-30 10:41:48 -060027S = "${WORKDIR}/git"
William A. Kennington IIIef047e22021-05-18 13:56:14 -070028SYSTEMD_PACKAGES = "${PN}"
Patrick Williams12fc9392021-08-06 09:16:53 -050029SYSTEMD_SERVICE:${PN} += "xyz.openbmc_project.Network.service"
Asmitha Karunanithi6ccf04f2021-07-23 07:40:13 -050030SYSTEMD_SERVICE:${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'hyp-nw-config', 'xyz.openbmc_project.Network.Hypervisor.service', '', d)}"
William A. Kennington III2b38d3f2021-05-29 15:11:03 -070031
Ed Tanous9936f862022-09-19 09:13:20 -070032inherit meson pkgconfig
33inherit python3native
34inherit systemd
35
Patrick Williamsed104d42021-08-31 13:19:27 -050036EXTRA_OEMESON:append = " -Dtests=disabled"
Ed Tanous9936f862022-09-19 09:13:20 -070037
38FILES:${PN} += "${datadir}/dbus-1/system.d"
39
40UBOOT_ENV_RDEPENDS = "${@d.getVar('PREFERRED_PROVIDER_u-boot-fw-utils', True) or 'u-boot-fw-utils'}"