blob: 8c02b8ece85e7804a25328dda784d78ae94384fa [file] [log] [blame]
Brad Bishop83254dc2015-10-27 17:12:45 -04001SUMMARY = "Phosphor DBUS Object Manager"
2DESCRIPTION = "Phosphor DBUS object manager."
3HOMEPAGE = "http://github.com/openbmc/phosphor-objmgr"
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
7
Matthew Barth11381c42016-10-05 16:20:54 -05008inherit autotools pkgconfig
Matthew Barth730ecb82016-11-16 10:17:02 -06009inherit obmc-phosphor-python-autotools
Brad Bishop83254dc2015-10-27 17:12:45 -040010inherit obmc-phosphor-dbus-service
11inherit obmc-phosphor-systemd
Brad Bishop83254dc2015-10-27 17:12:45 -040012
Brad Bishop5f077512016-08-07 23:18:32 -040013DEPENDS += "systemd"
Matthew Barth11381c42016-10-05 16:20:54 -050014DEPENDS += "autoconf-archive-native"
Matt Spinlera469b142017-06-08 12:35:36 -050015DEPENDS += "sdbusplus"
16DEPENDS += "phosphor-logging"
Rick Altherr68aa1402016-08-01 14:20:50 -070017
Brad Bishop59fc7e32016-11-02 15:21:22 -040018DBUS_SERVICE_${PN} += "xyz.openbmc_project.ObjectMapper.service"
Adriana Kobylakfcaf72e2017-04-11 11:06:59 -050019SYSTEMD_SERVICE_${PN} += " \
20 mapper-wait@.service \
21 mapper-subtree-remove@.service \
22 "
Matthew Barth11381c42016-10-05 16:20:54 -050023RDEPENDS_libmapper += "libsystemd"
Brad Bishop83254dc2015-10-27 17:12:45 -040024RDEPENDS_${PN} += " \
25 python-xml \
26 python-dbus \
27 python-pygobject \
Patrick Williams73f46432017-03-03 12:52:30 -060028 pyphosphor-dbus \
Matt Spinlera469b142017-06-08 12:35:36 -050029 sdbusplus \
30 phosphor-logging \
Brad Bishop83254dc2015-10-27 17:12:45 -040031 "
Chris Austenb70cb7e2015-12-02 22:32:06 -060032SRC_URI += "git://github.com/openbmc/phosphor-objmgr"
Brad Bishop83254dc2015-10-27 17:12:45 -040033
Patrick Williamsd16ae042017-06-14 02:40:06 -050034SRCREV = "f43e5d6889b4b1bfe1ec610de845eef67a0856fe"
Brad Bishop83254dc2015-10-27 17:12:45 -040035
36S = "${WORKDIR}/git"
Brad Bishopea4022a2016-07-26 15:52:01 -040037
Brad Bishopea4022a2016-07-26 15:52:01 -040038python populate_packages_prepend () {
39 mapperlibdir = d.getVar("libdir", True)
40 do_split_packages(d, mapperlibdir, '^lib(.*)\.so\.*', 'lib%s', 'Phosphor mapper %s library', extra_depends='', allow_links=True)
41}
42PACKAGES_DYNAMIC += "^libmapper.*"
43FILES_${PN}_remove = "${libdir}/lib*.so.* ${libdir}/*"