Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Target Communication Framework for the Eclipse IDE" |
| 2 | HOMEPAGE = "http://wiki.eclipse.org/TCF" |
| 3 | BUGTRACKER = "https://bugs.eclipse.org/bugs/" |
| 4 | |
| 5 | LICENSE = "EPL-1.0 | EDL-1.0" |
| 6 | LIC_FILES_CHKSUM = "file://edl-v10.html;md5=522a390a83dc186513f0500543ad3679" |
| 7 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 8 | SRCREV = "a022ef2f1acfd9209a1bf792dda14ae4b0d1b60f" |
| 9 | PV = "1.7.0+git${SRCPV}" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 10 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 11 | UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 12 | SRC_URI = "git://git.eclipse.org/gitroot/tcf/org.eclipse.tcf.agent \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 13 | file://fix_ranlib.patch \ |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 14 | file://ldflags.patch \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 15 | file://tcf-agent.init \ |
| 16 | file://tcf-agent.service \ |
| 17 | " |
| 18 | |
| 19 | DEPENDS = "util-linux openssl" |
| 20 | RDEPENDS_${PN} = "bash" |
| 21 | |
| 22 | S = "${WORKDIR}/git/agent" |
| 23 | |
| 24 | inherit update-rc.d systemd |
| 25 | |
| 26 | SYSTEMD_SERVICE_${PN} = "tcf-agent.service" |
| 27 | |
| 28 | INITSCRIPT_NAME = "tcf-agent" |
| 29 | INITSCRIPT_PARAMS = "start 99 3 5 . stop 20 0 1 2 6 ." |
| 30 | |
| 31 | # mangling needed for make |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 32 | MAKE_ARCH = "`echo ${TARGET_ARCH} | sed s,i.86,i686, | sed s,aarch64.*,a64, | sed s,armeb,arm,`" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 33 | MAKE_OS = "`echo ${TARGET_OS} | sed s,^linux.*,GNU/Linux,`" |
| 34 | |
| 35 | EXTRA_OEMAKE = "MACHINE=${MAKE_ARCH} OPSYS=${MAKE_OS} 'CC=${CC}' 'AR=${AR}'" |
| 36 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 37 | LCL_STOP_SERVICES = "-DSERVICE_RunControl=0 -DSERVICE_Breakpoints=0 \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 38 | -DSERVICE_Memory=0 -DSERVICE_Registers=0 -DSERVICE_MemoryMap=0 \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 39 | -DSERVICE_StackTrace=0 -DSERVICE_Expressions=0" |
| 40 | |
| 41 | |
| 42 | # These features don't compile for several cases. |
| 43 | # |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 44 | CFLAGS_append_arc = " ${LCL_STOP_SERVICES}" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 45 | CFLAGS_append_mips = " ${LCL_STOP_SERVICES}" |
| 46 | CFLAGS_append_mips64 = " ${LCL_STOP_SERVICES}" |
| 47 | CFLAGS_append_libc-musl = " ${LCL_STOP_SERVICES}" |
| 48 | CFLAGS_append_powerpc64 = " ${LCL_STOP_SERVICES}" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 49 | CFLAGS_append_powerpc64le = " ${LCL_STOP_SERVICES}" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 50 | CFLAGS_append_riscv64 = " ${LCL_STOP_SERVICES}" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 51 | |
| 52 | do_install() { |
| 53 | oe_runmake install INSTALLROOT=${D} |
| 54 | install -d ${D}${sysconfdir}/init.d/ |
| 55 | install -m 0755 ${WORKDIR}/tcf-agent.init ${D}${sysconfdir}/init.d/tcf-agent |
| 56 | install -d ${D}${systemd_unitdir}/system |
| 57 | install -m 0644 ${WORKDIR}/tcf-agent.service ${D}${systemd_unitdir}/system |
| 58 | sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/tcf-agent.service |
| 59 | } |
| 60 | |