blob: 77a2537698f56d2d53a8bfced8dd96b00f510842 [file] [log] [blame]
Brad Bishop5f9be072016-06-27 14:53:52 -04001SUMMARY = "OpenBMC gdbus library"
2DESCRIPTION = "libopenbmc_intf provides a set of gpio access \
3methods and the GDBUS skeleton code for the org.openbmc DBUS API."
4PR = "r1"
Patrick Venture78882612018-10-23 08:59:23 -07005PV = "1.0+git${SRCPV}"
Brad Bishop5f9be072016-06-27 14:53:52 -04006
7inherit skeleton
Saqib Khan02917df2017-11-13 10:47:54 -06008inherit pkgconfig
Brad Bishop5f9be072016-06-27 14:53:52 -04009
10DEPENDS += "glib-2.0"
Matt Spinler71c1c922018-08-07 16:35:19 -050011DEPENDS += "cjson"
Brad Bishop5f9be072016-06-27 14:53:52 -040012
13SKELETON_DIR = "libopenbmc_intf"
14
Matt Spinler71c1c922018-08-07 16:35:19 -050015SRC_URI += "file://gpio_defs.json"
16
Andrew Geisslere3817542020-07-14 13:41:21 -050017# Users of libopenbmc_intf use custom makefiles that do not
18# support the proper library version detection and linking.
19# Because of that, a link must be created within the
20# rootfs for applicaitons to use this library.
21# This next line tells bitbake to skip the check which
22# ensures no links are put in the rootfs
Patrick Williams12fc9392021-08-06 09:16:53 -050023INSANE_SKIP:${PN} += "dev-so"
Andrew Geisslere3817542020-07-14 13:41:21 -050024
25# Ensure the library is not in the dev package
26FILES_SOLIBSDEV = ""
27
28# Now add the link to the production package
Patrick Williams12fc9392021-08-06 09:16:53 -050029FILES:${PN} += "${libdir}/libopenbmc_intf.so"
Andrew Geisslere3817542020-07-14 13:41:21 -050030
Brad Bishop5f9be072016-06-27 14:53:52 -040031do_install() {
32 oe_runmake install DESTDIR=${D}
Matt Spinler71c1c922018-08-07 16:35:19 -050033
34 install -d ${D}${sysconfdir}/default/obmc/gpio/
35 install -m 0644 ${WORKDIR}/gpio_defs.json ${D}/${sysconfdir}/default/obmc/gpio/
Brad Bishop5f9be072016-06-27 14:53:52 -040036}