blob: bd9cdd25b3c336b893b47e8fe62d4c8a657481ed [file] [log] [blame]
vishwabmc2ac6f932015-10-09 15:51:50 +05301SUMMARY = "Phosphor OpenBMC IPMI daemon"
2DESCRIPTION = "Phosphor OpenBMC IPMI router and plugin libraries"
vishwabmc2ac6f932015-10-09 15:51:50 +05303PR = "r1"
4
Brad Bishop8fffc162016-08-19 09:02:54 -05005RRECOMMENDS_${PN} += "packagegroup-obmc-ipmid-providers-libs"
Chris Austen9d3325a2015-10-24 19:34:11 -05006
Matthew Barth6b136a42016-08-16 16:51:35 -05007inherit autotools pkgconfig
Patrick Venturecb675692017-12-22 14:36:07 -08008inherit obmc-phosphor-ipmiprovider-symlink
vishwabmc2ac6f932015-10-09 15:51:50 +05309inherit obmc-phosphor-license
Patrick Williams89b11a12015-10-15 15:20:20 -050010inherit obmc-phosphor-sdbus-service
Patrick Venturecb675692017-12-22 14:36:07 -080011inherit obmc-phosphor-systemd
Ratan Gupta3aa591f2017-03-06 17:05:11 +053012inherit phosphor-ipmi-host
13inherit pythonnative
vishwabmc2ac6f932015-10-09 15:51:50 +053014
Patrick Venturecb675692017-12-22 14:36:07 -080015DEPENDS += "autoconf-archive-native"
16DEPENDS += "obmc-targets"
17DEPENDS += "packagegroup-obmc-ipmid-providers"
18DEPENDS += "phosphor-dbus-interfaces"
Adriana Kobylakc009f892017-02-17 08:21:42 -060019DEPENDS += "phosphor-logging"
Brad Bishop12e3d602016-10-05 20:10:23 -040020DEPENDS += "phosphor-mapper"
Ratan Guptaca8fd9d2017-03-20 18:20:47 +053021DEPENDS += "sdbusplus"
Patrick Venturecb675692017-12-22 14:36:07 -080022DEPENDS += "sdbus++-native"
Tom Josephcf7e8492017-05-08 11:49:10 +053023DEPENDS += "virtual/phosphor-ipmi-inventory-sel"
Marri Devender Rao53c55032017-07-26 02:11:32 -050024DEPENDS += "virtual/phosphor-ipmi-fru-merge-config"
Patrick Venturecb675692017-12-22 14:36:07 -080025DEPENDS += "virtual/phosphor-ipmi-sensor-inventory"
Ratan Gupta3aa591f2017-03-06 17:05:11 +053026
Adriana Kobylakc009f892017-02-17 08:21:42 -060027RDEPENDS_${PN}-dev += "phosphor-logging"
Brad Bishop12e3d602016-10-05 20:10:23 -040028RDEPENDS_${PN}-dev += "phosphor-mapper-dev"
Milton D. Miller IIb8c51742016-03-04 15:29:29 -060029RDEPENDS_${PN} += "clear-once"
Brad Bishopea4022a2016-07-26 15:52:01 -040030RDEPENDS_${PN} += "libmapper"
Patrick Venturecb675692017-12-22 14:36:07 -080031RDEPENDS_${PN} += "network"
32RDEPENDS_${PN} += "phosphor-dbus-interfaces"
33RDEPENDS_${PN} += "phosphor-mapper"
Vishwanatha Subbannab1c39e02016-11-10 21:52:46 +053034RDEPENDS_${PN} += "phosphor-time-manager"
Patrick Venturecb675692017-12-22 14:36:07 -080035RDEPENDS_${PN} += "sdbusplus"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053036RDEPENDS_${PN} += "virtual/obmc-watchdog"
Ratan Guptaca8fd9d2017-03-20 18:20:47 +053037
Vishwanatha Subbannacaff3fa2017-03-31 14:41:11 +053038SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service phosphor-ipmi-host.service"
39
Adriana Kobylak1ffadd92016-08-25 10:07:34 -050040RRECOMMENDS_${PN} += "virtual-obmc-settings-mgmt"
vishwabmc2ac6f932015-10-09 15:51:50 +053041
Marri Devender Rao2ba514e2017-06-08 00:47:54 -050042require ${PN}.inc
Chris Austen9d3325a2015-10-24 19:34:11 -050043
Tom Joseph1562bbc2017-02-20 12:01:43 +053044# Setup IPMI Whitelist Conf files
45WHITELIST_CONF = " \
Patrick Williams43b61b72017-02-24 13:04:06 -060046 ${STAGING_DATADIR_NATIVE}/phosphor-ipmi-host/*.conf \
Tom Joseph1562bbc2017-02-20 12:01:43 +053047 ${S}/host-ipmid-whitelist.conf \
48 "
49EXTRA_OECONF = " \
50 WHITELIST_CONF="${WHITELIST_CONF}" \
Ratan Gupta3aa591f2017-03-06 17:05:11 +053051 SENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/sensor.yaml \
Tom Josephcf7e8492017-05-08 11:49:10 +053052 INVSENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/invsensor.yaml \
Marri Devender Rao53c55032017-07-26 02:11:32 -050053 FRU_YAML_GEN=${STAGING_DIR_NATIVE}${config_datadir}/fru_config.yaml \
Tom Joseph1562bbc2017-02-20 12:01:43 +053054 "
55
vishwabmc2ac6f932015-10-09 15:51:50 +053056S = "${WORKDIR}/git"
57
Dhruvaraj Subhashchandran12352762017-08-04 16:09:15 -050058SRC_URI += "file://merge_yamls.py"
59
Tom Josephdcdc8ea2017-02-01 19:47:27 +053060HOSTIPMI_PROVIDER_LIBRARY += "libapphandler.so"
Tom Josephdcdc8ea2017-02-01 19:47:27 +053061HOSTIPMI_PROVIDER_LIBRARY += "libsysintfcmds.so"
62
63NETIPMI_PROVIDER_LIBRARY += "libapphandler.so"
64
Matthew Barth6b136a42016-08-16 16:51:35 -050065FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
Patrick Venturecb675692017-12-22 14:36:07 -080066FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
Tom Josephdcdc8ea2017-02-01 19:47:27 +053067FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
68FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
Brad Bishop6371e702016-09-06 13:03:39 -040069
Andrew Geissler41e3cb32017-01-04 11:11:50 -060070# Soft Power Off
Andrew Geisslerecfa6622017-05-11 16:16:27 -050071# install the soft power off service in the host shutdown target
72SOFT_SVC = "xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service"
73SOFT_TGTFMT = "obmc-host-shutdown@{0}.target"
74SOFT_FMT = "../${SOFT_SVC}:${SOFT_TGTFMT}.requires/${SOFT_SVC}"
75SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'SOFT_FMT', 'OBMC_HOST_INSTANCES')}"
Dhruvaraj Subhashchandran12352762017-08-04 16:09:15 -050076
77#Collect all hardcoded sensor yamls from different recipes and
78#merge all of them with sensor.yaml.
79python do_merge_sensors () {
80 import subprocess
81
82 # TODO: Perform the merge in a temporary directory?
83 workdir = d.getVar('WORKDIR', True)
84 nativedir = d.getVar('STAGING_DIR_NATIVE', True)
85 sensorsdir = d.getVar('sensor_datadir', True)
86 sensorsdir = sensorsdir[1:]
87 sensorsdir = os.path.join(nativedir, sensorsdir)
88 cmd = []
89 cmd.append(os.path.join(workdir, 'merge_yamls.py'))
90 cmd.append(os.path.join(sensorsdir, 'sensor.yaml'))
91
92 if os.stat(os.path.join(sensorsdir, 'sensor.yaml')).st_size == 0:
93 return
94 fetch = bb.fetch2.Fetch([], d)
Kun Yicdc3b232017-10-09 23:17:08 -070095 override_urls = [url for url in fetch.urls if url.endswith('.hardcoded.yaml')]
Dhruvaraj Subhashchandran12352762017-08-04 16:09:15 -050096 for url in override_urls:
97 bb.debug(2, 'Overriding with source: ' + url)
98 local_base = os.path.basename(fetch.localpath(url))
99 filename = os.path.join(workdir, local_base)
100 cmd.append(filename)
101
102 # Invoke the script and don't catch any resulting exception.
103 subprocess.check_call(cmd)
104}
105# python-pyyaml-native is installed by do_configure, so put this task after
106addtask merge_sensors after do_configure before do_compile