blob: 112ee3379d36124b321803316f7e011c7b166c90 [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001# This class is used to check recipes against public CVEs.
2#
3# In order to use this class just inherit the class in the
4# local.conf file and it will add the cve_check task for
5# every recipe. The task can be used per recipe, per image,
6# or using the special cases "world" and "universe". The
7# cve_check task will print a warning for every unpatched
8# CVE found and generate a file in the recipe WORKDIR/cve
9# directory. If an image is build it will generate a report
10# in DEPLOY_DIR_IMAGE for all the packages used.
11#
12# Example:
13# bitbake -c cve_check openssl
14# bitbake core-image-sato
15# bitbake -k -c cve_check universe
16#
17# DISCLAIMER
18#
19# This class/tool is meant to be used as support and not
20# the only method to check against CVEs. Running this tool
21# doesn't guarantee your packages are free of CVEs.
22
Brad Bishop37a0e4d2017-12-04 01:01:44 -050023# The product name that the CVE database uses. Defaults to BPN, but may need to
24# be overriden per recipe (for example tiff.bb sets CVE_PRODUCT=libtiff).
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025CVE_PRODUCT ??= "${BPN}"
Brad Bishop316dfdd2018-06-25 12:45:53 -040026CVE_VERSION ??= "${PV}"
Brad Bishop37a0e4d2017-12-04 01:01:44 -050027
Patrick Williamsc0f7c042017-02-23 20:41:17 -060028CVE_CHECK_DB_DIR ?= "${DL_DIR}/CVE_CHECK"
Andrew Geissler82c905d2020-04-13 13:39:40 -050029CVE_CHECK_DB_FILE ?= "${CVE_CHECK_DB_DIR}/nvdcve_1.1.db"
Andrew Geisslerc9f78652020-09-18 14:11:35 -050030CVE_CHECK_DB_FILE_LOCK ?= "${CVE_CHECK_DB_FILE}.lock"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060031
Brad Bishop316dfdd2018-06-25 12:45:53 -040032CVE_CHECK_LOG ?= "${T}/cve.log"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060033CVE_CHECK_TMP_FILE ?= "${TMPDIR}/cve_check"
Andrew Geisslerb7d28612020-07-24 16:15:54 -050034CVE_CHECK_SUMMARY_DIR ?= "${LOG_DIR}/cve"
35CVE_CHECK_SUMMARY_FILE_NAME ?= "cve-summary"
36CVE_CHECK_SUMMARY_FILE ?= "${CVE_CHECK_SUMMARY_DIR}/${CVE_CHECK_SUMMARY_FILE_NAME}"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060037
38CVE_CHECK_DIR ??= "${DEPLOY_DIR}/cve"
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050039CVE_CHECK_RECIPE_FILE ?= "${CVE_CHECK_DIR}/${PN}"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060040CVE_CHECK_MANIFEST ?= "${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}${IMAGE_NAME_SUFFIX}.cve"
41CVE_CHECK_COPY_FILES ??= "1"
42CVE_CHECK_CREATE_MANIFEST ??= "1"
43
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050044CVE_CHECK_REPORT_PATCHED ??= "1"
45
Patrick Williamsc0f7c042017-02-23 20:41:17 -060046# Whitelist for packages (PN)
Brad Bishop96ff1982019-08-19 13:50:42 -040047CVE_CHECK_PN_WHITELIST ?= ""
Patrick Williamsc0f7c042017-02-23 20:41:17 -060048
Brad Bishop96ff1982019-08-19 13:50:42 -040049# Whitelist for CVE. If a CVE is found, then it is considered patched.
50# The value is a string containing space separated CVE values:
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050051#
Brad Bishop96ff1982019-08-19 13:50:42 -040052# CVE_CHECK_WHITELIST = 'CVE-2014-2524 CVE-2018-1234'
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050053#
Brad Bishop96ff1982019-08-19 13:50:42 -040054CVE_CHECK_WHITELIST ?= ""
Patrick Williamsc0f7c042017-02-23 20:41:17 -060055
Andrew Geisslerd1e89492021-02-12 15:35:20 -060056# Layers to be excluded
57CVE_CHECK_LAYER_EXCLUDELIST ??= ""
58
59# Layers to be included
60CVE_CHECK_LAYER_INCLUDELIST ??= ""
61
62
63# set to "alphabetical" for version using single alphabetical character as increament release
64CVE_VERSION_SUFFIX ??= ""
65
Andrew Geisslerb7d28612020-07-24 16:15:54 -050066python cve_save_summary_handler () {
67 import shutil
68 import datetime
69
70 cve_tmp_file = d.getVar("CVE_CHECK_TMP_FILE")
71
72 cve_summary_name = d.getVar("CVE_CHECK_SUMMARY_FILE_NAME")
73 cvelogpath = d.getVar("CVE_CHECK_SUMMARY_DIR")
74 bb.utils.mkdirhier(cvelogpath)
75
76 timestamp = datetime.datetime.now().strftime('%Y%m%d%H%M%S')
77 cve_summary_file = os.path.join(cvelogpath, "%s-%s.txt" % (cve_summary_name, timestamp))
78
Andrew Geisslerc9f78652020-09-18 14:11:35 -050079 if os.path.exists(cve_tmp_file):
80 shutil.copyfile(cve_tmp_file, cve_summary_file)
Andrew Geisslerb7d28612020-07-24 16:15:54 -050081
Andrew Geisslerc9f78652020-09-18 14:11:35 -050082 if cve_summary_file and os.path.exists(cve_summary_file):
83 cvefile_link = os.path.join(cvelogpath, cve_summary_name)
Andrew Geisslerb7d28612020-07-24 16:15:54 -050084
Andrew Geisslerc9f78652020-09-18 14:11:35 -050085 if os.path.exists(os.path.realpath(cvefile_link)):
86 os.remove(cvefile_link)
87 os.symlink(os.path.basename(cve_summary_file), cvefile_link)
Andrew Geisslerb7d28612020-07-24 16:15:54 -050088}
89
90addhandler cve_save_summary_handler
91cve_save_summary_handler[eventmask] = "bb.event.BuildCompleted"
92
Patrick Williamsc0f7c042017-02-23 20:41:17 -060093python do_cve_check () {
94 """
95 Check recipe for patched and unpatched CVEs
96 """
97
Brad Bishop96ff1982019-08-19 13:50:42 -040098 if os.path.exists(d.getVar("CVE_CHECK_DB_FILE")):
Andrew Geissler82c905d2020-04-13 13:39:40 -050099 try:
100 patched_cves = get_patches_cves(d)
101 except FileNotFoundError:
102 bb.fatal("Failure in searching patches")
103 whitelisted, patched, unpatched = check_cves(d, patched_cves)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600104 if patched or unpatched:
105 cve_data = get_cve_info(d, patched + unpatched)
Andrew Geissler82c905d2020-04-13 13:39:40 -0500106 cve_write_data(d, patched, unpatched, whitelisted, cve_data)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600107 else:
Brad Bishop96ff1982019-08-19 13:50:42 -0400108 bb.note("No CVE database found, skipping CVE check")
109
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600110}
111
Andrew Geissler1e34c2d2020-05-29 16:02:59 -0500112addtask cve_check before do_build after do_fetch
Andrew Geisslerc9f78652020-09-18 14:11:35 -0500113do_cve_check[depends] = "cve-update-db-native:do_fetch"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600114do_cve_check[nostamp] = "1"
115
116python cve_check_cleanup () {
117 """
118 Delete the file used to gather all the CVE information.
119 """
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500120 bb.utils.remove(e.data.getVar("CVE_CHECK_TMP_FILE"))
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600121}
122
123addhandler cve_check_cleanup
124cve_check_cleanup[eventmask] = "bb.cooker.CookerExit"
125
126python cve_check_write_rootfs_manifest () {
127 """
128 Create CVE manifest when building an image
129 """
130
131 import shutil
132
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500133 if d.getVar("CVE_CHECK_COPY_FILES") == "1":
Andrew Geisslerc3d88e42020-10-02 09:45:00 -0500134 deploy_file = d.getVar("CVE_CHECK_RECIPE_FILE")
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500135 if os.path.exists(deploy_file):
136 bb.utils.remove(deploy_file)
137
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500138 if os.path.exists(d.getVar("CVE_CHECK_TMP_FILE")):
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600139 bb.note("Writing rootfs CVE manifest")
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500140 deploy_dir = d.getVar("DEPLOY_DIR_IMAGE")
141 link_name = d.getVar("IMAGE_LINK_NAME")
142 manifest_name = d.getVar("CVE_CHECK_MANIFEST")
143 cve_tmp_file = d.getVar("CVE_CHECK_TMP_FILE")
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600144
145 shutil.copyfile(cve_tmp_file, manifest_name)
146
147 if manifest_name and os.path.exists(manifest_name):
148 manifest_link = os.path.join(deploy_dir, "%s.cve" % link_name)
149 # If we already have another manifest, update symlinks
150 if os.path.exists(os.path.realpath(manifest_link)):
151 os.remove(manifest_link)
152 os.symlink(os.path.basename(manifest_name), manifest_link)
153 bb.plain("Image CVE report stored in: %s" % manifest_name)
154}
155
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500156ROOTFS_POSTPROCESS_COMMAND_prepend = "${@'cve_check_write_rootfs_manifest; ' if d.getVar('CVE_CHECK_CREATE_MANIFEST') == '1' else ''}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500157do_rootfs[recrdeptask] += "${@'do_cve_check' if d.getVar('CVE_CHECK_CREATE_MANIFEST') == '1' else ''}"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600158
159def get_patches_cves(d):
160 """
161 Get patches that solve CVEs using the "CVE: " tag.
162 """
163
164 import re
165
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500166 pn = d.getVar("PN")
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600167 cve_match = re.compile("CVE:( CVE\-\d{4}\-\d+)+")
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500168
169 # Matches last CVE-1234-211432 in the file name, also if written
170 # with small letters. Not supporting multiple CVE id's in a single
171 # file name.
172 cve_file_name_match = re.compile(".*([Cc][Vv][Ee]\-\d{4}\-\d+)")
173
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600174 patched_cves = set()
175 bb.debug(2, "Looking for patches that solves CVEs for %s" % pn)
176 for url in src_patches(d):
177 patch_file = bb.fetch.decodeurl(url)[2]
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500178
Andrew Geissler82c905d2020-04-13 13:39:40 -0500179 if not os.path.isfile(patch_file):
180 bb.error("File Not found: %s" % patch_file)
181 raise FileNotFoundError
182
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500183 # Check patch file name for CVE ID
184 fname_match = cve_file_name_match.search(patch_file)
185 if fname_match:
186 cve = fname_match.group(1).upper()
187 patched_cves.add(cve)
188 bb.debug(2, "Found CVE %s from patch file name %s" % (cve, patch_file))
189
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600190 with open(patch_file, "r", encoding="utf-8") as f:
191 try:
192 patch_text = f.read()
193 except UnicodeDecodeError:
194 bb.debug(1, "Failed to read patch %s using UTF-8 encoding"
195 " trying with iso8859-1" % patch_file)
196 f.close()
197 with open(patch_file, "r", encoding="iso8859-1") as f:
198 patch_text = f.read()
199
Brad Bishopbba38f32018-08-23 16:11:46 +0800200 # Search for one or more "CVE: " lines
201 text_match = False
202 for match in cve_match.finditer(patch_text):
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600203 # Get only the CVEs without the "CVE: " tag
204 cves = patch_text[match.start()+5:match.end()]
205 for cve in cves.split():
206 bb.debug(2, "Patch %s solves %s" % (patch_file, cve))
207 patched_cves.add(cve)
Brad Bishopbba38f32018-08-23 16:11:46 +0800208 text_match = True
209
210 if not fname_match and not text_match:
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600211 bb.debug(2, "Patch %s doesn't solve CVEs" % patch_file)
212
213 return patched_cves
214
215def check_cves(d, patched_cves):
216 """
Brad Bishopf3fd2882019-06-21 08:06:37 -0400217 Connect to the NVD database and find unpatched cves.
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600218 """
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600219 from oe.cve_check import Version
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600220
Andrew Geissler6ce62a22020-11-30 19:58:47 -0600221 pn = d.getVar("PN")
222 real_pv = d.getVar("PV")
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600223 suffix = d.getVar("CVE_VERSION_SUFFIX")
Andrew Geissler6ce62a22020-11-30 19:58:47 -0600224
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600225 cves_unpatched = []
Brad Bishopf3fd2882019-06-21 08:06:37 -0400226 # CVE_PRODUCT can contain more than one product (eg. curl/libcurl)
Brad Bishop96ff1982019-08-19 13:50:42 -0400227 products = d.getVar("CVE_PRODUCT").split()
Brad Bishop316dfdd2018-06-25 12:45:53 -0400228 # If this has been unset then we're not scanning for CVEs here (for example, image recipes)
Brad Bishop96ff1982019-08-19 13:50:42 -0400229 if not products:
Andrew Geissler82c905d2020-04-13 13:39:40 -0500230 return ([], [], [])
Brad Bishop316dfdd2018-06-25 12:45:53 -0400231 pv = d.getVar("CVE_VERSION").split("+git")[0]
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600232
233 # If the recipe has been whitlisted we return empty lists
Andrew Geissler6ce62a22020-11-30 19:58:47 -0600234 if pn in d.getVar("CVE_CHECK_PN_WHITELIST").split():
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600235 bb.note("Recipe has been whitelisted, skipping check")
Andrew Geissler82c905d2020-04-13 13:39:40 -0500236 return ([], [], [])
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600237
Brad Bishop96ff1982019-08-19 13:50:42 -0400238 old_cve_whitelist = d.getVar("CVE_CHECK_CVE_WHITELIST")
239 if old_cve_whitelist:
240 bb.warn("CVE_CHECK_CVE_WHITELIST is deprecated, please use CVE_CHECK_WHITELIST.")
241 cve_whitelist = d.getVar("CVE_CHECK_WHITELIST").split()
242
Brad Bishopf3fd2882019-06-21 08:06:37 -0400243 import sqlite3
Brad Bishop6dbb3162019-11-25 09:41:34 -0500244 db_file = d.expand("file:${CVE_CHECK_DB_FILE}?mode=ro")
245 conn = sqlite3.connect(db_file, uri=True)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600246
Brad Bishop6dbb3162019-11-25 09:41:34 -0500247 # For each of the known product names (e.g. curl has CPEs using curl and libcurl)...
Brad Bishop96ff1982019-08-19 13:50:42 -0400248 for product in products:
Brad Bishop96ff1982019-08-19 13:50:42 -0400249 if ":" in product:
250 vendor, product = product.split(":", 1)
Brad Bishop96ff1982019-08-19 13:50:42 -0400251 else:
Brad Bishop6dbb3162019-11-25 09:41:34 -0500252 vendor = "%"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600253
Brad Bishop6dbb3162019-11-25 09:41:34 -0500254 # Find all relevant CVE IDs.
255 for cverow in conn.execute("SELECT DISTINCT ID FROM PRODUCTS WHERE PRODUCT IS ? AND VENDOR LIKE ?", (product, vendor)):
256 cve = cverow[0]
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600257
Brad Bishop96ff1982019-08-19 13:50:42 -0400258 if cve in cve_whitelist:
259 bb.note("%s-%s has been whitelisted for %s" % (product, pv, cve))
Brad Bishop64c979e2019-11-04 13:55:29 -0500260 # TODO: this should be in the report as 'whitelisted'
261 patched_cves.add(cve)
Brad Bishop6dbb3162019-11-25 09:41:34 -0500262 continue
Brad Bishopf3fd2882019-06-21 08:06:37 -0400263 elif cve in patched_cves:
264 bb.note("%s has been patched" % (cve))
Brad Bishop6dbb3162019-11-25 09:41:34 -0500265 continue
266
267 vulnerable = False
268 for row in conn.execute("SELECT * FROM PRODUCTS WHERE ID IS ? AND PRODUCT IS ? AND VENDOR LIKE ?", (cve, product, vendor)):
269 (_, _, _, version_start, operator_start, version_end, operator_end) = row
270 #bb.debug(2, "Evaluating row " + str(row))
271
Andrew Geissler82c905d2020-04-13 13:39:40 -0500272 if (operator_start == '=' and pv == version_start) or version_start == '-':
Brad Bishop6dbb3162019-11-25 09:41:34 -0500273 vulnerable = True
Brad Bishop96ff1982019-08-19 13:50:42 -0400274 else:
275 if operator_start:
276 try:
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600277 vulnerable_start = (operator_start == '>=' and Version(pv,suffix) >= Version(version_start,suffix))
278 vulnerable_start |= (operator_start == '>' and Version(pv,suffix) > Version(version_start,suffix))
Brad Bishop96ff1982019-08-19 13:50:42 -0400279 except:
Brad Bishop64c979e2019-11-04 13:55:29 -0500280 bb.warn("%s: Failed to compare %s %s %s for %s" %
Brad Bishop96ff1982019-08-19 13:50:42 -0400281 (product, pv, operator_start, version_start, cve))
Brad Bishop6dbb3162019-11-25 09:41:34 -0500282 vulnerable_start = False
Brad Bishop96ff1982019-08-19 13:50:42 -0400283 else:
Brad Bishop6dbb3162019-11-25 09:41:34 -0500284 vulnerable_start = False
Brad Bishop96ff1982019-08-19 13:50:42 -0400285
286 if operator_end:
287 try:
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600288 vulnerable_end = (operator_end == '<=' and Version(pv,suffix) <= Version(version_end,suffix) )
289 vulnerable_end |= (operator_end == '<' and Version(pv,suffix) < Version(version_end,suffix) )
Brad Bishop96ff1982019-08-19 13:50:42 -0400290 except:
Brad Bishop64c979e2019-11-04 13:55:29 -0500291 bb.warn("%s: Failed to compare %s %s %s for %s" %
Brad Bishop96ff1982019-08-19 13:50:42 -0400292 (product, pv, operator_end, version_end, cve))
Brad Bishop6dbb3162019-11-25 09:41:34 -0500293 vulnerable_end = False
Brad Bishop96ff1982019-08-19 13:50:42 -0400294 else:
Brad Bishop6dbb3162019-11-25 09:41:34 -0500295 vulnerable_end = False
Brad Bishop96ff1982019-08-19 13:50:42 -0400296
297 if operator_start and operator_end:
Brad Bishop6dbb3162019-11-25 09:41:34 -0500298 vulnerable = vulnerable_start and vulnerable_end
Brad Bishop96ff1982019-08-19 13:50:42 -0400299 else:
Brad Bishop6dbb3162019-11-25 09:41:34 -0500300 vulnerable = vulnerable_start or vulnerable_end
Brad Bishop96ff1982019-08-19 13:50:42 -0400301
Brad Bishop6dbb3162019-11-25 09:41:34 -0500302 if vulnerable:
Andrew Geissler6ce62a22020-11-30 19:58:47 -0600303 bb.note("%s-%s is vulnerable to %s" % (pn, real_pv, cve))
Brad Bishop96ff1982019-08-19 13:50:42 -0400304 cves_unpatched.append(cve)
Brad Bishop6dbb3162019-11-25 09:41:34 -0500305 break
306
307 if not vulnerable:
Andrew Geissler6ce62a22020-11-30 19:58:47 -0600308 bb.note("%s-%s is not vulnerable to %s" % (pn, real_pv, cve))
Brad Bishop6dbb3162019-11-25 09:41:34 -0500309 # TODO: not patched but not vulnerable
310 patched_cves.add(cve)
311
Brad Bishopf3fd2882019-06-21 08:06:37 -0400312 conn.close()
313
Andrew Geissler82c905d2020-04-13 13:39:40 -0500314 return (list(cve_whitelist), list(patched_cves), cves_unpatched)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600315
316def get_cve_info(d, cves):
317 """
Brad Bishop96ff1982019-08-19 13:50:42 -0400318 Get CVE information from the database.
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600319 """
320
Brad Bishop6dbb3162019-11-25 09:41:34 -0500321 import sqlite3
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600322
323 cve_data = {}
Brad Bishop6dbb3162019-11-25 09:41:34 -0500324 conn = sqlite3.connect(d.getVar("CVE_CHECK_DB_FILE"))
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600325
Brad Bishop6dbb3162019-11-25 09:41:34 -0500326 for cve in cves:
327 for row in conn.execute("SELECT * FROM NVD WHERE ID IS ?", (cve,)):
328 cve_data[row[0]] = {}
329 cve_data[row[0]]["summary"] = row[1]
330 cve_data[row[0]]["scorev2"] = row[2]
331 cve_data[row[0]]["scorev3"] = row[3]
332 cve_data[row[0]]["modified"] = row[4]
333 cve_data[row[0]]["vector"] = row[5]
334
335 conn.close()
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600336 return cve_data
337
Andrew Geissler82c905d2020-04-13 13:39:40 -0500338def cve_write_data(d, patched, unpatched, whitelisted, cve_data):
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600339 """
340 Write CVE information in WORKDIR; and to CVE_CHECK_DIR, and
341 CVE manifest if enabled.
342 """
343
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600344
Brad Bishop316dfdd2018-06-25 12:45:53 -0400345 cve_file = d.getVar("CVE_CHECK_LOG")
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600346 fdir_name = d.getVar("FILE_DIRNAME")
347 layer = fdir_name.split("/")[-3]
348
349 include_layers = d.getVar("CVE_CHECK_LAYER_INCLUDELIST").split()
350 exclude_layers = d.getVar("CVE_CHECK_LAYER_EXCLUDELIST").split()
351
352 if exclude_layers and layer in exclude_layers:
353 return
354
355 if include_layers and layer not in include_layers:
356 return
357
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600358 nvd_link = "https://web.nvd.nist.gov/view/vuln/detail?vulnId="
359 write_string = ""
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500360 unpatched_cves = []
Brad Bishop316dfdd2018-06-25 12:45:53 -0400361 bb.utils.mkdirhier(os.path.dirname(cve_file))
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600362
363 for cve in sorted(cve_data):
Andrew Geisslerc3d88e42020-10-02 09:45:00 -0500364 is_patched = cve in patched
365 if is_patched and (d.getVar("CVE_CHECK_REPORT_PATCHED") != "1"):
366 continue
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600367 write_string += "LAYER: %s\n" % layer
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500368 write_string += "PACKAGE NAME: %s\n" % d.getVar("PN")
Andrew Geissler4ed12e12020-06-05 18:00:41 -0500369 write_string += "PACKAGE VERSION: %s%s\n" % (d.getVar("EXTENDPE"), d.getVar("PV"))
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600370 write_string += "CVE: %s\n" % cve
Andrew Geissler82c905d2020-04-13 13:39:40 -0500371 if cve in whitelisted:
372 write_string += "CVE STATUS: Whitelisted\n"
Andrew Geisslerc3d88e42020-10-02 09:45:00 -0500373 elif is_patched:
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600374 write_string += "CVE STATUS: Patched\n"
375 else:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500376 unpatched_cves.append(cve)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600377 write_string += "CVE STATUS: Unpatched\n"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600378 write_string += "CVE SUMMARY: %s\n" % cve_data[cve]["summary"]
Brad Bishopf3fd2882019-06-21 08:06:37 -0400379 write_string += "CVSS v2 BASE SCORE: %s\n" % cve_data[cve]["scorev2"]
380 write_string += "CVSS v3 BASE SCORE: %s\n" % cve_data[cve]["scorev3"]
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600381 write_string += "VECTOR: %s\n" % cve_data[cve]["vector"]
382 write_string += "MORE INFORMATION: %s%s\n\n" % (nvd_link, cve)
383
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500384 if unpatched_cves:
385 bb.warn("Found unpatched CVE (%s), for more information check %s" % (" ".join(unpatched_cves),cve_file))
386
Andrew Geisslerc3d88e42020-10-02 09:45:00 -0500387 if write_string:
388 with open(cve_file, "w") as f:
389 bb.note("Writing file %s with CVE information" % cve_file)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600390 f.write(write_string)
391
Andrew Geisslerc3d88e42020-10-02 09:45:00 -0500392 if d.getVar("CVE_CHECK_COPY_FILES") == "1":
393 deploy_file = d.getVar("CVE_CHECK_RECIPE_FILE")
394 bb.utils.mkdirhier(os.path.dirname(deploy_file))
395 with open(deploy_file, "w") as f:
396 f.write(write_string)
Andrew Geisslerb7d28612020-07-24 16:15:54 -0500397
Andrew Geisslerc3d88e42020-10-02 09:45:00 -0500398 if d.getVar("CVE_CHECK_CREATE_MANIFEST") == "1":
399 cvelogpath = d.getVar("CVE_CHECK_SUMMARY_DIR")
400 bb.utils.mkdirhier(cvelogpath)
401
402 with open(d.getVar("CVE_CHECK_TMP_FILE"), "a") as f:
403 f.write("%s" % write_string)