Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 1 | SUMMARY = "Socket-based service activation daemon" |
| 2 | HOMEPAGE = "https://github.com/xinetd-org/xinetd" |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 3 | DESCRIPTION = "xinetd is a powerful replacement for inetd, xinetd has access control mechanisms, extensive logging capabilities, the ability to make services available based on time, can place limits on the number of servers that can be started, and has deployable defence mechanisms to protect against port scanners, among other things." |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 4 | |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 5 | LICENSE = "xinetd" |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=55c5fdf02cfcca3fc9621b6f2ceae10f" |
| 7 | |
| 8 | UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)" |
| 9 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 10 | SRC_URI = "git://github.com/openSUSE/xinetd.git;protocol=https;branch=master \ |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 11 | file://xinetd.init \ |
| 12 | file://xinetd.default \ |
| 13 | file://xinetd.service \ |
| 14 | " |
| 15 | |
| 16 | SRCREV = "6a4af7786630ce48747d9687e2f18f45ea6684c4" |
| 17 | |
| 18 | S = "${WORKDIR}/git" |
| 19 | |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 20 | # https://github.com/xinetd-org/xinetd/pull/10 is merged into this git tree revision |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 21 | CVE_STATUS[CVE-2013-4342] = "fixed-version: Fixed directly in git tree revision" |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 22 | |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 23 | inherit autotools update-rc.d systemd pkgconfig |
| 24 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 25 | SYSTEMD_SERVICE:${PN} = "xinetd.service" |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 26 | |
| 27 | INITSCRIPT_NAME = "xinetd" |
| 28 | INITSCRIPT_PARAMS = "defaults" |
| 29 | |
| 30 | PACKAGECONFIG ??= "tcp-wrappers" |
| 31 | PACKAGECONFIG[tcp-wrappers] = "--with-libwrap,,tcp-wrappers" |
| 32 | |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 33 | CFLAGS += "-D_GNU_SOURCE" |
| 34 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 35 | CONFFILES:${PN} = "${sysconfdir}/xinetd.conf" |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 36 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 37 | do_install:append() { |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 38 | install -d "${D}${sysconfdir}/init.d" |
| 39 | install -d "${D}${sysconfdir}/default" |
| 40 | install -m 755 "${WORKDIR}/xinetd.init" "${D}${sysconfdir}/init.d/xinetd" |
| 41 | install -m 644 "${WORKDIR}/xinetd.default" "${D}${sysconfdir}/default/xinetd" |
| 42 | |
| 43 | # Install systemd unit files |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 44 | install -d ${D}${systemd_system_unitdir} |
| 45 | install -m 0644 ${WORKDIR}/xinetd.service ${D}${systemd_system_unitdir} |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 46 | sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \ |
| 47 | -e 's,@SBINDIR@,${sbindir},g' \ |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 48 | ${D}${systemd_system_unitdir}/xinetd.service |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 49 | } |
| 50 | |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 51 | # Script for converting inetd.conf files into xinetd.conf files |
| 52 | PACKAGES =+ "${PN}-xconv" |
| 53 | FILES:${PN}-xconv = "${bindir}/xconv.pl" |
| 54 | RDEPENDS:${PN}-xconv += "perl" |