blob: 5da369d4226f083f7e34fa8f803ebb72d2f54599 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# ex:ts=4:sw=4:sts=4:et
2# -*- tab-width: 4; c-basic-offset: 4; indent-tabs-mode: nil -*-
3#
4# This bbclass is used for creating archive for:
Andrew Geissler82c905d2020-04-13 13:39:40 -05005# 1) original (or unpacked) source: ARCHIVER_MODE[src] = "original"
6# 2) patched source: ARCHIVER_MODE[src] = "patched" (default)
7# 3) configured source: ARCHIVER_MODE[src] = "configured"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00008# 4) source mirror: ARCHIVER_MODE[src] = "mirror"
Andrew Geissler82c905d2020-04-13 13:39:40 -05009# 5) The patches between do_unpack and do_patch:
10# ARCHIVER_MODE[diff] = "1"
11# And you can set the one that you'd like to exclude from the diff:
12# ARCHIVER_MODE[diff-exclude] ?= ".pc autom4te.cache patches"
13# 6) The environment data, similar to 'bitbake -e recipe':
14# ARCHIVER_MODE[dumpdata] = "1"
15# 7) The recipe (.bb and .inc): ARCHIVER_MODE[recipe] = "1"
16# 8) Whether output the .src.rpm package:
17# ARCHIVER_MODE[srpm] = "1"
18# 9) Filter the license, the recipe whose license in
19# COPYLEFT_LICENSE_INCLUDE will be included, and in
20# COPYLEFT_LICENSE_EXCLUDE will be excluded.
21# COPYLEFT_LICENSE_INCLUDE = 'GPL* LGPL*'
22# COPYLEFT_LICENSE_EXCLUDE = 'CLOSED Proprietary'
23# 10) The recipe type that will be archived:
24# COPYLEFT_RECIPE_TYPES = 'target'
25# 11) The source mirror mode:
26# ARCHIVER_MODE[mirror] = "split" (default): Sources are split into
27# per-recipe directories in a similar way to other archiver modes.
28# Post-processing may be required to produce a single mirror directory.
29# This does however allow inspection of duplicate sources and more
30# intelligent handling.
31# ARCHIVER_MODE[mirror] = "combined": All sources are placed into a single
32# directory suitable for direct use as a mirror. Duplicate sources are
33# ignored.
34# 12) Source mirror exclusions:
35# ARCHIVER_MIRROR_EXCLUDE is a list of prefixes to exclude from the mirror.
36# This may be used for sources which you are already publishing yourself
37# (e.g. if the URI starts with 'https://mysite.com/' and your mirror is
38# going to be published to the same site). It may also be used to exclude
39# local files (with the prefix 'file://') if these will be provided as part
40# of an archive of the layers themselves.
Patrick Williamsc124f4f2015-09-15 14:41:29 -050041#
42
Patrick Williamsc124f4f2015-09-15 14:41:29 -050043# Create archive for all the recipe types
44COPYLEFT_RECIPE_TYPES ?= 'target native nativesdk cross crosssdk cross-canadian'
45inherit copyleft_filter
46
47ARCHIVER_MODE[srpm] ?= "0"
48ARCHIVER_MODE[src] ?= "patched"
49ARCHIVER_MODE[diff] ?= "0"
50ARCHIVER_MODE[diff-exclude] ?= ".pc autom4te.cache patches"
51ARCHIVER_MODE[dumpdata] ?= "0"
52ARCHIVER_MODE[recipe] ?= "0"
Andrew Geissler82c905d2020-04-13 13:39:40 -050053ARCHIVER_MODE[mirror] ?= "split"
Andrew Geissler595f6302022-01-24 19:11:47 +000054ARCHIVER_MODE[compression] ?= "xz"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050055
56DEPLOY_DIR_SRC ?= "${DEPLOY_DIR}/sources"
Andrew Geisslerf0343792020-11-18 10:42:21 -060057ARCHIVER_TOPDIR ?= "${WORKDIR}/archiver-sources"
Andrew Geissler615f2f12022-07-15 14:00:58 -050058ARCHIVER_ARCH = "${TARGET_SYS}"
59ARCHIVER_OUTDIR = "${ARCHIVER_TOPDIR}/${ARCHIVER_ARCH}/${PF}/"
Brad Bishop19323692019-04-05 15:28:33 -040060ARCHIVER_RPMTOPDIR ?= "${WORKDIR}/deploy-sources-rpm"
Andrew Geissler615f2f12022-07-15 14:00:58 -050061ARCHIVER_RPMOUTDIR = "${ARCHIVER_RPMTOPDIR}/${ARCHIVER_ARCH}/${PF}/"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050062ARCHIVER_WORKDIR = "${WORKDIR}/archiver-work/"
63
Andrew Geissler82c905d2020-04-13 13:39:40 -050064# When producing a combined mirror directory, allow duplicates for the case
65# where multiple recipes use the same SRC_URI.
66ARCHIVER_COMBINED_MIRRORDIR = "${ARCHIVER_TOPDIR}/mirror"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000067SSTATE_ALLOW_OVERLAP_FILES += "${DEPLOY_DIR_SRC}/mirror"
Brad Bishop19323692019-04-05 15:28:33 -040068
Patrick Williamsc124f4f2015-09-15 14:41:29 -050069do_dumpdata[dirs] = "${ARCHIVER_OUTDIR}"
70do_ar_recipe[dirs] = "${ARCHIVER_OUTDIR}"
71do_ar_original[dirs] = "${ARCHIVER_OUTDIR} ${ARCHIVER_WORKDIR}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050072
73# This is a convenience for the shell script to use it
74
75
76python () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050077 pn = d.getVar('PN')
78 assume_provided = (d.getVar("ASSUME_PROVIDED") or "").split()
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050079 if pn in assume_provided:
Brad Bishop6e60e8b2018-02-01 10:27:11 -050080 for p in d.getVar("PROVIDES").split():
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050081 if p != pn:
82 pn = p
83 break
Patrick Williamsc124f4f2015-09-15 14:41:29 -050084
85 included, reason = copyleft_should_include(d)
86 if not included:
87 bb.debug(1, 'archiver: %s is excluded: %s' % (pn, reason))
88 return
89 else:
90 bb.debug(1, 'archiver: %s is included: %s' % (pn, reason))
91
Brad Bishop6e60e8b2018-02-01 10:27:11 -050092
93 # glibc-locale: do_fetch, do_unpack and do_patch tasks have been deleted,
94 # so avoid archiving source here.
95 if pn.startswith('glibc-locale'):
96 return
97
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050098 # We just archive gcc-source for all the gcc related recipes
Brad Bishop6e60e8b2018-02-01 10:27:11 -050099 if d.getVar('BPN') in ['gcc', 'libgcc'] \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500100 and not pn.startswith('gcc-source'):
101 bb.debug(1, 'archiver: %s is excluded, covered by gcc-source' % pn)
102 return
103
Andrew Geissler615f2f12022-07-15 14:00:58 -0500104 # TARGET_SYS in ARCHIVER_ARCH will break the stamp for gcc-source in multiconfig
105 if pn.startswith('gcc-source'):
106 d.setVar('ARCHIVER_ARCH', "allarch")
107
Brad Bishop79641f22019-09-10 07:20:22 -0400108 def hasTask(task):
109 return bool(d.getVarFlag(task, "task", False)) and not bool(d.getVarFlag(task, "noexec", False))
110
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500111 ar_src = d.getVarFlag('ARCHIVER_MODE', 'src')
112 ar_dumpdata = d.getVarFlag('ARCHIVER_MODE', 'dumpdata')
113 ar_recipe = d.getVarFlag('ARCHIVER_MODE', 'recipe')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500114
115 if ar_src == "original":
116 d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_ar_original' % pn)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500117 # 'patched' and 'configured' invoke do_unpack_and_patch because
118 # do_ar_patched resp. do_ar_configured depend on it, but for 'original'
119 # we have to add it explicitly.
120 if d.getVarFlag('ARCHIVER_MODE', 'diff') == '1':
121 d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_unpack_and_patch' % pn)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500122 elif ar_src == "patched":
123 d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_ar_patched' % pn)
124 elif ar_src == "configured":
125 # We can't use "addtask do_ar_configured after do_configure" since it
Andrew Geisslerc926e172021-05-07 16:11:35 -0500126 # will cause the deptask of do_populate_sysroot to run no matter what
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500127 # archives we need, so we add the depends here.
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500128
129 # There is a corner case with "gcc-source-${PV}" recipes, they don't have
130 # the "do_configure" task, so we need to use "do_preconfigure"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800131 if hasTask("do_preconfigure"):
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500132 d.appendVarFlag('do_ar_configured', 'depends', ' %s:do_preconfigure' % pn)
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800133 elif hasTask("do_configure"):
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500134 d.appendVarFlag('do_ar_configured', 'depends', ' %s:do_configure' % pn)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500135 d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_ar_configured' % pn)
Andrew Geissler82c905d2020-04-13 13:39:40 -0500136 elif ar_src == "mirror":
137 d.appendVarFlag('do_deploy_archives', 'depends', '%s:do_ar_mirror' % pn)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500138
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500139 elif ar_src:
140 bb.fatal("Invalid ARCHIVER_MODE[src]: %s" % ar_src)
141
142 if ar_dumpdata == "1":
143 d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_dumpdata' % pn)
144
145 if ar_recipe == "1":
146 d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_ar_recipe' % pn)
147
Brad Bishop316dfdd2018-06-25 12:45:53 -0400148 # Output the SRPM package
149 if d.getVarFlag('ARCHIVER_MODE', 'srpm') == "1" and d.getVar('PACKAGES'):
Brad Bishop79641f22019-09-10 07:20:22 -0400150 if "package_rpm" not in d.getVar('PACKAGE_CLASSES'):
151 bb.fatal("ARCHIVER_MODE[srpm] needs package_rpm in PACKAGE_CLASSES")
152
153 # Some recipes do not have any packaging tasks
154 if hasTask("do_package_write_rpm"):
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500155 d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_package_write_rpm' % pn)
Brad Bishop19323692019-04-05 15:28:33 -0400156 d.appendVarFlag('do_package_write_rpm', 'dirs', ' ${ARCHIVER_RPMTOPDIR}')
157 d.appendVarFlag('do_package_write_rpm', 'sstate-inputdirs', ' ${ARCHIVER_RPMTOPDIR}')
158 d.appendVarFlag('do_package_write_rpm', 'sstate-outputdirs', ' ${DEPLOY_DIR_SRC}')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500159 if ar_dumpdata == "1":
160 d.appendVarFlag('do_package_write_rpm', 'depends', ' %s:do_dumpdata' % pn)
161 if ar_recipe == "1":
162 d.appendVarFlag('do_package_write_rpm', 'depends', ' %s:do_ar_recipe' % pn)
163 if ar_src == "original":
164 d.appendVarFlag('do_package_write_rpm', 'depends', ' %s:do_ar_original' % pn)
165 elif ar_src == "patched":
166 d.appendVarFlag('do_package_write_rpm', 'depends', ' %s:do_ar_patched' % pn)
167 elif ar_src == "configured":
168 d.appendVarFlag('do_package_write_rpm', 'depends', ' %s:do_ar_configured' % pn)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500169}
170
Andrew Geisslerc926e172021-05-07 16:11:35 -0500171# Take all the sources for a recipe and put them in WORKDIR/archiver-work/.
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500172# Files in SRC_URI are copied directly, anything that's a directory
173# (e.g. git repositories) is "unpacked" and then put into a tarball.
174python do_ar_original() {
175
Brad Bishop37a0e4d2017-12-04 01:01:44 -0500176 import shutil, tempfile
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500177
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500178 if d.getVarFlag('ARCHIVER_MODE', 'src') != "original":
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500179 return
180
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500181 ar_outdir = d.getVar('ARCHIVER_OUTDIR')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500182 bb.note('Archiving the original source...')
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500183 urls = d.getVar("SRC_URI").split()
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600184 # destsuffix (git fetcher) and subdir (everything else) are allowed to be
185 # absolute paths (for example, destsuffix=${S}/foobar).
186 # That messes with unpacking inside our tmpdir below, because the fetchers
187 # will then unpack in that directory and completely ignore the tmpdir.
188 # That breaks parallel tasks relying on ${S}, like do_compile.
189 #
190 # To solve this, we remove these parameters from all URLs.
191 # We do this even for relative paths because it makes the content of the
192 # archives more useful (no extra paths that are only used during
193 # compilation).
194 for i, url in enumerate(urls):
195 decoded = bb.fetch2.decodeurl(url)
196 for param in ('destsuffix', 'subdir'):
197 if param in decoded[5]:
198 del decoded[5][param]
199 encoded = bb.fetch2.encodeurl(decoded)
200 urls[i] = encoded
Andrew Geissler1e34c2d2020-05-29 16:02:59 -0500201
202 # Cleanup SRC_URI before call bb.fetch2.Fetch() since now SRC_URI is in the
203 # variable "urls", otherwise there might be errors like:
204 # The SRCREV_FORMAT variable must be set when multiple SCMs are used
205 ld = bb.data.createCopy(d)
206 ld.setVar('SRC_URI', '')
207 fetch = bb.fetch2.Fetch(urls, ld)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600208 tarball_suffix = {}
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500209 for url in fetch.urls:
210 local = fetch.localpath(url).rstrip("/");
211 if os.path.isfile(local):
212 shutil.copy(local, ar_outdir)
213 elif os.path.isdir(local):
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500214 tmpdir = tempfile.mkdtemp(dir=d.getVar('ARCHIVER_WORKDIR'))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500215 fetch.unpack(tmpdir, (url,))
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600216 # To handle recipes with more than one source, we add the "name"
217 # URL parameter as suffix. We treat it as an error when
218 # there's more than one URL without a name, or a name gets reused.
219 # This is an additional safety net, in practice the name has
220 # to be set when using the git fetcher, otherwise SRCREV cannot
221 # be set separately for each URL.
222 params = bb.fetch2.decodeurl(url)[5]
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500223 type = bb.fetch2.decodeurl(url)[0]
224 location = bb.fetch2.decodeurl(url)[2]
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600225 name = params.get('name', '')
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500226 if type.lower() == 'file':
227 name_tmp = location.rstrip("*").rstrip("/")
228 name = os.path.basename(name_tmp)
229 else:
230 if name in tarball_suffix:
231 if not name:
232 bb.fatal("Cannot determine archive names for original source because 'name' URL parameter is unset in more than one URL. Add it to at least one of these: %s %s" % (tarball_suffix[name], url))
233 else:
234 bb.fatal("Cannot determine archive names for original source because 'name=' URL parameter '%s' is used twice. Make it unique in: %s %s" % (tarball_suffix[name], url))
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600235 tarball_suffix[name] = url
236 create_tarball(d, tmpdir + '/.', name, ar_outdir)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500237
238 # Emit patch series files for 'original'
239 bb.note('Writing patch series files...')
240 for patch in src_patches(d):
241 _, _, local, _, _, parm = bb.fetch.decodeurl(patch)
242 patchdir = parm.get('patchdir')
243 if patchdir:
244 series = os.path.join(ar_outdir, 'series.subdir.%s' % patchdir.replace('/', '_'))
245 else:
246 series = os.path.join(ar_outdir, 'series')
247
248 with open(series, 'a') as s:
249 s.write('%s -p%s\n' % (os.path.basename(local), parm['striplevel']))
250}
251
252python do_ar_patched() {
253
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500254 if d.getVarFlag('ARCHIVER_MODE', 'src') != 'patched':
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500255 return
256
257 # Get the ARCHIVER_OUTDIR before we reset the WORKDIR
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500258 ar_outdir = d.getVar('ARCHIVER_OUTDIR')
Brad Bishopa34c0302019-09-23 22:34:48 -0400259 if not is_work_shared(d):
260 ar_workdir = d.getVar('ARCHIVER_WORKDIR')
261 d.setVar('WORKDIR', ar_workdir)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500262 bb.note('Archiving the patched source...')
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500263 create_tarball(d, d.getVar('S'), 'patched', ar_outdir)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500264}
265
266python do_ar_configured() {
267 import shutil
268
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500269 # Forcibly expand the sysroot paths as we're about to change WORKDIR
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500270 d.setVar('STAGING_DIR_HOST', d.getVar('STAGING_DIR_HOST'))
271 d.setVar('STAGING_DIR_TARGET', d.getVar('STAGING_DIR_TARGET'))
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500272 d.setVar('RECIPE_SYSROOT', d.getVar('RECIPE_SYSROOT'))
273 d.setVar('RECIPE_SYSROOT_NATIVE', d.getVar('RECIPE_SYSROOT_NATIVE'))
274
275 ar_outdir = d.getVar('ARCHIVER_OUTDIR')
276 if d.getVarFlag('ARCHIVER_MODE', 'src') == 'configured':
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500277 bb.note('Archiving the configured source...')
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500278 pn = d.getVar('PN')
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500279 # "gcc-source-${PV}" recipes don't have "do_configure"
280 # task, so we need to run "do_preconfigure" instead
281 if pn.startswith("gcc-source-"):
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500282 d.setVar('WORKDIR', d.getVar('ARCHIVER_WORKDIR'))
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500283 bb.build.exec_func('do_preconfigure', d)
284
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500285 # The libtool-native's do_configure will remove the
286 # ${STAGING_DATADIR}/aclocal/libtool.m4, so we can't re-run the
287 # do_configure, we archive the already configured ${S} to
288 # instead of.
Patrick Williams213cb262021-08-07 19:21:33 -0500289 # The kernel class functions require it to be on work-shared, we
290 # don't unpack, patch, configure again, just archive the already
291 # configured ${S}
292 elif not (pn == 'libtool-native' or is_work_shared(d)):
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800293 def runTask(task):
294 prefuncs = d.getVarFlag(task, 'prefuncs') or ''
295 for func in prefuncs.split():
296 if func != "sysroot_cleansstate":
297 bb.build.exec_func(func, d)
298 bb.build.exec_func(task, d)
299 postfuncs = d.getVarFlag(task, 'postfuncs') or ''
300 for func in postfuncs.split():
301 if func != 'do_qa_configure':
302 bb.build.exec_func(func, d)
303
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500304 # Change the WORKDIR to make do_configure run in another dir.
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500305 d.setVar('WORKDIR', d.getVar('ARCHIVER_WORKDIR'))
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800306
307 preceeds = bb.build.preceedtask('do_configure', False, d)
308 for task in preceeds:
309 if task != 'do_patch' and task != 'do_prepare_recipe_sysroot':
310 runTask(task)
311 runTask('do_configure')
312
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500313 srcdir = d.getVar('S')
314 builddir = d.getVar('B')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500315 if srcdir != builddir:
316 if os.path.exists(builddir):
317 oe.path.copytree(builddir, os.path.join(srcdir, \
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500318 'build.%s.ar_configured' % d.getVar('PF')))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500319 create_tarball(d, srcdir, 'configured', ar_outdir)
320}
321
Andrew Geissler82c905d2020-04-13 13:39:40 -0500322python do_ar_mirror() {
323 import subprocess
324
325 src_uri = (d.getVar('SRC_URI') or '').split()
326 if len(src_uri) == 0:
327 return
328
329 dl_dir = d.getVar('DL_DIR')
330 mirror_exclusions = (d.getVar('ARCHIVER_MIRROR_EXCLUDE') or '').split()
331 mirror_mode = d.getVarFlag('ARCHIVER_MODE', 'mirror')
332 have_mirror_tarballs = d.getVar('BB_GENERATE_MIRROR_TARBALLS')
333
334 if mirror_mode == 'combined':
335 destdir = d.getVar('ARCHIVER_COMBINED_MIRRORDIR')
336 elif mirror_mode == 'split':
337 destdir = d.getVar('ARCHIVER_OUTDIR')
338 else:
339 bb.fatal('Invalid ARCHIVER_MODE[mirror]: %s' % (mirror_mode))
340
341 if not have_mirror_tarballs:
342 bb.fatal('Using `ARCHIVER_MODE[src] = "mirror"` depends on setting `BB_GENERATE_MIRROR_TARBALLS = "1"`')
343
344 def is_excluded(url):
345 for prefix in mirror_exclusions:
346 if url.startswith(prefix):
347 return True
348 return False
349
350 bb.note('Archiving the source as a mirror...')
351
352 bb.utils.mkdirhier(destdir)
353
354 fetcher = bb.fetch2.Fetch(src_uri, d)
355
Andrew Geissler5a43b432020-06-13 10:46:56 -0500356 for ud in fetcher.expanded_urldata():
357 if is_excluded(ud.url):
358 bb.note('Skipping excluded url: %s' % (ud.url))
Andrew Geissler82c905d2020-04-13 13:39:40 -0500359 continue
360
Andrew Geissler5a43b432020-06-13 10:46:56 -0500361 bb.note('Archiving url: %s' % (ud.url))
Andrew Geissler82c905d2020-04-13 13:39:40 -0500362 ud.setup_localpath(d)
363 localpath = None
364
365 # Check for mirror tarballs first. We will archive the first mirror
366 # tarball that we find as it's assumed that we just need one.
367 for mirror_fname in ud.mirrortarballs:
368 mirror_path = os.path.join(dl_dir, mirror_fname)
369 if os.path.exists(mirror_path):
370 bb.note('Found mirror tarball: %s' % (mirror_path))
371 localpath = mirror_path
372 break
373
374 if len(ud.mirrortarballs) and not localpath:
375 bb.warn('Mirror tarballs are listed for a source but none are present. ' \
376 'Falling back to original download.\n' \
Andrew Geissler5a43b432020-06-13 10:46:56 -0500377 'SRC_URI = %s' % (ud.url))
Andrew Geissler82c905d2020-04-13 13:39:40 -0500378
379 # Check original download
380 if not localpath:
381 bb.note('Using original download: %s' % (ud.localpath))
382 localpath = ud.localpath
383
384 if not localpath or not os.path.exists(localpath):
385 bb.fatal('Original download is missing for a source.\n' \
Andrew Geissler5a43b432020-06-13 10:46:56 -0500386 'SRC_URI = %s' % (ud.url))
Andrew Geissler82c905d2020-04-13 13:39:40 -0500387
388 # We now have an appropriate localpath
389 bb.note('Copying source mirror')
390 cmd = 'cp -fpPRH %s %s' % (localpath, destdir)
391 subprocess.check_call(cmd, shell=True)
392}
393
Brad Bishopc4ea0752018-11-15 14:30:15 -0800394def exclude_useless_paths(tarinfo):
395 if tarinfo.isdir():
396 if tarinfo.name.endswith('/temp') or tarinfo.name.endswith('/patches') or tarinfo.name.endswith('/.pc'):
397 return None
398 elif tarinfo.name == 'temp' or tarinfo.name == 'patches' or tarinfo.name == '.pc':
399 return None
400 return tarinfo
401
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500402def create_tarball(d, srcdir, suffix, ar_outdir):
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500403 """
404 create the tarball from srcdir
405 """
406 import tarfile
407
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500408 # Make sure we are only creating a single tarball for gcc sources
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500409 if (d.getVar('SRC_URI') == ""):
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500410 return
411
Brad Bishop316dfdd2018-06-25 12:45:53 -0400412 # For the kernel archive, srcdir may just be a link to the
413 # work-shared location. Use os.path.realpath to make sure
414 # that we archive the actual directory and not just the link.
415 srcdir = os.path.realpath(srcdir)
416
Andrew Geisslereff27472021-10-29 15:35:00 -0500417 compression_method = d.getVarFlag('ARCHIVER_MODE', 'compression')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500418 bb.utils.mkdirhier(ar_outdir)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500419 if suffix:
Andrew Geisslereff27472021-10-29 15:35:00 -0500420 filename = '%s-%s.tar.%s' % (d.getVar('PF'), suffix, compression_method)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500421 else:
Andrew Geisslereff27472021-10-29 15:35:00 -0500422 filename = '%s.tar.%s' % (d.getVar('PF'), compression_method)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500423 tarname = os.path.join(ar_outdir, filename)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500424
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500425 bb.note('Creating %s' % tarname)
Andrew Geisslereff27472021-10-29 15:35:00 -0500426 tar = tarfile.open(tarname, 'w:%s' % compression_method)
Brad Bishopc4ea0752018-11-15 14:30:15 -0800427 tar.add(srcdir, arcname=os.path.basename(srcdir), filter=exclude_useless_paths)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500428 tar.close()
429
430# creating .diff.gz between source.orig and source
431def create_diff_gz(d, src_orig, src, ar_outdir):
432
433 import subprocess
434
435 if not os.path.isdir(src) or not os.path.isdir(src_orig):
436 return
437
438 # The diff --exclude can't exclude the file with path, so we copy
439 # the patched source, and remove the files that we'd like to
440 # exclude.
441 src_patched = src + '.patched'
442 oe.path.copyhardlinktree(src, src_patched)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500443 for i in d.getVarFlag('ARCHIVER_MODE', 'diff-exclude').split():
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500444 bb.utils.remove(os.path.join(src_orig, i), recurse=True)
445 bb.utils.remove(os.path.join(src_patched, i), recurse=True)
446
447 dirname = os.path.dirname(src)
448 basename = os.path.basename(src)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500449 bb.utils.mkdirhier(ar_outdir)
450 cwd = os.getcwd()
451 try:
452 os.chdir(dirname)
453 out_file = os.path.join(ar_outdir, '%s-diff.gz' % d.getVar('PF'))
454 diff_cmd = 'diff -Naur %s.orig %s.patched | gzip -c > %s' % (basename, basename, out_file)
455 subprocess.check_call(diff_cmd, shell=True)
456 bb.utils.remove(src_patched, recurse=True)
457 finally:
458 os.chdir(cwd)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500459
Brad Bishop316dfdd2018-06-25 12:45:53 -0400460def is_work_shared(d):
461 pn = d.getVar('PN')
462 return bb.data.inherits_class('kernel', d) or pn.startswith('gcc-source')
463
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500464# Run do_unpack and do_patch
465python do_unpack_and_patch() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500466 if d.getVarFlag('ARCHIVER_MODE', 'src') not in \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500467 [ 'patched', 'configured'] and \
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500468 d.getVarFlag('ARCHIVER_MODE', 'diff') != '1':
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500469 return
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500470 ar_outdir = d.getVar('ARCHIVER_OUTDIR')
471 ar_workdir = d.getVar('ARCHIVER_WORKDIR')
472 ar_sysroot_native = d.getVar('STAGING_DIR_NATIVE')
473 pn = d.getVar('PN')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500474
Andrew Geisslerc926e172021-05-07 16:11:35 -0500475 # The kernel class functions require it to be on work-shared, so we don't change WORKDIR
Brad Bishop316dfdd2018-06-25 12:45:53 -0400476 if not is_work_shared(d):
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500477 # Change the WORKDIR to make do_unpack do_patch run in another dir.
478 d.setVar('WORKDIR', ar_workdir)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500479 # Restore the original path to recipe's native sysroot (it's relative to WORKDIR).
480 d.setVar('STAGING_DIR_NATIVE', ar_sysroot_native)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500481
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500482 # The changed 'WORKDIR' also caused 'B' changed, create dir 'B' for the
483 # possibly requiring of the following tasks (such as some recipes's
484 # do_patch required 'B' existed).
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500485 bb.utils.mkdirhier(d.getVar('B'))
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500486
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500487 bb.build.exec_func('do_unpack', d)
488
489 # Save the original source for creating the patches
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500490 if d.getVarFlag('ARCHIVER_MODE', 'diff') == '1':
491 src = d.getVar('S').rstrip('/')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500492 src_orig = '%s.orig' % src
493 oe.path.copytree(src, src_orig)
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500494
Patrick Williams213cb262021-08-07 19:21:33 -0500495 if bb.data.inherits_class('dos2unix', d):
496 bb.build.exec_func('do_convert_crlf_to_lf', d)
497
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500498 # Make sure gcc and kernel sources are patched only once
Brad Bishop316dfdd2018-06-25 12:45:53 -0400499 if not (d.getVar('SRC_URI') == "" or is_work_shared(d)):
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500500 bb.build.exec_func('do_patch', d)
501
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500502 # Create the patches
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500503 if d.getVarFlag('ARCHIVER_MODE', 'diff') == '1':
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500504 bb.note('Creating diff gz...')
505 create_diff_gz(d, src_orig, src, ar_outdir)
506 bb.utils.remove(src_orig, recurse=True)
507}
508
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500509# BBINCLUDED is special (excluded from basehash signature
510# calculation). Using it in a task signature can cause "basehash
511# changed" errors.
512#
513# Depending on BBINCLUDED also causes do_ar_recipe to run again
514# for unrelated changes, like adding or removing buildhistory.bbclass.
515#
516# For these reasons we ignore the dependency completely. The versioning
517# of the output file ensures that we create it each time the recipe
518# gets rebuilt, at least as long as a PR server is used. We also rely
519# on that mechanism to catch changes in the file content, because the
Andrew Geisslerc926e172021-05-07 16:11:35 -0500520# file content is not part of the task signature either.
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500521do_ar_recipe[vardepsexclude] += "BBINCLUDED"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500522python do_ar_recipe () {
523 """
524 archive the recipe, including .bb and .inc.
525 """
526 import re
527 import shutil
528
529 require_re = re.compile( r"require\s+(.+)" )
530 include_re = re.compile( r"include\s+(.+)" )
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500531 bbfile = d.getVar('FILE')
532 outdir = os.path.join(d.getVar('WORKDIR'), \
533 '%s-recipe' % d.getVar('PF'))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500534 bb.utils.mkdirhier(outdir)
535 shutil.copy(bbfile, outdir)
536
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500537 pn = d.getVar('PN')
538 bbappend_files = d.getVar('BBINCLUDED').split()
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500539 # If recipe name is aa, we need to match files like aa.bbappend and aa_1.1.bbappend
540 # Files like aa1.bbappend or aa1_1.1.bbappend must be excluded.
Brad Bishop37a0e4d2017-12-04 01:01:44 -0500541 bbappend_re = re.compile( r".*/%s_[^/]*\.bbappend$" % re.escape(pn))
542 bbappend_re1 = re.compile( r".*/%s\.bbappend$" % re.escape(pn))
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500543 for file in bbappend_files:
544 if bbappend_re.match(file) or bbappend_re1.match(file):
545 shutil.copy(file, outdir)
546
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500547 dirname = os.path.dirname(bbfile)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500548 bbpath = '%s:%s' % (dirname, d.getVar('BBPATH'))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500549 f = open(bbfile, 'r')
550 for line in f.readlines():
551 incfile = None
552 if require_re.match(line):
553 incfile = require_re.match(line).group(1)
554 elif include_re.match(line):
555 incfile = include_re.match(line).group(1)
556 if incfile:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500557 incfile = d.expand(incfile)
Brad Bishop1d80a2e2019-11-15 16:35:03 -0500558 if incfile:
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500559 incfile = bb.utils.which(bbpath, incfile)
Brad Bishop1d80a2e2019-11-15 16:35:03 -0500560 if incfile:
561 shutil.copy(incfile, outdir)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500562
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500563 create_tarball(d, outdir, 'recipe', d.getVar('ARCHIVER_OUTDIR'))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500564 bb.utils.remove(outdir, recurse=True)
565}
566
567python do_dumpdata () {
568 """
569 dump environment data to ${PF}-showdata.dump
570 """
571
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500572 dumpfile = os.path.join(d.getVar('ARCHIVER_OUTDIR'), \
573 '%s-showdata.dump' % d.getVar('PF'))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500574 bb.note('Dumping metadata into %s' % dumpfile)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500575 with open(dumpfile, "w") as f:
576 # emit variables and shell functions
577 bb.data.emit_env(f, d, True)
578 # emit the metadata which isn't valid shell
579 for e in d.keys():
580 if d.getVarFlag(e, "python", False):
581 f.write("\npython %s () {\n%s}\n" % (e, d.getVar(e, False)))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500582}
583
584SSTATETASKS += "do_deploy_archives"
585do_deploy_archives () {
Andrew Geissler78b72792022-06-14 06:47:25 -0500586 bbnote "Deploying source archive files from ${ARCHIVER_TOPDIR} to ${DEPLOY_DIR_SRC}."
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500587}
588python do_deploy_archives_setscene () {
589 sstate_setscene(d)
590}
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500591do_deploy_archives[dirs] = "${ARCHIVER_TOPDIR}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500592do_deploy_archives[sstate-inputdirs] = "${ARCHIVER_TOPDIR}"
593do_deploy_archives[sstate-outputdirs] = "${DEPLOY_DIR_SRC}"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500594addtask do_deploy_archives_setscene
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500595
596addtask do_ar_original after do_unpack
Andrew Geissler475cb722020-07-10 16:00:51 -0500597addtask do_unpack_and_patch after do_patch do_preconfigure
598addtask do_ar_patched after do_unpack_and_patch
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500599addtask do_ar_configured after do_unpack_and_patch
Andrew Geissler82c905d2020-04-13 13:39:40 -0500600addtask do_ar_mirror after do_fetch
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500601addtask do_dumpdata
602addtask do_ar_recipe
Andrew Geissler1e34c2d2020-05-29 16:02:59 -0500603addtask do_deploy_archives
604do_build[recrdeptask] += "do_deploy_archives"
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600605do_rootfs[recrdeptask] += "do_deploy_archives"
Andrew Geissler1e34c2d2020-05-29 16:02:59 -0500606do_populate_sdk[recrdeptask] += "do_deploy_archives"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500607
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500608python () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500609 # Add tasks in the correct order, specifically for linux-yocto to avoid race condition.
610 # sstatesig.py:sstate_rundepfilter has special support that excludes this dependency
611 # so that do_kernel_configme does not need to run again when do_unpack_and_patch
612 # gets added or removed (by adding or removing archiver.bbclass).
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500613 if bb.data.inherits_class('kernel-yocto', d):
614 bb.build.addtask('do_kernel_configme', 'do_configure', 'do_unpack_and_patch', d)
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500615}