Brad Bishop | ea02e47 | 2017-05-12 13:02:56 -0400 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC event and error logging" |
| 2 | DESCRIPTION = "An error and event log daemon application, and \ |
| 3 | supporting tools for OpenBMC." |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 4 | HOMEPAGE = "https://github.com/openbmc/phosphor-logging" |
| 5 | PR = "r1" |
| 6 | |
| 7 | inherit autotools pkgconfig |
| 8 | inherit pythonnative |
| 9 | inherit obmc-phosphor-license |
| 10 | inherit obmc-phosphor-dbus-service |
Deepak Kodihalli | 44b1c52 | 2017-03-16 06:32:12 -0500 | [diff] [blame] | 11 | inherit phosphor-logging |
Marri Devender Rao | 56eae0a | 2017-06-06 08:39:39 -0500 | [diff] [blame] | 12 | inherit phosphor-dbus-yaml |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 13 | |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 14 | DEPENDS += "autoconf-archive-native" |
| 15 | DEPENDS += "systemd" |
| 16 | DEPENDS += "python-mako-native" |
| 17 | DEPENDS += "python-pyyaml-native" |
Patrick Williams | 57b1781 | 2016-12-09 08:56:38 -0600 | [diff] [blame] | 18 | DEPENDS += "sdbusplus sdbusplus-native" |
Deepak Kodihalli | c8d9205 | 2017-03-23 03:52:28 -0500 | [diff] [blame] | 19 | DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native" |
Deepak Kodihalli | 44b1c52 | 2017-03-16 06:32:12 -0500 | [diff] [blame] | 20 | DEPENDS += "virtual/phosphor-logging-callouts" |
Marri Devender Rao | f2ea35d | 2017-05-14 09:01:35 -0500 | [diff] [blame] | 21 | DEPENDS += "phosphor-logging-error-logs-native" |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 22 | DEPENDS += "phosphor-logging-native" |
Deepak Kodihalli | 4516050 | 2017-06-13 12:52:19 -0500 | [diff] [blame] | 23 | DEPENDS += "cereal" |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 24 | |
Michael Tritz | ccc0d0f | 2017-03-13 14:54:24 -0500 | [diff] [blame] | 25 | PACKAGE_BEFORE_PN = "${PN}-test" |
| 26 | FILES_${PN}-test = "${bindir}/*-test" |
| 27 | |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 28 | PACKAGE_BEFORE_PN += "${PN}-elog" |
| 29 | FILES_${PN}-elog += "${elog_dir}" |
| 30 | |
Deepak Kodihalli | 38af2c0 | 2018-08-24 08:05:14 -0500 | [diff] [blame] | 31 | # Package configuration |
| 32 | LOGGING_PACKAGES = " \ |
| 33 | ${PN}-base \ |
Deepak Kodihalli | f99f3c8 | 2018-08-28 11:39:41 -0500 | [diff] [blame] | 34 | phosphor-rsyslog-config \ |
Deepak Kodihalli | 38af2c0 | 2018-08-24 08:05:14 -0500 | [diff] [blame] | 35 | " |
| 36 | |
| 37 | ALLOW_EMPTY_${PN} = "1" |
| 38 | PACKAGE_BEFORE_PN += "${LOGGING_PACKAGES}" |
| 39 | SYSTEMD_PACKAGES = "${LOGGING_PACKAGES}" |
| 40 | DBUS_PACKAGES = "${LOGGING_PACKAGES}" |
| 41 | |
| 42 | RDEPENDS_${PN}-base += "sdbusplus phosphor-dbus-interfaces" |
| 43 | FILES_${PN}-base += " \ |
| 44 | ${sbindir}/phosphor-log-manager \ |
| 45 | ${libdir}/libphosphor_logging.so.* \ |
| 46 | " |
| 47 | DBUS_SERVICE_${PN}-base += "xyz.openbmc_project.Logging.service" |
| 48 | |
Deepak Kodihalli | f99f3c8 | 2018-08-28 11:39:41 -0500 | [diff] [blame] | 49 | RDEPENDS_phosphor-rsyslog-config += "sdbusplus phosphor-dbus-interfaces" |
| 50 | DBUS_SERVICE_phosphor-rsyslog-config += "xyz.openbmc_project.Syslog.Config.service" |
| 51 | FILES_phosphor-rsyslog-config += " \ |
| 52 | ${sbindir}/phosphor-rsyslog-conf \ |
| 53 | " |
| 54 | |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 55 | SRC_URI += "git://github.com/openbmc/phosphor-logging" |
Andrew Geissler | 4d42c84 | 2018-10-05 13:30:22 +0000 | [diff] [blame] | 56 | SRCREV = "b17e8768da6db65dc7e96f07995256a666dc83f5" |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 57 | |
| 58 | S = "${WORKDIR}/git" |
| 59 | |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 60 | # Do not DEPEND on the specified packages for native build |
| 61 | # as they will not be available in host machine |
Brad Bishop | efeb13a | 2018-01-27 00:27:21 -0500 | [diff] [blame] | 62 | DEPENDS_remove_class-native = " \ |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 63 | virtual/phosphor-logging-callouts \ |
Brad Bishop | efeb13a | 2018-01-27 00:27:21 -0500 | [diff] [blame] | 64 | sdbus++ \ |
| 65 | systemd \ |
| 66 | cereal \ |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 67 | " |
| 68 | |
| 69 | # Do not DEPEND on the specified packages for native SDK build |
| 70 | # as they will not be available in host machine |
| 71 | DEPENDS_remove_class-nativesdk = " \ |
| 72 | virtual/phosphor-logging-callouts \ |
| 73 | sdbus++-native \ |
Brad Bishop | efeb13a | 2018-01-27 00:27:21 -0500 | [diff] [blame] | 74 | cereal \ |
| 75 | systemd \ |
| 76 | phosphor-dbus-interfaces \ |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 77 | " |
| 78 | |
| 79 | PACKAGECONFIG ??= "metadata-processing install_scripts" |
| 80 | |
Deepak Kodihalli | 2551ece | 2017-03-28 07:47:51 -0500 | [diff] [blame] | 81 | PACKAGECONFIG[metadata-processing] = " \ |
| 82 | --enable-metadata-processing, \ |
| 83 | --disable-metadata-processing, , \ |
| 84 | " |
| 85 | |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 86 | # Provide a means to enable/disable install_scripts feature |
| 87 | PACKAGECONFIG[install_scripts] = " \ |
| 88 | --enable-install_scripts, \ |
| 89 | --disable-install_scripts, ,\ |
| 90 | " |
| 91 | |
| 92 | # Enable install_scripts during native and native SDK build |
| 93 | PACKAGECONFIG_add_class-native = "install_scripts" |
| 94 | PACKAGECONFIG_add_class-nativesdk = "install_scripts" |
| 95 | |
| 96 | # Disable install_scripts during target build |
| 97 | PACKAGECONFIG_remove_class-target = "install_scripts" |
| 98 | |
Deepak Kodihalli | 44b1c52 | 2017-03-16 06:32:12 -0500 | [diff] [blame] | 99 | EXTRA_OECONF = " \ |
| 100 | YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir} \ |
| 101 | CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \ |
| 102 | " |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 103 | |
| 104 | BBCLASSEXTEND += "native nativesdk" |