Matthew Barth | 9146042 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 1 | SUMMARY = "Phosphor Fan Presence" |
| 2 | DESCRIPTION = "Phosphor fan presence provides a set of fan presence \ |
| 3 | daemons to monitor fan presence changes by different methods of \ |
| 4 | presence detection." |
Matthew Barth | 9146042 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 5 | PR = "r1" |
Matt Spinler | c943de3 | 2017-03-21 15:02:13 -0500 | [diff] [blame] | 6 | |
| 7 | require ${PN}.inc |
Matthew Barth | 9146042 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 8 | |
| 9 | inherit autotools pkgconfig pythonnative |
| 10 | inherit obmc-phosphor-systemd |
Matt Spinler | c943de3 | 2017-03-21 15:02:13 -0500 | [diff] [blame] | 11 | inherit phosphor-fan-presence |
Matthew Barth | 9146042 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 12 | |
| 13 | DEPENDS += "autoconf-archive-native" |
| 14 | DEPENDS += "python-pyyaml-native" |
Matt Spinler | c943de3 | 2017-03-21 15:02:13 -0500 | [diff] [blame] | 15 | DEPENDS += "python-mako-native" |
Matthew Barth | 9146042 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 16 | DEPENDS += "sdbusplus" |
| 17 | DEPENDS += "phosphor-logging" |
Matt Spinler | c943de3 | 2017-03-21 15:02:13 -0500 | [diff] [blame] | 18 | DEPENDS += "virtual/phosphor-fan-presence-config" |
Brad Bishop | 96960aa | 2017-04-03 10:44:23 -0400 | [diff] [blame] | 19 | DEPENDS += "libevdev" |
Matthew Barth | 9146042 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 20 | |
| 21 | FAN_PRESENCE_PACKAGES = " \ |
| 22 | ${PN}-tach \ |
| 23 | " |
| 24 | PACKAGES_remove = "${PN}" |
Brad Bishop | 98cea15 | 2017-04-11 22:12:56 -0400 | [diff] [blame] | 25 | PACKAGES += "${FAN_PRESENCE_PACKAGES} phosphor-chassis-cooling-type" |
| 26 | |
| 27 | # Remove when this package has content |
| 28 | ALLOW_EMPTY_phosphor-chassis-cooling-type = "1" |
| 29 | |
Matthew Barth | 9146042 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 30 | SYSTEMD_PACKAGES = "${FAN_PRESENCE_PACKAGES}" |
Brad Bishop | 98cea15 | 2017-04-11 22:12:56 -0400 | [diff] [blame] | 31 | RDEPENDS_${PN}-dev = "${FAN_PRESENCE_PACKAGES} phosphor-chassis-cooling-type" |
Matthew Barth | 9146042 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 32 | |
Brad Bishop | 74fe8ff | 2017-04-11 21:51:26 -0400 | [diff] [blame] | 33 | RDEPENDS_${PN}-tach += "sdbusplus" |
| 34 | |
Brad Bishop | 98cea15 | 2017-04-11 22:12:56 -0400 | [diff] [blame] | 35 | RDEPENDS_phosphor-chassis-cooling-type += "libevdev" |
| 36 | |
Josh D. King | a283e07 | 2017-04-06 15:56:37 -0500 | [diff] [blame] | 37 | # Needed to install into the obmc-host-start target |
Matthew Barth | 9146042 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 38 | TMPL = "phosphor-fan-presence-tach@.service" |
| 39 | INSTFMT = "phosphor-fan-presence-tach@{0}.service" |
Josh D. King | a283e07 | 2017-04-06 15:56:37 -0500 | [diff] [blame] | 40 | TGTFMT = "obmc-host-start@{0}.target" |
Matthew Barth | 9146042 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 41 | FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}" |
| 42 | |
| 43 | FILES_${PN}-tach = "${sbindir}/phosphor-fan-presence-tach" |
| 44 | SYSTEMD_SERVICE_${PN}-tach += "${TMPL}" |
| 45 | SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}" |
| 46 | |
Matthew Barth | 9146042 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 47 | S = "${WORKDIR}/git" |
Matt Spinler | c943de3 | 2017-03-21 15:02:13 -0500 | [diff] [blame] | 48 | |
| 49 | EXTRA_OECONF = \ |
| 50 | "FAN_DETECT_YAML_FILE=${STAGING_DIR_NATIVE}${presence_datadir}/config.yaml" |