Brad Bishop | ea02e47 | 2017-05-12 13:02:56 -0400 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC event and error logging" |
| 2 | DESCRIPTION = "An error and event log daemon application, and \ |
| 3 | supporting tools for OpenBMC." |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 4 | HOMEPAGE = "https://github.com/openbmc/phosphor-logging" |
| 5 | PR = "r1" |
| 6 | |
| 7 | inherit autotools pkgconfig |
| 8 | inherit pythonnative |
| 9 | inherit obmc-phosphor-license |
| 10 | inherit obmc-phosphor-dbus-service |
Deepak Kodihalli | 44b1c52 | 2017-03-16 06:32:12 -0500 | [diff] [blame] | 11 | inherit phosphor-logging |
Marri Devender Rao | 56eae0a | 2017-06-06 08:39:39 -0500 | [diff] [blame] | 12 | inherit phosphor-dbus-yaml |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 13 | |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 14 | DEPENDS += "autoconf-archive-native" |
| 15 | DEPENDS += "systemd" |
| 16 | DEPENDS += "python-mako-native" |
| 17 | DEPENDS += "python-pyyaml-native" |
Patrick Williams | 57b1781 | 2016-12-09 08:56:38 -0600 | [diff] [blame] | 18 | DEPENDS += "sdbusplus sdbusplus-native" |
Deepak Kodihalli | c8d9205 | 2017-03-23 03:52:28 -0500 | [diff] [blame] | 19 | DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native" |
Deepak Kodihalli | 44b1c52 | 2017-03-16 06:32:12 -0500 | [diff] [blame] | 20 | DEPENDS += "virtual/phosphor-logging-callouts" |
Marri Devender Rao | f2ea35d | 2017-05-14 09:01:35 -0500 | [diff] [blame] | 21 | DEPENDS += "phosphor-logging-error-logs-native" |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 22 | DEPENDS += "phosphor-logging-native" |
Deepak Kodihalli | 4516050 | 2017-06-13 12:52:19 -0500 | [diff] [blame] | 23 | DEPENDS += "cereal" |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 24 | |
Michael Tritz | ccc0d0f | 2017-03-13 14:54:24 -0500 | [diff] [blame] | 25 | PACKAGE_BEFORE_PN = "${PN}-test" |
| 26 | FILES_${PN}-test = "${bindir}/*-test" |
| 27 | |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 28 | PACKAGE_BEFORE_PN += "${PN}-elog" |
| 29 | FILES_${PN}-elog += "${elog_dir}" |
| 30 | |
Deepak Kodihalli | 38af2c0 | 2018-08-24 08:05:14 -0500 | [diff] [blame] | 31 | # Package configuration |
| 32 | LOGGING_PACKAGES = " \ |
| 33 | ${PN}-base \ |
| 34 | " |
| 35 | |
| 36 | ALLOW_EMPTY_${PN} = "1" |
| 37 | PACKAGE_BEFORE_PN += "${LOGGING_PACKAGES}" |
| 38 | SYSTEMD_PACKAGES = "${LOGGING_PACKAGES}" |
| 39 | DBUS_PACKAGES = "${LOGGING_PACKAGES}" |
| 40 | |
| 41 | RDEPENDS_${PN}-base += "sdbusplus phosphor-dbus-interfaces" |
| 42 | FILES_${PN}-base += " \ |
| 43 | ${sbindir}/phosphor-log-manager \ |
| 44 | ${libdir}/libphosphor_logging.so.* \ |
| 45 | " |
| 46 | DBUS_SERVICE_${PN}-base += "xyz.openbmc_project.Logging.service" |
| 47 | |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 48 | SRC_URI += "git://github.com/openbmc/phosphor-logging" |
Brad Bishop | ea6a3d1 | 2018-08-30 13:52:43 -0400 | [diff] [blame] | 49 | SRCREV = "9fab279fb38ab6b391503ce89aceb917ec35efa9" |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 50 | |
| 51 | S = "${WORKDIR}/git" |
| 52 | |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 53 | # Do not DEPEND on the specified packages for native build |
| 54 | # as they will not be available in host machine |
Brad Bishop | efeb13a | 2018-01-27 00:27:21 -0500 | [diff] [blame] | 55 | DEPENDS_remove_class-native = " \ |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 56 | virtual/phosphor-logging-callouts \ |
Brad Bishop | efeb13a | 2018-01-27 00:27:21 -0500 | [diff] [blame] | 57 | sdbus++ \ |
| 58 | systemd \ |
| 59 | cereal \ |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 60 | " |
| 61 | |
| 62 | # Do not DEPEND on the specified packages for native SDK build |
| 63 | # as they will not be available in host machine |
| 64 | DEPENDS_remove_class-nativesdk = " \ |
| 65 | virtual/phosphor-logging-callouts \ |
| 66 | sdbus++-native \ |
Brad Bishop | efeb13a | 2018-01-27 00:27:21 -0500 | [diff] [blame] | 67 | cereal \ |
| 68 | systemd \ |
| 69 | phosphor-dbus-interfaces \ |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 70 | " |
| 71 | |
| 72 | PACKAGECONFIG ??= "metadata-processing install_scripts" |
| 73 | |
Deepak Kodihalli | 2551ece | 2017-03-28 07:47:51 -0500 | [diff] [blame] | 74 | PACKAGECONFIG[metadata-processing] = " \ |
| 75 | --enable-metadata-processing, \ |
| 76 | --disable-metadata-processing, , \ |
| 77 | " |
| 78 | |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 79 | # Provide a means to enable/disable install_scripts feature |
| 80 | PACKAGECONFIG[install_scripts] = " \ |
| 81 | --enable-install_scripts, \ |
| 82 | --disable-install_scripts, ,\ |
| 83 | " |
| 84 | |
| 85 | # Enable install_scripts during native and native SDK build |
| 86 | PACKAGECONFIG_add_class-native = "install_scripts" |
| 87 | PACKAGECONFIG_add_class-nativesdk = "install_scripts" |
| 88 | |
| 89 | # Disable install_scripts during target build |
| 90 | PACKAGECONFIG_remove_class-target = "install_scripts" |
| 91 | |
Deepak Kodihalli | 44b1c52 | 2017-03-16 06:32:12 -0500 | [diff] [blame] | 92 | EXTRA_OECONF = " \ |
| 93 | YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir} \ |
| 94 | CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \ |
| 95 | " |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 96 | |
| 97 | BBCLASSEXTEND += "native nativesdk" |