blob: 7ff4b2cdfd12035ef0c8d35c48635d44832e4f61 [file] [log] [blame]
Patrick Venture7ebe0262018-03-30 11:23:16 -07001SUMMARY = "Phosphor OpenBMC Post Code Daemon"
2DESCRIPTION = "Phosphor OpenBMC Post Code Daemon"
Patrick Venture6b91f732018-09-28 19:21:26 -07003HOMEPAGE = "http://github.com/openbmc/phosphor-host-postd"
Patrick Venture7ebe0262018-03-30 11:23:16 -07004PR = "r1"
Patrick Venture6b91f732018-09-28 19:21:26 -07005PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Patrick Venture7ebe0262018-03-30 11:23:16 -07008
Kun Yi556e23b2020-05-02 22:13:53 -07009inherit meson
10inherit pkgconfig
Patrick Venture20b4af62018-10-23 11:57:36 -070011inherit systemd
Patrick Venture7ebe0262018-03-30 11:23:16 -070012
Benjamin Fair14f1b6a2020-04-07 11:48:40 -070013PACKAGECONFIG ?= ""
Kun Yi556e23b2020-05-02 22:13:53 -070014PACKAGECONFIG[7seg] = "-D7seg=enabled,-D7seg=disabled,,udev"
Benjamin Fair14f1b6a2020-04-07 11:48:40 -070015
Patrick Venture7ebe0262018-03-30 11:23:16 -070016DEPENDS += "sdbusplus"
Kun Yi41d3e4d2018-09-12 11:01:33 -070017DEPENDS += "sdeventplus"
Patrick Venture7ebe0262018-03-30 11:23:16 -070018DEPENDS += "phosphor-dbus-interfaces"
19DEPENDS += "systemd"
20
Patrick Venture6b91f732018-09-28 19:21:26 -070021S = "${WORKDIR}/git"
22SRC_URI = "git://github.com/openbmc/phosphor-host-postd"
Andrew Geisslerb2a8c3e2021-04-06 02:41:52 +000023SRCREV = "2a744b2d70ce9de8519a7c716da5009cb049db17"
Patrick Venture6b91f732018-09-28 19:21:26 -070024
Benjamin Fair89e86cd2018-06-29 13:00:14 -070025SNOOP_DEVICE ?= "aspeed-lpc-snoop0"
26POST_CODE_BYTES ?= "1"
27
28SERVICE_FILE = "lpcsnoop.service"
Patrick Venture20b4af62018-10-23 11:57:36 -070029SYSTEMD_PACKAGES = "${PN}"
Patrick Williams12fc9392021-08-06 09:16:53 -050030SYSTEMD_SERVICE:${PN} += "${SERVICE_FILE}"
Patrick Venture20b4af62018-10-23 11:57:36 -070031
Kun Yi556e23b2020-05-02 22:13:53 -070032EXTRA_OEMESON += "-Dsnoop-device=${SNOOP_DEVICE}"
33EXTRA_OEMESON += "-Dpost-code-bytes=${POST_CODE_BYTES}"
34EXTRA_OEMESON += "-Dsystemd-target=multi-user.target"
Benjamin Fair14f1b6a2020-04-07 11:48:40 -070035
36POSTCODE_SEVENSEG_DEVICE ?= "seven_seg_disp_val"
37SERVICE_FILE_7SEG = " \
38 postcode-7seg@.service \
39 postcode-7seg@${POSTCODE_SEVENSEG_DEVICE}.service \
40"
Patrick Williams12fc9392021-08-06 09:16:53 -050041SYSTEMD_SERVICE:${PN} += "${@bb.utils.contains('PACKAGECONFIG', '7seg', '${SERVICE_FILE_7SEG}', '', d)}"