blob: 59d134801a4c1a4cc6c3097e492ff3be597e47d5 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "OpenGL driver testing framework"
2LICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
4
5SRC_URI = "git://anongit.freedesktop.org/piglit \
Patrick Williamsc0f7c042017-02-23 20:41:17 -06006 file://0001-cmake-install-bash-completions-in-the-right-place.patch \
7 file://0001-tests-Use-FE_UPWARD-only-if-its-defined-in-fenv.h.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008 file://0001-cmake-use-proper-WAYLAND_INCLUDE_DIRS-variable.patch \
Brad Bishop19323692019-04-05 15:28:33 -04009 file://format-fix.patch \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060010 "
Brad Bishop316dfdd2018-06-25 12:45:53 -040011UPSTREAM_CHECK_COMMITS = "1"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050012
Brad Bishop19323692019-04-05 15:28:33 -040013# From 2018-10-26
14SRCREV = "b9066c7717af1d169a616c9e61706b99ff8515b5"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050015# (when PV goes above 1.0 remove the trailing r)
16PV = "1.0+gitr${SRCPV}"
17
18S = "${WORKDIR}/git"
19
Brad Bishop6e60e8b2018-02-01 10:27:11 -050020DEPENDS = "libpng virtual/libx11 libxkbcommon libxrender waffle virtual/libgl libglu python3-mako-native python3-numpy-native python3-six-native virtual/egl"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050021
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080022inherit cmake pkgconfig python3native distro_features_check bash-completion
Patrick Williamsc124f4f2015-09-15 14:41:29 -050023# depends on virtual/libx11
24REQUIRED_DISTRO_FEATURES = "x11"
25
Brad Bishop6e60e8b2018-02-01 10:27:11 -050026# depends on virtual/libgl
27REQUIRED_DISTRO_FEATURES += "opengl"
28
Patrick Williamsf1e5d692016-03-30 15:21:19 -050029# The built scripts go into the temporary directory according to tempfile
30# (typically /tmp) which can race if multiple builds happen on the same machine,
31# so tell it to use a directory in ${B} to avoid overwriting.
32export TEMP = "${B}/temp/"
33do_compile[dirs] =+ "${B}/temp/"
34
Patrick Williamsc124f4f2015-09-15 14:41:29 -050035PACKAGECONFIG ??= ""
36PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
37
38do_configure_prepend() {
39 if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
40 sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
41 sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h
42 fi
43}
44
Brad Bishop316dfdd2018-06-25 12:45:53 -040045OECMAKE_TARGET_INSTALL = "install/strip"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060046
Brad Bishopa5c52ff2018-11-23 10:55:50 +130047RDEPENDS_${PN} = "waffle waffle-bin python3 python3-mako python3-json \
Brad Bishop316dfdd2018-06-25 12:45:53 -040048 python3-misc \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060049 python3-unixadmin python3-xml python3-multiprocessing \
Brad Bishop316dfdd2018-06-25 12:45:53 -040050 python3-six python3-shell python3-io \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050051 python3-netserver mesa-demos bash \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050052 "
53
Patrick Williamsc0f7c042017-02-23 20:41:17 -060054INSANE_SKIP_${PN} += "dev-so already-stripped"
Brad Bishop19323692019-04-05 15:28:33 -040055
56# Can't be built with ccache
57CCACHE_DISABLE = "1"