blob: 6582f97151389639cbbc483b524cc16a6bf3c24f [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001# This class is used to check recipes against public CVEs.
2#
3# In order to use this class just inherit the class in the
4# local.conf file and it will add the cve_check task for
5# every recipe. The task can be used per recipe, per image,
6# or using the special cases "world" and "universe". The
7# cve_check task will print a warning for every unpatched
8# CVE found and generate a file in the recipe WORKDIR/cve
9# directory. If an image is build it will generate a report
10# in DEPLOY_DIR_IMAGE for all the packages used.
11#
12# Example:
13# bitbake -c cve_check openssl
14# bitbake core-image-sato
15# bitbake -k -c cve_check universe
16#
17# DISCLAIMER
18#
19# This class/tool is meant to be used as support and not
20# the only method to check against CVEs. Running this tool
21# doesn't guarantee your packages are free of CVEs.
22
Patrick Williams213cb262021-08-07 19:21:33 -050023# The product name that the CVE database uses defaults to BPN, but may need to
Brad Bishop37a0e4d2017-12-04 01:01:44 -050024# be overriden per recipe (for example tiff.bb sets CVE_PRODUCT=libtiff).
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025CVE_PRODUCT ??= "${BPN}"
Brad Bishop316dfdd2018-06-25 12:45:53 -040026CVE_VERSION ??= "${PV}"
Brad Bishop37a0e4d2017-12-04 01:01:44 -050027
Patrick Williamsc0f7c042017-02-23 20:41:17 -060028CVE_CHECK_DB_DIR ?= "${DL_DIR}/CVE_CHECK"
Andrew Geissler82c905d2020-04-13 13:39:40 -050029CVE_CHECK_DB_FILE ?= "${CVE_CHECK_DB_DIR}/nvdcve_1.1.db"
Andrew Geisslerc9f78652020-09-18 14:11:35 -050030CVE_CHECK_DB_FILE_LOCK ?= "${CVE_CHECK_DB_FILE}.lock"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060031
Brad Bishop316dfdd2018-06-25 12:45:53 -040032CVE_CHECK_LOG ?= "${T}/cve.log"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060033CVE_CHECK_TMP_FILE ?= "${TMPDIR}/cve_check"
Andrew Geisslerb7d28612020-07-24 16:15:54 -050034CVE_CHECK_SUMMARY_DIR ?= "${LOG_DIR}/cve"
35CVE_CHECK_SUMMARY_FILE_NAME ?= "cve-summary"
36CVE_CHECK_SUMMARY_FILE ?= "${CVE_CHECK_SUMMARY_DIR}/${CVE_CHECK_SUMMARY_FILE_NAME}"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060037
38CVE_CHECK_DIR ??= "${DEPLOY_DIR}/cve"
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050039CVE_CHECK_RECIPE_FILE ?= "${CVE_CHECK_DIR}/${PN}"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060040CVE_CHECK_MANIFEST ?= "${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}${IMAGE_NAME_SUFFIX}.cve"
41CVE_CHECK_COPY_FILES ??= "1"
42CVE_CHECK_CREATE_MANIFEST ??= "1"
43
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050044CVE_CHECK_REPORT_PATCHED ??= "1"
45
Patrick Williamsc0f7c042017-02-23 20:41:17 -060046# Whitelist for packages (PN)
Brad Bishop96ff1982019-08-19 13:50:42 -040047CVE_CHECK_PN_WHITELIST ?= ""
Patrick Williamsc0f7c042017-02-23 20:41:17 -060048
Brad Bishop96ff1982019-08-19 13:50:42 -040049# Whitelist for CVE. If a CVE is found, then it is considered patched.
50# The value is a string containing space separated CVE values:
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050051#
Brad Bishop96ff1982019-08-19 13:50:42 -040052# CVE_CHECK_WHITELIST = 'CVE-2014-2524 CVE-2018-1234'
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050053#
Brad Bishop96ff1982019-08-19 13:50:42 -040054CVE_CHECK_WHITELIST ?= ""
Patrick Williamsc0f7c042017-02-23 20:41:17 -060055
Andrew Geisslerd1e89492021-02-12 15:35:20 -060056# Layers to be excluded
57CVE_CHECK_LAYER_EXCLUDELIST ??= ""
58
Patrick Williams213cb262021-08-07 19:21:33 -050059# Layers to be included
Andrew Geisslerd1e89492021-02-12 15:35:20 -060060CVE_CHECK_LAYER_INCLUDELIST ??= ""
61
62
Patrick Williams213cb262021-08-07 19:21:33 -050063# set to "alphabetical" for version using single alphabetical character as increment release
Andrew Geisslerd1e89492021-02-12 15:35:20 -060064CVE_VERSION_SUFFIX ??= ""
65
Andrew Geisslerb7d28612020-07-24 16:15:54 -050066python cve_save_summary_handler () {
67 import shutil
68 import datetime
69
70 cve_tmp_file = d.getVar("CVE_CHECK_TMP_FILE")
71
72 cve_summary_name = d.getVar("CVE_CHECK_SUMMARY_FILE_NAME")
73 cvelogpath = d.getVar("CVE_CHECK_SUMMARY_DIR")
74 bb.utils.mkdirhier(cvelogpath)
75
76 timestamp = datetime.datetime.now().strftime('%Y%m%d%H%M%S')
77 cve_summary_file = os.path.join(cvelogpath, "%s-%s.txt" % (cve_summary_name, timestamp))
78
Andrew Geisslerc9f78652020-09-18 14:11:35 -050079 if os.path.exists(cve_tmp_file):
80 shutil.copyfile(cve_tmp_file, cve_summary_file)
Andrew Geisslerb7d28612020-07-24 16:15:54 -050081
Andrew Geisslerc9f78652020-09-18 14:11:35 -050082 if cve_summary_file and os.path.exists(cve_summary_file):
83 cvefile_link = os.path.join(cvelogpath, cve_summary_name)
Andrew Geisslerb7d28612020-07-24 16:15:54 -050084
Andrew Geisslerc9f78652020-09-18 14:11:35 -050085 if os.path.exists(os.path.realpath(cvefile_link)):
86 os.remove(cvefile_link)
87 os.symlink(os.path.basename(cve_summary_file), cvefile_link)
Andrew Geisslerb7d28612020-07-24 16:15:54 -050088}
89
90addhandler cve_save_summary_handler
91cve_save_summary_handler[eventmask] = "bb.event.BuildCompleted"
92
Patrick Williamsc0f7c042017-02-23 20:41:17 -060093python do_cve_check () {
94 """
95 Check recipe for patched and unpatched CVEs
96 """
97
Brad Bishop96ff1982019-08-19 13:50:42 -040098 if os.path.exists(d.getVar("CVE_CHECK_DB_FILE")):
Andrew Geissler82c905d2020-04-13 13:39:40 -050099 try:
100 patched_cves = get_patches_cves(d)
101 except FileNotFoundError:
102 bb.fatal("Failure in searching patches")
103 whitelisted, patched, unpatched = check_cves(d, patched_cves)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600104 if patched or unpatched:
105 cve_data = get_cve_info(d, patched + unpatched)
Andrew Geissler82c905d2020-04-13 13:39:40 -0500106 cve_write_data(d, patched, unpatched, whitelisted, cve_data)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600107 else:
Brad Bishop96ff1982019-08-19 13:50:42 -0400108 bb.note("No CVE database found, skipping CVE check")
109
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600110}
111
Andrew Geissler1e34c2d2020-05-29 16:02:59 -0500112addtask cve_check before do_build after do_fetch
Andrew Geisslerc9f78652020-09-18 14:11:35 -0500113do_cve_check[depends] = "cve-update-db-native:do_fetch"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600114do_cve_check[nostamp] = "1"
115
116python cve_check_cleanup () {
117 """
118 Delete the file used to gather all the CVE information.
119 """
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500120 bb.utils.remove(e.data.getVar("CVE_CHECK_TMP_FILE"))
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600121}
122
123addhandler cve_check_cleanup
124cve_check_cleanup[eventmask] = "bb.cooker.CookerExit"
125
126python cve_check_write_rootfs_manifest () {
127 """
128 Create CVE manifest when building an image
129 """
130
131 import shutil
132
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500133 if d.getVar("CVE_CHECK_COPY_FILES") == "1":
Andrew Geisslerc3d88e42020-10-02 09:45:00 -0500134 deploy_file = d.getVar("CVE_CHECK_RECIPE_FILE")
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500135 if os.path.exists(deploy_file):
136 bb.utils.remove(deploy_file)
137
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500138 if os.path.exists(d.getVar("CVE_CHECK_TMP_FILE")):
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600139 bb.note("Writing rootfs CVE manifest")
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500140 deploy_dir = d.getVar("DEPLOY_DIR_IMAGE")
141 link_name = d.getVar("IMAGE_LINK_NAME")
142 manifest_name = d.getVar("CVE_CHECK_MANIFEST")
143 cve_tmp_file = d.getVar("CVE_CHECK_TMP_FILE")
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600144
145 shutil.copyfile(cve_tmp_file, manifest_name)
146
147 if manifest_name and os.path.exists(manifest_name):
148 manifest_link = os.path.join(deploy_dir, "%s.cve" % link_name)
149 # If we already have another manifest, update symlinks
150 if os.path.exists(os.path.realpath(manifest_link)):
151 os.remove(manifest_link)
152 os.symlink(os.path.basename(manifest_name), manifest_link)
153 bb.plain("Image CVE report stored in: %s" % manifest_name)
154}
155
Patrick Williams213cb262021-08-07 19:21:33 -0500156ROOTFS_POSTPROCESS_COMMAND:prepend = "${@'cve_check_write_rootfs_manifest; ' if d.getVar('CVE_CHECK_CREATE_MANIFEST') == '1' else ''}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500157do_rootfs[recrdeptask] += "${@'do_cve_check' if d.getVar('CVE_CHECK_CREATE_MANIFEST') == '1' else ''}"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600158
159def get_patches_cves(d):
160 """
161 Get patches that solve CVEs using the "CVE: " tag.
162 """
163
164 import re
165
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500166 pn = d.getVar("PN")
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600167 cve_match = re.compile("CVE:( CVE\-\d{4}\-\d+)+")
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500168
Patrick Williams213cb262021-08-07 19:21:33 -0500169 # Matches the last "CVE-YYYY-ID" in the file name, also if written
170 # in lowercase. Possible to have multiple CVE IDs in a single
171 # file name, but only the last one will be detected from the file name.
172 # However, patch files contents addressing multiple CVE IDs are supported
173 # (cve_match regular expression)
174
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500175 cve_file_name_match = re.compile(".*([Cc][Vv][Ee]\-\d{4}\-\d+)")
176
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600177 patched_cves = set()
178 bb.debug(2, "Looking for patches that solves CVEs for %s" % pn)
179 for url in src_patches(d):
180 patch_file = bb.fetch.decodeurl(url)[2]
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500181
Andrew Geissler82c905d2020-04-13 13:39:40 -0500182 if not os.path.isfile(patch_file):
183 bb.error("File Not found: %s" % patch_file)
184 raise FileNotFoundError
185
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500186 # Check patch file name for CVE ID
187 fname_match = cve_file_name_match.search(patch_file)
188 if fname_match:
189 cve = fname_match.group(1).upper()
190 patched_cves.add(cve)
191 bb.debug(2, "Found CVE %s from patch file name %s" % (cve, patch_file))
192
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600193 with open(patch_file, "r", encoding="utf-8") as f:
194 try:
195 patch_text = f.read()
196 except UnicodeDecodeError:
197 bb.debug(1, "Failed to read patch %s using UTF-8 encoding"
198 " trying with iso8859-1" % patch_file)
199 f.close()
200 with open(patch_file, "r", encoding="iso8859-1") as f:
201 patch_text = f.read()
202
Brad Bishopbba38f32018-08-23 16:11:46 +0800203 # Search for one or more "CVE: " lines
204 text_match = False
205 for match in cve_match.finditer(patch_text):
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600206 # Get only the CVEs without the "CVE: " tag
207 cves = patch_text[match.start()+5:match.end()]
208 for cve in cves.split():
209 bb.debug(2, "Patch %s solves %s" % (patch_file, cve))
210 patched_cves.add(cve)
Brad Bishopbba38f32018-08-23 16:11:46 +0800211 text_match = True
212
213 if not fname_match and not text_match:
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600214 bb.debug(2, "Patch %s doesn't solve CVEs" % patch_file)
215
216 return patched_cves
217
218def check_cves(d, patched_cves):
219 """
Brad Bishopf3fd2882019-06-21 08:06:37 -0400220 Connect to the NVD database and find unpatched cves.
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600221 """
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600222 from oe.cve_check import Version
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600223
Andrew Geissler6ce62a22020-11-30 19:58:47 -0600224 pn = d.getVar("PN")
225 real_pv = d.getVar("PV")
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600226 suffix = d.getVar("CVE_VERSION_SUFFIX")
Andrew Geissler6ce62a22020-11-30 19:58:47 -0600227
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600228 cves_unpatched = []
Brad Bishopf3fd2882019-06-21 08:06:37 -0400229 # CVE_PRODUCT can contain more than one product (eg. curl/libcurl)
Brad Bishop96ff1982019-08-19 13:50:42 -0400230 products = d.getVar("CVE_PRODUCT").split()
Brad Bishop316dfdd2018-06-25 12:45:53 -0400231 # If this has been unset then we're not scanning for CVEs here (for example, image recipes)
Brad Bishop96ff1982019-08-19 13:50:42 -0400232 if not products:
Andrew Geissler82c905d2020-04-13 13:39:40 -0500233 return ([], [], [])
Brad Bishop316dfdd2018-06-25 12:45:53 -0400234 pv = d.getVar("CVE_VERSION").split("+git")[0]
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600235
Patrick Williams213cb262021-08-07 19:21:33 -0500236 # If the recipe has been whitelisted we return empty lists
Andrew Geissler6ce62a22020-11-30 19:58:47 -0600237 if pn in d.getVar("CVE_CHECK_PN_WHITELIST").split():
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600238 bb.note("Recipe has been whitelisted, skipping check")
Andrew Geissler82c905d2020-04-13 13:39:40 -0500239 return ([], [], [])
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600240
Brad Bishop96ff1982019-08-19 13:50:42 -0400241 old_cve_whitelist = d.getVar("CVE_CHECK_CVE_WHITELIST")
242 if old_cve_whitelist:
243 bb.warn("CVE_CHECK_CVE_WHITELIST is deprecated, please use CVE_CHECK_WHITELIST.")
244 cve_whitelist = d.getVar("CVE_CHECK_WHITELIST").split()
245
Brad Bishopf3fd2882019-06-21 08:06:37 -0400246 import sqlite3
Brad Bishop6dbb3162019-11-25 09:41:34 -0500247 db_file = d.expand("file:${CVE_CHECK_DB_FILE}?mode=ro")
248 conn = sqlite3.connect(db_file, uri=True)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600249
Brad Bishop6dbb3162019-11-25 09:41:34 -0500250 # For each of the known product names (e.g. curl has CPEs using curl and libcurl)...
Brad Bishop96ff1982019-08-19 13:50:42 -0400251 for product in products:
Brad Bishop96ff1982019-08-19 13:50:42 -0400252 if ":" in product:
253 vendor, product = product.split(":", 1)
Brad Bishop96ff1982019-08-19 13:50:42 -0400254 else:
Brad Bishop6dbb3162019-11-25 09:41:34 -0500255 vendor = "%"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600256
Brad Bishop6dbb3162019-11-25 09:41:34 -0500257 # Find all relevant CVE IDs.
258 for cverow in conn.execute("SELECT DISTINCT ID FROM PRODUCTS WHERE PRODUCT IS ? AND VENDOR LIKE ?", (product, vendor)):
259 cve = cverow[0]
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600260
Brad Bishop96ff1982019-08-19 13:50:42 -0400261 if cve in cve_whitelist:
262 bb.note("%s-%s has been whitelisted for %s" % (product, pv, cve))
Brad Bishop64c979e2019-11-04 13:55:29 -0500263 # TODO: this should be in the report as 'whitelisted'
264 patched_cves.add(cve)
Brad Bishop6dbb3162019-11-25 09:41:34 -0500265 continue
Brad Bishopf3fd2882019-06-21 08:06:37 -0400266 elif cve in patched_cves:
267 bb.note("%s has been patched" % (cve))
Brad Bishop6dbb3162019-11-25 09:41:34 -0500268 continue
269
270 vulnerable = False
271 for row in conn.execute("SELECT * FROM PRODUCTS WHERE ID IS ? AND PRODUCT IS ? AND VENDOR LIKE ?", (cve, product, vendor)):
272 (_, _, _, version_start, operator_start, version_end, operator_end) = row
273 #bb.debug(2, "Evaluating row " + str(row))
274
Andrew Geissler82c905d2020-04-13 13:39:40 -0500275 if (operator_start == '=' and pv == version_start) or version_start == '-':
Brad Bishop6dbb3162019-11-25 09:41:34 -0500276 vulnerable = True
Brad Bishop96ff1982019-08-19 13:50:42 -0400277 else:
278 if operator_start:
279 try:
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600280 vulnerable_start = (operator_start == '>=' and Version(pv,suffix) >= Version(version_start,suffix))
281 vulnerable_start |= (operator_start == '>' and Version(pv,suffix) > Version(version_start,suffix))
Brad Bishop96ff1982019-08-19 13:50:42 -0400282 except:
Brad Bishop64c979e2019-11-04 13:55:29 -0500283 bb.warn("%s: Failed to compare %s %s %s for %s" %
Brad Bishop96ff1982019-08-19 13:50:42 -0400284 (product, pv, operator_start, version_start, cve))
Brad Bishop6dbb3162019-11-25 09:41:34 -0500285 vulnerable_start = False
Brad Bishop96ff1982019-08-19 13:50:42 -0400286 else:
Brad Bishop6dbb3162019-11-25 09:41:34 -0500287 vulnerable_start = False
Brad Bishop96ff1982019-08-19 13:50:42 -0400288
289 if operator_end:
290 try:
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600291 vulnerable_end = (operator_end == '<=' and Version(pv,suffix) <= Version(version_end,suffix) )
292 vulnerable_end |= (operator_end == '<' and Version(pv,suffix) < Version(version_end,suffix) )
Brad Bishop96ff1982019-08-19 13:50:42 -0400293 except:
Brad Bishop64c979e2019-11-04 13:55:29 -0500294 bb.warn("%s: Failed to compare %s %s %s for %s" %
Brad Bishop96ff1982019-08-19 13:50:42 -0400295 (product, pv, operator_end, version_end, cve))
Brad Bishop6dbb3162019-11-25 09:41:34 -0500296 vulnerable_end = False
Brad Bishop96ff1982019-08-19 13:50:42 -0400297 else:
Brad Bishop6dbb3162019-11-25 09:41:34 -0500298 vulnerable_end = False
Brad Bishop96ff1982019-08-19 13:50:42 -0400299
300 if operator_start and operator_end:
Brad Bishop6dbb3162019-11-25 09:41:34 -0500301 vulnerable = vulnerable_start and vulnerable_end
Brad Bishop96ff1982019-08-19 13:50:42 -0400302 else:
Brad Bishop6dbb3162019-11-25 09:41:34 -0500303 vulnerable = vulnerable_start or vulnerable_end
Brad Bishop96ff1982019-08-19 13:50:42 -0400304
Brad Bishop6dbb3162019-11-25 09:41:34 -0500305 if vulnerable:
Andrew Geissler6ce62a22020-11-30 19:58:47 -0600306 bb.note("%s-%s is vulnerable to %s" % (pn, real_pv, cve))
Brad Bishop96ff1982019-08-19 13:50:42 -0400307 cves_unpatched.append(cve)
Brad Bishop6dbb3162019-11-25 09:41:34 -0500308 break
309
310 if not vulnerable:
Andrew Geissler6ce62a22020-11-30 19:58:47 -0600311 bb.note("%s-%s is not vulnerable to %s" % (pn, real_pv, cve))
Brad Bishop6dbb3162019-11-25 09:41:34 -0500312 # TODO: not patched but not vulnerable
313 patched_cves.add(cve)
314
Brad Bishopf3fd2882019-06-21 08:06:37 -0400315 conn.close()
316
Andrew Geissler82c905d2020-04-13 13:39:40 -0500317 return (list(cve_whitelist), list(patched_cves), cves_unpatched)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600318
319def get_cve_info(d, cves):
320 """
Brad Bishop96ff1982019-08-19 13:50:42 -0400321 Get CVE information from the database.
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600322 """
323
Brad Bishop6dbb3162019-11-25 09:41:34 -0500324 import sqlite3
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600325
326 cve_data = {}
Brad Bishop6dbb3162019-11-25 09:41:34 -0500327 conn = sqlite3.connect(d.getVar("CVE_CHECK_DB_FILE"))
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600328
Brad Bishop6dbb3162019-11-25 09:41:34 -0500329 for cve in cves:
330 for row in conn.execute("SELECT * FROM NVD WHERE ID IS ?", (cve,)):
331 cve_data[row[0]] = {}
332 cve_data[row[0]]["summary"] = row[1]
333 cve_data[row[0]]["scorev2"] = row[2]
334 cve_data[row[0]]["scorev3"] = row[3]
335 cve_data[row[0]]["modified"] = row[4]
336 cve_data[row[0]]["vector"] = row[5]
337
338 conn.close()
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600339 return cve_data
340
Andrew Geissler82c905d2020-04-13 13:39:40 -0500341def cve_write_data(d, patched, unpatched, whitelisted, cve_data):
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600342 """
343 Write CVE information in WORKDIR; and to CVE_CHECK_DIR, and
344 CVE manifest if enabled.
345 """
346
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600347
Brad Bishop316dfdd2018-06-25 12:45:53 -0400348 cve_file = d.getVar("CVE_CHECK_LOG")
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600349 fdir_name = d.getVar("FILE_DIRNAME")
350 layer = fdir_name.split("/")[-3]
351
352 include_layers = d.getVar("CVE_CHECK_LAYER_INCLUDELIST").split()
353 exclude_layers = d.getVar("CVE_CHECK_LAYER_EXCLUDELIST").split()
354
355 if exclude_layers and layer in exclude_layers:
356 return
357
358 if include_layers and layer not in include_layers:
359 return
360
Patrick Williams213cb262021-08-07 19:21:33 -0500361 nvd_link = "https://nvd.nist.gov/vuln/detail/"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600362 write_string = ""
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500363 unpatched_cves = []
Brad Bishop316dfdd2018-06-25 12:45:53 -0400364 bb.utils.mkdirhier(os.path.dirname(cve_file))
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600365
366 for cve in sorted(cve_data):
Andrew Geisslerc3d88e42020-10-02 09:45:00 -0500367 is_patched = cve in patched
368 if is_patched and (d.getVar("CVE_CHECK_REPORT_PATCHED") != "1"):
369 continue
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600370 write_string += "LAYER: %s\n" % layer
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500371 write_string += "PACKAGE NAME: %s\n" % d.getVar("PN")
Andrew Geissler4ed12e12020-06-05 18:00:41 -0500372 write_string += "PACKAGE VERSION: %s%s\n" % (d.getVar("EXTENDPE"), d.getVar("PV"))
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600373 write_string += "CVE: %s\n" % cve
Andrew Geissler82c905d2020-04-13 13:39:40 -0500374 if cve in whitelisted:
375 write_string += "CVE STATUS: Whitelisted\n"
Andrew Geisslerc3d88e42020-10-02 09:45:00 -0500376 elif is_patched:
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600377 write_string += "CVE STATUS: Patched\n"
378 else:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500379 unpatched_cves.append(cve)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600380 write_string += "CVE STATUS: Unpatched\n"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600381 write_string += "CVE SUMMARY: %s\n" % cve_data[cve]["summary"]
Brad Bishopf3fd2882019-06-21 08:06:37 -0400382 write_string += "CVSS v2 BASE SCORE: %s\n" % cve_data[cve]["scorev2"]
383 write_string += "CVSS v3 BASE SCORE: %s\n" % cve_data[cve]["scorev3"]
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600384 write_string += "VECTOR: %s\n" % cve_data[cve]["vector"]
385 write_string += "MORE INFORMATION: %s%s\n\n" % (nvd_link, cve)
386
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500387 if unpatched_cves:
388 bb.warn("Found unpatched CVE (%s), for more information check %s" % (" ".join(unpatched_cves),cve_file))
389
Andrew Geisslerc3d88e42020-10-02 09:45:00 -0500390 if write_string:
391 with open(cve_file, "w") as f:
392 bb.note("Writing file %s with CVE information" % cve_file)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600393 f.write(write_string)
394
Andrew Geisslerc3d88e42020-10-02 09:45:00 -0500395 if d.getVar("CVE_CHECK_COPY_FILES") == "1":
396 deploy_file = d.getVar("CVE_CHECK_RECIPE_FILE")
397 bb.utils.mkdirhier(os.path.dirname(deploy_file))
398 with open(deploy_file, "w") as f:
399 f.write(write_string)
Andrew Geisslerb7d28612020-07-24 16:15:54 -0500400
Andrew Geisslerc3d88e42020-10-02 09:45:00 -0500401 if d.getVar("CVE_CHECK_CREATE_MANIFEST") == "1":
402 cvelogpath = d.getVar("CVE_CHECK_SUMMARY_DIR")
403 bb.utils.mkdirhier(cvelogpath)
404
405 with open(d.getVar("CVE_CHECK_TMP_FILE"), "a") as f:
406 f.write("%s" % write_string)