blob: 603d3f9eeedc5e1bc792213affe61260ff5de116 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Performance analysis tools for Linux"
2DESCRIPTION = "Performance counters for Linux are a new kernel-based \
3subsystem that provide a framework for all things \
4performance analysis. It covers hardware level \
5(CPU/PMU, Performance Monitoring Unit) features \
6and software features (software counters, tracepoints) \
7as well."
Joel Stanleye252c312017-12-14 15:11:12 +10308HOMEPAGE = "https://perf.wiki.kernel.org/index.php/Main_Page"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05009
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000010LICENSE = "GPL-2.0-only"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050011
12PR = "r9"
13
Joel Stanleye252c312017-12-14 15:11:12 +103014PACKAGECONFIG ??= "scripting tui libunwind"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015PACKAGECONFIG[dwarf] = ",NO_DWARF=1"
Brad Bishop79641f22019-09-10 07:20:22 -040016PACKAGECONFIG[scripting] = ",NO_LIBPERL=1 NO_LIBPYTHON=1,perl python3"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050017# gui support was added with kernel 3.6.35
18# since 3.10 libnewt was replaced by slang
19# to cover a wide range of kernel we add both dependencies
Joel Stanleye252c312017-12-14 15:11:12 +103020PACKAGECONFIG[tui] = ",NO_NEWT=1,libnewt slang"
21PACKAGECONFIG[libunwind] = ",NO_LIBUNWIND=1 NO_LIBDW_DWARF_UNWIND=1,libunwind"
22PACKAGECONFIG[libnuma] = ",NO_LIBNUMA=1"
23PACKAGECONFIG[systemtap] = ",NO_SDT=1,systemtap"
24PACKAGECONFIG[jvmti] = ",NO_JVMTI=1"
Brad Bishop316dfdd2018-06-25 12:45:53 -040025# libaudit support would need scripting to be enabled
26PACKAGECONFIG[audit] = ",NO_LIBAUDIT=1,audit"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080027PACKAGECONFIG[manpages] = ",,xmlto-native asciidoc-native"
Brad Bishop64c979e2019-11-04 13:55:29 -050028PACKAGECONFIG[cap] = ",,libcap"
Andrew Geisslerb7d28612020-07-24 16:15:54 -050029# Arm CoreSight
30PACKAGECONFIG[coresight] = "CORESIGHT=1,,opencsd"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031
32# libunwind is not yet ported for some architectures
Patrick Williams213cb262021-08-07 19:21:33 -050033PACKAGECONFIG:remove:arc = "libunwind"
Patrick Williams213cb262021-08-07 19:21:33 -050034PACKAGECONFIG:remove:riscv32 = "libunwind"
Brad Bishop316dfdd2018-06-25 12:45:53 -040035
Patrick Williamsc124f4f2015-09-15 14:41:29 -050036DEPENDS = " \
37 virtual/${MLPREFIX}libc \
38 ${MLPREFIX}elfutils \
39 ${MLPREFIX}binutils \
Brad Bishop316dfdd2018-06-25 12:45:53 -040040 bison-native flex-native xz \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050041"
42
43do_configure[depends] += "virtual/kernel:do_shared_workdir"
44
45PROVIDES = "virtual/perf"
46
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080047inherit linux-kernel-base kernel-arch manpages
Patrick Williamsc124f4f2015-09-15 14:41:29 -050048
49# needed for building the tools/perf Python bindings
Andrew Geissler09036742021-06-25 14:25:14 -050050inherit ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'python3targetconfig', '', d)}
Brad Bishop79641f22019-09-10 07:20:22 -040051inherit python3-dir
Patrick Williamsc124f4f2015-09-15 14:41:29 -050052export PYTHON_SITEPACKAGES_DIR
53
54#kernel 3.1+ supports WERROR to disable warnings as errors
55export WERROR = "0"
56
Andrew Geissler82c905d2020-04-13 13:39:40 -050057do_populate_lic[depends] += "virtual/kernel:do_shared_workdir"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050058
59# needed for building the tools/perf Perl binding
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080060include ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'perf-perl.inc', '', d)}
Patrick Williamsc124f4f2015-09-15 14:41:29 -050061
62inherit kernelsrc
63
Brad Bishop316dfdd2018-06-25 12:45:53 -040064S = "${WORKDIR}/${BP}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050065SPDX_S = "${S}/tools/perf"
66
Patrick Williamsc124f4f2015-09-15 14:41:29 -050067# The LDFLAGS is required or some old kernels fails due missing
68# symbols and this is preferred than requiring patches to every old
69# supported kernel.
70LDFLAGS="-ldl -lutil"
71
72EXTRA_OEMAKE = '\
Andrew Geissler635e0e42020-08-21 15:58:33 -050073 V=1 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050074 -C ${S}/tools/perf \
75 O=${B} \
76 CROSS_COMPILE=${TARGET_PREFIX} \
77 ARCH=${ARCH} \
78 CC="${CC}" \
Andrew Geissler82c905d2020-04-13 13:39:40 -050079 CCLD="${CC}" \
80 LDSHARED="${CC} -shared" \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050081 AR="${AR}" \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060082 LD="${LD}" \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050083 EXTRA_CFLAGS="-ldw" \
Andrew Geissler95ac1b82021-03-31 14:34:31 -050084 YFLAGS='-y --file-prefix-map=${WORKDIR}=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}' \
Joel Stanleye252c312017-12-14 15:11:12 +103085 EXTRA_LDFLAGS="${PERF_EXTRA_LDFLAGS}" \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050086 perfexecdir=${libexecdir} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080087 NO_GTK2=1 \
Joel Stanleye252c312017-12-14 15:11:12 +103088 ${PACKAGECONFIG_CONFARGS} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080089 TMPDIR="${B}" \
Brad Bishop19323692019-04-05 15:28:33 -040090 LIBUNWIND_DIR=${STAGING_EXECPREFIXDIR} \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050091'
92
93EXTRA_OEMAKE += "\
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050094 'DESTDIR=${D}' \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050095 'prefix=${prefix}' \
96 'bindir=${bindir}' \
97 'sharedir=${datadir}' \
98 'sysconfdir=${sysconfdir}' \
99 'perfexecdir=${libexecdir}/perf-core' \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500100 'ETC_PERFCONFIG=${@os.path.relpath(sysconfdir, prefix)}' \
101 'sharedir=${@os.path.relpath(datadir, prefix)}' \
102 'mandir=${@os.path.relpath(mandir, prefix)}' \
103 'infodir=${@os.path.relpath(infodir, prefix)}' \
Brad Bishop79641f22019-09-10 07:20:22 -0400104 ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'PYTHON=python3 PYTHON_CONFIG=python3-config', '', d)} \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500105"
106
Brad Bishopd5ae7d92018-06-14 09:52:03 -0700107# During do_configure, we might run a 'make clean'. That often breaks
108# when done in parallel, so disable parallelism for do_configure. Note
109# that it has to be done this way rather than by passing -j1, since
110# perf's build system by default ignores any -j argument, but does
111# honour a JOBS variable.
Patrick Williams213cb262021-08-07 19:21:33 -0500112EXTRA_OEMAKE:append:task-configure = " JOBS=1"
Brad Bishopd5ae7d92018-06-14 09:52:03 -0700113
Brad Bishop316dfdd2018-06-25 12:45:53 -0400114PERF_SRC ?= "Makefile \
Brad Bishop316dfdd2018-06-25 12:45:53 -0400115 tools/arch \
116 tools/build \
117 tools/include \
118 tools/lib \
119 tools/Makefile \
120 tools/perf \
121 tools/scripts \
Brad Bishop64c979e2019-11-04 13:55:29 -0500122 scripts/ \
123 arch/${ARCH}/Makefile \
Brad Bishop316dfdd2018-06-25 12:45:53 -0400124"
125
Joel Stanleye252c312017-12-14 15:11:12 +1030126PERF_EXTRA_LDFLAGS = ""
127
Andrew Geissler595f6302022-01-24 19:11:47 +0000128# MIPS N32/N64
Patrick Williams213cb262021-08-07 19:21:33 -0500129PERF_EXTRA_LDFLAGS:mipsarchn32eb = "-m elf32btsmipn32"
130PERF_EXTRA_LDFLAGS:mipsarchn32el = "-m elf32ltsmipn32"
Andrew Geissler595f6302022-01-24 19:11:47 +0000131PERF_EXTRA_LDFLAGS:mipsarchn64eb = "-m elf64btsmip"
132PERF_EXTRA_LDFLAGS:mipsarchn64el = "-m elf64ltsmip"
Joel Stanleye252c312017-12-14 15:11:12 +1030133
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500134do_compile() {
135 # Linux kernel build system is expected to do the right thing
136 unset CFLAGS
137 oe_runmake all
138}
139
140do_install() {
141 # Linux kernel build system is expected to do the right thing
142 unset CFLAGS
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500143 oe_runmake install
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500144 # we are checking for this make target to be compatible with older perf versions
Joel Stanleye252c312017-12-14 15:11:12 +1030145 if ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'true', 'false', d)} && grep -q install-python_ext ${S}/tools/perf/Makefile*; then
Brad Bishop79641f22019-09-10 07:20:22 -0400146 oe_runmake DESTDIR=${D} install-python_ext
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500147 fi
148}
149
Brad Bishop316dfdd2018-06-25 12:45:53 -0400150do_configure[prefuncs] += "copy_perf_source_from_kernel"
151python copy_perf_source_from_kernel() {
152 sources = (d.getVar("PERF_SRC") or "").split()
153 src_dir = d.getVar("STAGING_KERNEL_DIR")
154 dest_dir = d.getVar("S")
155 bb.utils.mkdirhier(dest_dir)
Andrew Geissler82c905d2020-04-13 13:39:40 -0500156 bb.utils.prunedir(dest_dir)
Brad Bishop316dfdd2018-06-25 12:45:53 -0400157 for s in sources:
158 src = oe.path.join(src_dir, s)
159 dest = oe.path.join(dest_dir, s)
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800160 if not os.path.exists(src):
161 bb.fatal("Path does not exist: %s. Maybe PERF_SRC does not match the kernel version." % src)
Brad Bishop316dfdd2018-06-25 12:45:53 -0400162 if os.path.isdir(src):
163 oe.path.copyhardlinktree(src, dest)
164 else:
Brad Bishop64c979e2019-11-04 13:55:29 -0500165 src_path = os.path.dirname(s)
166 os.makedirs(os.path.join(dest_dir,src_path),exist_ok=True)
Brad Bishop316dfdd2018-06-25 12:45:53 -0400167 bb.utils.copyfile(src, dest)
168}
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500169
Patrick Williams213cb262021-08-07 19:21:33 -0500170do_configure:prepend () {
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500171 # If building a multlib based perf, the incorrect library path will be
172 # detected by perf, since it triggers via: ifeq ($(ARCH),x86_64). In a 32 bit
William A. Kennington IIIac69b482021-06-02 12:28:27 -0700173 # build, with a 64 bit multilib, the arch won't match and the detection of a
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500174 # 64 bit build (and library) are not exected. To ensure that libraries are
175 # installed to the correct location, we can use the weak assignment in the
176 # config/Makefile.
177 #
178 # Also need to relocate .config-detected to $(OUTPUT)/config-detected
179 # for kernel sources that do not already do this
180 # as two builds (e.g. perf and lib32-perf from mutlilib can conflict
181 # with each other if its in the shared source directory
182 #
183 if [ -e "${S}/tools/perf/config/Makefile" ]; then
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600184 perfconfig="${S}/tools/perf/config/Makefile"
185 fi
186 if [ -e "${S}/tools/perf/Makefile.config" ]; then
187 perfconfig="${S}/tools/perf/Makefile.config"
188 fi
189 if [ -n "${perfconfig}" ]; then
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500190 # Match $(prefix)/$(lib) and $(prefix)/lib
191 sed -i -e 's,^libdir = \($(prefix)/.*lib\),libdir ?= \1,' \
192 -e 's,^perfexecdir = \(.*\),perfexecdir ?= \1,' \
193 -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600194 ${perfconfig}
195 fi
196 # The man pages installation is "$(INSTALL) -d -m 755 $(DESTDIR)$(man1dir)"
197 # in ${S}/tools/perf/Documentation/Makefile, if the mandir set to '?=', it
198 # will use the relative path 'share/man', in the way it will resulting in
199 # incorrect installation for man pages.
200 if [ -e "${S}/tools/perf/Documentation/Makefile" ]; then
201 sed -i 's,^mandir?=,mandir:=,' ${S}/tools/perf/Documentation/Makefile
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500202 fi
203 if [ -e "${S}/tools/perf/Makefile.perf" ]; then
204 sed -i -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
205 ${S}/tools/perf/Makefile.perf
206 sed -i -e "s,prefix='\$(DESTDIR_SQ)/usr'$,prefix='\$(DESTDIR_SQ)/usr' --install-lib='\$(DESTDIR)\$(PYTHON_SITEPACKAGES_DIR)',g" \
207 ${S}/tools/perf/Makefile.perf
Andrew Geissler635e0e42020-08-21 15:58:33 -0500208 # backport https://github.com/torvalds/linux/commit/e4ffd066ff440a57097e9140fa9e16ceef905de8
209 sed -i -e 's,\($(Q)$(SHELL) .$(arch_errno_tbl).\) $(CC) $(arch_errno_hdr_dir),\1 $(firstword $(CC)) $(arch_errno_hdr_dir),g' \
210 ${S}/tools/perf/Makefile.perf
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500211 fi
212 sed -i -e "s,--root='/\$(DESTDIR_SQ)',--prefix='\$(DESTDIR_SQ)/usr' --install-lib='\$(DESTDIR)\$(PYTHON_SITEPACKAGES_DIR)',g" \
Patrick Williamsd7e96312015-09-22 08:09:05 -0500213 ${S}/tools/perf/Makefile*
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500214
215 if [ -e "${S}/tools/build/Makefile.build" ]; then
216 sed -i -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
217 ${S}/tools/build/Makefile.build
218 fi
219
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500220 # start reproducibility substitutions
221 if [ -e "${S}/tools/perf/Makefile.config" ]; then
222 # The following line in the Makefle:
223 # override PYTHON := $(call get-executable-or-default,PYTHON,$(PYTHON_AUTO))
224 # "PYTHON" / "PYTHON_AUTO" have the full path as part of the variable. We've
225 # ensure that the environment is setup and we do not need the full path to be
226 # captured, since the symbol gets built into the executable, making it not
227 # reproducible.
228 sed -i -e 's,$(call get-executable-or-default\,PYTHON\,$(PYTHON_AUTO)),$(notdir $(call get-executable-or-default\,PYTHON\,$(PYTHON_AUTO))),g' \
229 ${S}/tools/perf/Makefile.config
230
Andrew Geissler615f2f12022-07-15 14:00:58 -0500231 # likewise with this substitution. Kernels with commit 18f2967418d031a39
232 # [perf tools: Use Python devtools for version autodetection rather than runtime]
233 # need this substitution for reproducibility.
234 sed -i -e 's,$(call get-executable-or-default\,PYTHON\,$(subst -config\,\,$(PYTHON_AUTO))),$(notdir $(call get-executable-or-default\,PYTHON\,$(subst -config\,\,$(PYTHON_AUTO)))),g' \
235 ${S}/tools/perf/Makefile.config
236
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500237 # The following line:
238 # srcdir_SQ = $(patsubst %tools/perf,tools/perf,$(subst ','\'',$(srcdir))),
239 # Captures the full src path of perf, which of course makes it not
240 # reproducible. We really only need the relative location 'tools/perf', so we
241 # change the Makefile line to remove everything before 'tools/perf'
242 sed -i -e "s%srcdir_SQ = \$(subst ','\\\'',\$(srcdir))%srcdir_SQ = \$(patsubst \%tools/perf,tools/perf,\$(subst ','\\\'',\$(srcdir)))%g" \
243 ${S}/tools/perf/Makefile.config
244 fi
245 if [ -e "${S}/tools/perf/tests/Build" ]; then
246 # OUTPUT is the full path, we have python on the path so we remove it from the
247 # definition. This is captured in the perf binary, so breaks reproducibility
248 sed -i -e 's,PYTHONPATH="BUILD_STR($(OUTPUT)python)",PYTHONPATH="BUILD_STR(python)",g' \
249 ${S}/tools/perf/tests/Build
250 fi
251 if [ -e "${S}/tools/perf/util/Build" ]; then
252 # To avoid bison generating #ifdefs that have captured paths, we make sure
253 # all the calls have YFLAGS, which contains prefix mapping information.
254 sed -i -e 's,$(BISON),$(BISON) $(YFLAGS),g' ${S}/tools/perf/util/Build
255 fi
256 if [ -e "${S}/scripts/Makefile.host" ]; then
257 # To avoid yacc (bison) generating #ifdefs that have captured paths, we make sure
258 # all the calls have YFLAGS, which contains prefix mapping information.
259 sed -i -e 's,$(YACC),$(YACC) $(YFLAGS),g' ${S}/scripts/Makefile.host
260 fi
261 if [ -e "${S}/tools/perf/pmu-events/Build" ]; then
262 target='$(OUTPUT)pmu-events/pmu-events.c $(V)'
263 replacement1='$(OUTPUT)pmu-events/pmu-events.c $(V)\n'
264 replacement2='\t$(srctree)/sort-pmuevents.py $(OUTPUT)pmu-events/pmu-events.c $(OUTPUT)pmu-events/pmu-events.c.new\n'
265 replacement3='\tcp $(OUTPUT)pmu-events/pmu-events.c.new $(OUTPUT)pmu-events/pmu-events.c'
266 sed -i -e "s,$target,$replacement1$replacement2$replacement3,g" \
267 "${S}/tools/perf/pmu-events/Build"
268 fi
269 # end reproducibility substitutions
270
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500271 # We need to ensure the --sysroot option in CC is preserved
272 if [ -e "${S}/tools/perf/Makefile.perf" ]; then
273 sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/perf/Makefile.perf
274 sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/perf/Makefile.perf
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600275 sed -i 's,LD = $(CROSS_COMPILE)ld,#LD,' ${S}/tools/perf/Makefile.perf
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500276 fi
277 if [ -e "${S}/tools/lib/api/Makefile" ]; then
278 sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/lib/api/Makefile
279 sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/lib/api/Makefile
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600280 sed -i 's,LD = $(CROSS_COMPILE)ld,#LD,' ${S}/tools/lib/api/Makefile
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500281 fi
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500282 if [ -e "${S}/tools/lib/subcmd/Makefile" ]; then
283 sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/lib/subcmd/Makefile
284 sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/lib/subcmd/Makefile
285 fi
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500286 if [ -e "${S}/tools/perf/config/feature-checks/Makefile" ]; then
287 sed -i 's,CC := $(CROSS_COMPILE)gcc -MD,CC += -MD,' ${S}/tools/perf/config/feature-checks/Makefile
288 fi
289 if [ -e "${S}/tools/build/Makefile.feature" ]; then
290 sed -i 's,CFLAGS=,CC="\$(CC)" CFLAGS=,' ${S}/tools/build/Makefile.feature
291 fi
292
293 # 3.17-rc1+ has a include issue for arm/powerpc. Temporarily sed in the appropriate include
294 if [ -e "${S}/tools/perf/arch/$ARCH/util/skip-callchain-idx.c" ]; then
295 sed -i 's,#include "util/callchain.h",#include "util/callchain.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/$ARCH/util/skip-callchain-idx.c
296 fi
297 if [ -e "${S}/tools/perf/arch/arm/util/unwind-libunwind.c" ] && [ -e "${S}/tools/perf/arch/arm/tests/dwarf-unwind.c" ]; then
298 sed -i 's,#include "tests/tests.h",#include "tests/tests.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/arm/tests/dwarf-unwind.c
299 sed -i 's,#include "perf_regs.h",#include "perf_regs.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/arm/util/unwind-libunwind.c
300 fi
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500301
302 # use /usr/bin/env instead of version specific python
Andrew Geissler82c905d2020-04-13 13:39:40 -0500303 for s in `find ${S}/tools/perf/ -name '*.py'` `find ${S}/scripts/ -name 'bpf_helpers_doc.py'`; do
304 sed -i -e "s,#!.*python.*,#!${USRBINPATH}/env python3," ${s}
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500305 done
Brad Bishop19323692019-04-05 15:28:33 -0400306
307 # unistd.h can be out of sync between libc-headers and the captured version in the perf source
308 # so we copy it from the sysroot unistd.h to the perf unistd.h
Brad Bishopc342db32019-05-15 21:57:59 -0400309 install -D -m0644 ${STAGING_INCDIR}/asm-generic/unistd.h ${S}/tools/include/uapi/asm-generic/unistd.h
Brad Bishop79641f22019-09-10 07:20:22 -0400310 install -D -m0644 ${STAGING_INCDIR}/asm-generic/unistd.h ${S}/include/uapi/asm-generic/unistd.h
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500311
312 # the fetcher is inhibited by the 'inherit kernelsrc', so we do a quick check and
313 # copy for a helper script we need
314 for p in $(echo ${FILESPATH} | tr ':' '\n'); do
315 if [ -e $p/sort-pmuevents.py ]; then
316 cp $p/sort-pmuevents.py ${S}
317 fi
318 done
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500319}
320
Patrick Williams213cb262021-08-07 19:21:33 -0500321python do_package:prepend() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500322 d.setVar('PKGV', d.getVar("KERNEL_VERSION").split("-")[0])
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500323}
324
325PACKAGE_ARCH = "${MACHINE_ARCH}"
326
327
328PACKAGES =+ "${PN}-archive ${PN}-tests ${PN}-perl ${PN}-python"
329
Patrick Williams213cb262021-08-07 19:21:33 -0500330RDEPENDS:${PN} += "elfutils bash"
331RDEPENDS:${PN}-archive =+ "bash"
332RDEPENDS:${PN}-python =+ "bash python3 python3-modules ${@bb.utils.contains('PACKAGECONFIG', 'audit', 'audit-python', '', d)}"
333RDEPENDS:${PN}-perl =+ "bash perl perl-modules"
334RDEPENDS:${PN}-tests =+ "python3 bash"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500335
Joel Stanleye252c312017-12-14 15:11:12 +1030336RSUGGESTS_SCRIPTING = "${@bb.utils.contains('PACKAGECONFIG', 'scripting', '${PN}-perl ${PN}-python', '',d)}"
Patrick Williams213cb262021-08-07 19:21:33 -0500337RSUGGESTS:${PN} += "${PN}-archive ${PN}-tests ${RSUGGESTS_SCRIPTING}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500338
Brad Bishop19323692019-04-05 15:28:33 -0400339FILES_SOLIBSDEV = ""
Patrick Williams213cb262021-08-07 19:21:33 -0500340FILES:${PN} += "${libexecdir}/perf-core ${exec_prefix}/libexec/perf-core ${libdir}/traceevent ${libdir}/libperf-jvmti.so"
341FILES:${PN}-archive = "${libdir}/perf/perf-core/perf-archive"
342FILES:${PN}-tests = "${libdir}/perf/perf-core/tests ${libexecdir}/perf-core/tests"
343FILES:${PN}-python = " \
Brad Bishop316dfdd2018-06-25 12:45:53 -0400344 ${PYTHON_SITEPACKAGES_DIR} \
345 ${libexecdir}/perf-core/scripts/python \
346 "
Patrick Williams213cb262021-08-07 19:21:33 -0500347FILES:${PN}-perl = "${libexecdir}/perf-core/scripts/perl"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500348
349
350INHIBIT_PACKAGE_DEBUG_SPLIT="1"
Patrick Williams213cb262021-08-07 19:21:33 -0500351DEBUG_OPTIMIZATION:append = " -Wno-error=maybe-uninitialized"