blob: 28a1524b54fbcc624c74ba9589e53bcd9e230724 [file] [log] [blame]
Ed Tanous9936f862022-09-19 09:13:20 -07001LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=9aa91e13d644326bf281924212862184"
Patrick Williams12fc9392021-08-06 09:16:53 -05002FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
Ed Tanousd9aea6f2019-01-11 16:26:13 -08003DEPENDS += "systemd"
Ed Tanous9936f862022-09-19 09:13:20 -07004SRCREV = "c3939dac2c060651361fc71516806f9ab8c38901"
5PV = "1.8.18+git${SRCPV}"
Ed Tanousd9aea6f2019-01-11 16:26:13 -08006
Patrick Williamsbb99d222022-01-24 15:55:09 -06007SRC_URI = "git://github.com/ipmitool/ipmitool.git;protocol=https;branch=master"
Alex Schendel6a69fe42023-06-20 19:42:53 -07008
9# Temporary patch for https://codeberg.org/IPMITool/ipmitool/pulls/1
10SRC_URI += " \
11 file://0001-Fru-Fix-edit-field-not-checking-area-existence.patch \
12"
13
Vernon Mauerye0b32cb2020-03-04 11:02:02 -080014# TODO: when a new company joins the OpenBMC project by signing
15# a CLA, if they have an enterprise number on file with the
16# IANA, the versioned file, $PWD/ipmitool/enterprise-numbers
17# needs to be updated to add their entry. The canonical
18# version of the file is locatede here:
19# https://www.iana.org/assignments/enterprise-numbers
20#
21# This file is manually downloaded so it can be versioned
22# instead of having the makefile download it during do_compile
Vernon Mauery5896a232019-04-23 15:31:51 -070023SRC_URI += " \
Vernon Mauerye0b32cb2020-03-04 11:02:02 -080024 file://enterprise-numbers \
Vernon Mauery5896a232019-04-23 15:31:51 -070025 "
26
Ed Tanous9936f862022-09-19 09:13:20 -070027S = "${WORKDIR}/git"
28
29EXTRA_OECONF:append = " --disable-ipmishell --enable-intf-dbus DEFAULT_INTF=dbus "
30
Patrick Williams12fc9392021-08-06 09:16:53 -050031do_compile:prepend() {
Vernon Mauerye0b32cb2020-03-04 11:02:02 -080032 # copy the SRC_URI version of enterprise-numbers
33 # to the build dir to prevent a fetch
James Feist19841272020-05-01 14:35:25 -070034 mkdir -p "${WORKDIR}/build"
Vernon Mauerye0b32cb2020-03-04 11:02:02 -080035 cp "${WORKDIR}/enterprise-numbers" "${WORKDIR}/build/enterprise-numbers"
36}
37
Ed Tanous9936f862022-09-19 09:13:20 -070038# make sure that the enterprise-numbers file gets installed in the root FS
Patrick Williamsc7d88022023-03-24 09:39:28 -050039FILES:${PN} += "${datadir}/misc/enterprise-numbers"