blob: 5db181ac147e3316a3104a0b6587d45c59d1be36 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Valgrind memory debugger and instrumentation framework"
2HOMEPAGE = "http://valgrind.org/"
3BUGTRACKER = "http://valgrind.org/support/bug_reports.html"
4LICENSE = "GPLv2 & GPLv2+ & BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
Andrew Geissler4ed12e12020-06-05 18:00:41 -05006 file://include/pub_tool_basics.h;beginline=6;endline=29;md5=41c410e8d3f305aee7aaa666b2e4f366 \
Brad Bishopc342db32019-05-15 21:57:59 -04007 file://include/valgrind.h;beginline=1;endline=56;md5=ad3b317f3286b6b704575d9efe6ca5df \
8 file://COPYING.DOCS;md5=24ea4c7092233849b4394699333b5c56"
9
Brad Bishop96ff1982019-08-19 13:50:42 -040010DEPENDS = " \
Brad Bishopc342db32019-05-15 21:57:59 -040011 ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'boost', '', d)} \
12 "
13
14SRC_URI = "https://sourceware.org/pub/valgrind/valgrind-${PV}.tar.bz2 \
15 file://fixed-perl-path.patch \
16 file://Added-support-for-PPC-instructions-mfatbu-mfatbl.patch \
17 file://run-ptest \
Brad Bishopa34c0302019-09-23 22:34:48 -040018 file://remove-for-aarch64 \
Brad Bishopc342db32019-05-15 21:57:59 -040019 file://0004-Fix-out-of-tree-builds.patch \
20 file://0005-Modify-vg_test-wrapper-to-support-PTEST-formats.patch \
21 file://0001-Remove-tests-that-fail-to-build-on-some-PPC32-config.patch \
22 file://use-appropriate-march-mcpu-mfpu-for-ARM-test-apps.patch \
23 file://avoid-neon-for-targets-which-don-t-support-it.patch \
24 file://valgrind-make-ld-XXX.so-strlen-intercept-optional.patch \
25 file://0001-makefiles-Drop-setting-mcpu-to-cortex-a8-on-arm-arch.patch \
26 file://0001-str_tester.c-Limit-rawmemchr-test-to-glibc.patch \
27 file://0001-sigqueue-Rename-_sifields-to-__si_fields-on-musl.patch \
28 file://0002-context-APIs-are-not-available-on-musl.patch \
29 file://0003-correct-include-directive-path-for-config.h.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040030 file://0005-tc20_verifywrap.c-Fake-__GLIBC_PREREQ-with-musl.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040031 file://0001-memcheck-arm64-Define-__THROW-if-not-already-defined.patch \
32 file://0002-memcheck-x86-Define-__THROW-if-not-defined.patch \
33 file://0003-tests-seg_override-Replace-__modify_ldt-with-syscall.patch \
34 file://0001-fix-opcode-not-supported-on-mips32-linux.patch \
35 file://0001-Guard-against-__GLIBC_PREREQ-for-musl-libc.patch \
36 file://0001-Make-local-functions-static-to-avoid-assembler-error.patch \
37 file://0001-Return-a-valid-exit_code-from-vg_regtest.patch \
38 file://0001-valgrind-filter_xml_frames-do-not-filter-usr.patch \
Andrew Geisslerc9f78652020-09-18 14:11:35 -050039 file://0001-memcheck-vgtests-remove-fullpath-after-flags.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050040 file://s390x_vec_op_t.patch \
41 file://0001-none-tests-fdleak_cmsg.stderr.exp-adjust-tmp-paths.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050042 file://0001-memcheck-tests-Fix-timerfd-syscall-test.patch \
Andrew Geissler4c19ea12020-10-27 13:52:24 -050043 file://0001-drd-Port-to-Fedora-33.patch \
44 file://0001-drd-musl-fix.patch \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060045 file://0001-helgrind-Intercept-libc-functions.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040046 "
Andrew Geisslerd25ed322020-06-27 00:28:28 -050047SRC_URI[md5sum] = "d1b153f1ab17cf1f311705e7a83ef589"
48SRC_URI[sha256sum] = "c91f3a2f7b02db0f3bc99479861656154d241d2fdb265614ba918cc6720a33ca"
Brad Bishopc342db32019-05-15 21:57:59 -040049UPSTREAM_CHECK_REGEX = "valgrind-(?P<pver>\d+(\.\d+)+)\.tar"
50
51COMPATIBLE_HOST = '(i.86|x86_64|arm|aarch64|mips|powerpc|powerpc64).*-linux'
52
Andrew Geisslerc9f78652020-09-18 14:11:35 -050053# patch 0001-memcheck-vgtests-remove-fullpath-after-flags.patch removes relative path
54# argument. Change expected stderr files accordingly.
55do_patch_append() {
56 bb.build.exec_func('do_sed_paths', d)
57}
58
59do_sed_paths() {
60 sed -i -e 's|tests/||' ${S}/memcheck/tests/badfree3.stderr.exp
61 sed -i -e 's|tests/||' ${S}/memcheck/tests/varinfo5.stderr.exp
62}
63
Brad Bishopc342db32019-05-15 21:57:59 -040064# valgrind supports armv7 and above
65COMPATIBLE_HOST_armv4 = 'null'
66COMPATIBLE_HOST_armv5 = 'null'
67COMPATIBLE_HOST_armv6 = 'null'
68
Andrew Geisslerd25ed322020-06-27 00:28:28 -050069# valgrind fails with powerpc soft-float
70COMPATIBLE_HOST_powerpc = "${@bb.utils.contains('TARGET_FPU', 'soft', 'null', '.*-linux', d)}"
71
Brad Bishopc342db32019-05-15 21:57:59 -040072# X32 isn't supported by valgrind at this time
73COMPATIBLE_HOST_linux-gnux32 = 'null'
74COMPATIBLE_HOST_linux-muslx32 = 'null'
75
76# Disable for some MIPS variants
77COMPATIBLE_HOST_mipsarchr6 = 'null'
78COMPATIBLE_HOST_linux-gnun32 = 'null'
79
80# Disable for powerpc64 with musl
81COMPATIBLE_HOST_libc-musl_powerpc64 = 'null'
82
Andrew Geissler82c905d2020-04-13 13:39:40 -050083# brokenseip is unfortunately required by ptests to pass
84inherit autotools-brokensep ptest multilib_header
Brad Bishopc342db32019-05-15 21:57:59 -040085
86EXTRA_OECONF = "--enable-tls --without-mpicc"
87EXTRA_OECONF += "${@['--enable-only32bit','--enable-only64bit'][d.getVar('SITEINFO_BITS') != '32']}"
88
89# valgrind checks host_cpu "armv7*)", so we need to over-ride the autotools.bbclass default --host option
90EXTRA_OECONF_append_arm = " --host=armv7${HOST_VENDOR}-${HOST_OS}"
91
92EXTRA_OEMAKE = "-w"
93
94CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl'"
95
96# valgrind likes to control its own optimisation flags. It generally defaults
97# to -O2 but uses -O0 for some specific test apps etc. Passing our own flags
98# (via CFLAGS) means we interfere with that. Only pass DEBUG_FLAGS to it
99# which fixes build path issue in DWARF.
100SELECTED_OPTIMIZATION = "${DEBUG_FLAGS}"
101
102do_configure_prepend () {
103 rm -rf ${S}/config.h
104 sed -i -e 's:$(abs_top_builddir):$(pkglibdir)/ptest:g' ${S}/none/tests/Makefile.am
105 sed -i -e 's:$(top_builddir):$(pkglibdir)/ptest:g' ${S}/memcheck/tests/Makefile.am
106}
107
108do_install_append () {
109 install -m 644 ${B}/default.supp ${D}/${libdir}/valgrind/
110 oe_multilib_header valgrind/config.h
111}
112
113VALGRINDARCH ?= "${TARGET_ARCH}"
114VALGRINDARCH_aarch64 = "arm64"
115VALGRINDARCH_x86-64 = "amd64"
116VALGRINDARCH_x86 = "x86"
117VALGRINDARCH_mips = "mips32"
118VALGRINDARCH_mipsel = "mips32"
119VALGRINDARCH_mips64el = "mips64"
120VALGRINDARCH_powerpc = "ppc"
121VALGRINDARCH_powerpc64 = "ppc64"
122VALGRINDARCH_powerpc64el = "ppc64le"
123
124INHIBIT_PACKAGE_STRIP_FILES = "${PKGD}${libdir}/valgrind/vgpreload_memcheck-${VALGRINDARCH}-linux.so"
125
126RDEPENDS_${PN} += "perl"
127
128# valgrind needs debug information for ld.so at runtime in order to
129# redirect functions like strlen.
130RRECOMMENDS_${PN} += "${TCLIBC}-dbg"
131
Brad Bishopa34c0302019-09-23 22:34:48 -0400132RDEPENDS_${PN}-ptest += " bash coreutils file \
133 gdb libgomp \
134 perl \
Andrew Geisslerc9f78652020-09-18 14:11:35 -0500135 perl-module-file-basename perl-module-file-glob perl-module-getopt-long \
136 perl-module-overloading \
Andrew Geissler82c905d2020-04-13 13:39:40 -0500137 procps sed ${PN}-dbg ${PN}-src"
Brad Bishopc342db32019-05-15 21:57:59 -0400138RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-utils"
139
140# One of the tests contains a bogus interpreter path on purpose.
141# Skip file dependency check
142SKIP_FILEDEPS_${PN}-ptest = '1'
143INSANE_SKIP_${PN}-ptest = "debug-deps"
144
145do_compile_ptest() {
146 oe_runmake check
147}
148
149do_install_ptest() {
150 chmod +x ${B}/tests/vg_regtest
151
152 # The test application binaries are not automatically installed.
153 # Grab them from the build directory.
154 #
155 # The regression tests require scripts and data files that are not
156 # copied to the build directory. They must be copied from the
157 # source directory.
158 saved_dir=$PWD
159 for parent_dir in ${S} ${B} ; do
160 cd $parent_dir
161
Brad Bishopc342db32019-05-15 21:57:59 -0400162 subdirs=" \
Brad Bishopa34c0302019-09-23 22:34:48 -0400163 .in_place \
Brad Bishopc342db32019-05-15 21:57:59 -0400164 cachegrind/tests \
165 callgrind/tests \
Brad Bishopa34c0302019-09-23 22:34:48 -0400166 dhat/tests \
Brad Bishopc342db32019-05-15 21:57:59 -0400167 drd/tests \
168 gdbserver_tests \
169 helgrind/tests \
Brad Bishopa34c0302019-09-23 22:34:48 -0400170 lackey/tests \
Brad Bishopc342db32019-05-15 21:57:59 -0400171 massif/tests \
172 memcheck/tests \
173 none/tests \
174 tests \
Brad Bishopa34c0302019-09-23 22:34:48 -0400175 exp-bbv/tests \
176 exp-dhat/tests \
177 exp-sgcheck/tests \
Brad Bishopc342db32019-05-15 21:57:59 -0400178 "
Brad Bishopc342db32019-05-15 21:57:59 -0400179 # Get the vg test scripts, filters, and expected files
180 for dir in $subdirs ; do
181 find $dir | cpio -pvdu ${D}${PTEST_PATH}
182 done
183 cd $saved_dir
184 done
185
Brad Bishopa34c0302019-09-23 22:34:48 -0400186 # The scripts reference config.h so add it to the top ptest dir.
187 cp ${B}/config.h ${D}${PTEST_PATH}
188 install -D ${WORKDIR}/remove-for-aarch64 ${D}${PTEST_PATH}
189
190 # Add an executable need by none/tests/bigcode
191 mkdir ${D}${PTEST_PATH}/perf
192 cp ${B}/perf/bigcode ${D}${PTEST_PATH}/perf
193
194 # Add an executable needed by memcheck/tests/vcpu_bz2
195 cp ${B}/perf/bz2 ${D}${PTEST_PATH}/perf
196
197 # Make the ptest dir look like the top level valgrind src dir
198 # This is checked by the gdbserver_tests/make_local_links script
199 mkdir ${D}${PTEST_PATH}/coregrind
200 cp ${B}/coregrind/vgdb ${D}${PTEST_PATH}/coregrind
201
202 # Add an executable needed by massif tests
203 cp ${B}/massif/ms_print ${D}${PTEST_PATH}/massif/ms_print
204
Brad Bishopc342db32019-05-15 21:57:59 -0400205 find ${D}${PTEST_PATH} \
Brad Bishopa34c0302019-09-23 22:34:48 -0400206 \( \
207 -name "Makefile*" \
Brad Bishopc342db32019-05-15 21:57:59 -0400208 -o -name "*.o" \
Brad Bishopa34c0302019-09-23 22:34:48 -0400209 \) \
Brad Bishopc342db32019-05-15 21:57:59 -0400210 -exec rm {} \;
Brad Bishopa34c0302019-09-23 22:34:48 -0400211
212 # These files need to be newer so touch them.
Brad Bishop15ae2502019-06-18 21:44:24 -0400213 touch ${D}${PTEST_PATH}/cachegrind/tests/a.c -r ${D}${PTEST_PATH}/cachegrind/tests/cgout-test
Brad Bishopc342db32019-05-15 21:57:59 -0400214
215 # find *_annotate in ${bindir} for yocto build
216 sed -i s:\.\./\.\./cachegrind/cg_annotate:${bindir}/cg_annotate: ${D}${PTEST_PATH}/cachegrind/tests/ann1.vgtest
217 sed -i s:\.\./\.\./cachegrind/cg_annotate:${bindir}/cg_annotate: ${D}${PTEST_PATH}/cachegrind/tests/ann2.vgtest
218
219 sed -i s:\.\./\.\./callgrind/callgrind_annotate:${bindir}/callgrind_annotate: ${D}${PTEST_PATH}/callgrind/tests/ann1.vgtest
220 sed -i s:\.\./\.\./callgrind/callgrind_annotate:${bindir}/callgrind_annotate: ${D}${PTEST_PATH}/callgrind/tests/ann2.vgtest
221
Brad Bishopc342db32019-05-15 21:57:59 -0400222 # handle multilib
223 sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest
Brad Bishopa34c0302019-09-23 22:34:48 -0400224 sed -i s:@bindir@:${bindir}:g ${D}${PTEST_PATH}/run-ptest
Andrew Geissler82c905d2020-04-13 13:39:40 -0500225
226 # This test fails on the host as well, using both 3.15 and git master (as of Jan 24 2020)
227 # https://bugs.kde.org/show_bug.cgi?id=402833
228 rm ${D}${PTEST_PATH}/memcheck/tests/overlap.vgtest
229
230 # As the binary isn't stripped or debug-splitted, the source file isn't fetched
231 # via dwarfsrcfiles either, so it needs to be installed manually.
232 mkdir -p ${D}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/${BP}/none/tests/
233 install ${S}/none/tests/tls.c ${D}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/${BP}/none/tests/
Brad Bishopc342db32019-05-15 21:57:59 -0400234}
Andrew Geissler82c905d2020-04-13 13:39:40 -0500235
236# avoid stripping some generated binaries otherwise some of the tests will fail
237# run-strip-reloc.sh, run-strip-strmerge.sh and so on will fail
238INHIBIT_PACKAGE_STRIP_FILES = "\
239 ${PKGD}${PTEST_PATH}/none/tests/tls \
240 ${PKGD}${PTEST_PATH}/none/tests/tls.so \
241 ${PKGD}${PTEST_PATH}/none/tests/tls2.so \
242 ${PKGD}${PTEST_PATH}/helgrind/tests/tc09_bad_unlock \
243 ${PKGD}${PTEST_PATH}/memcheck/tests/manuel1 \
244 ${PKGD}${PTEST_PATH}/drd/tests/pth_detached3 \
245"