blob: 4047aaaacab4fe44f3b3b627879748117d7edfa0 [file] [log] [blame]
Patrick Williams314e8332023-10-06 17:41:44 -05001HOMEPAGE = "https://github.com/openbmc/pldm"
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
4SRC_URI = "git://github.com/openbmc/pldm;branch=master;protocol=https"
Andrew Geissler7353faa2024-03-04 23:50:24 -06005SRCREV = "245fc6f10fd5038eb014f1b6c5c7bed20c334ae7"
Patrick Williams314e8332023-10-06 17:41:44 -05006
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -05007SUMMARY = "PLDM Stack"
8DESCRIPTION = "Implementation of the PLDM specifications"
Tom Josephf6785aa2021-06-15 07:12:34 -07009DEPENDS += "function2"
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -050010DEPENDS += "systemd"
Matt Spinlere2375b52020-01-20 14:09:47 -060011DEPENDS += "sdeventplus"
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -050012DEPENDS += "phosphor-dbus-interfaces"
13DEPENDS += "nlohmann-json"
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -050014DEPENDS += "cli11"
Manojkiran Edac5934752022-09-27 13:59:35 -050015DEPENDS += "libpldm"
Riya Dixit1b221332023-03-28 01:42:41 -050016DEPENDS += "phosphor-logging"
Ed Tanous9936f862022-09-19 09:13:20 -070017PV = "1.0+git${SRCPV}"
18PR = "r1"
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -050019
20S = "${WORKDIR}/git"
Patrick Williams12fc9392021-08-06 09:16:53 -050021SYSTEMD_SERVICE:${PN} += "pldmd.service"
22SYSTEMD_SERVICE:${PN} += "pldmSoftPowerOff.service"
Deepak Kodihallia7482012020-06-22 05:25:35 -050023
Ed Tanous9936f862022-09-19 09:13:20 -070024inherit meson pkgconfig
25inherit systemd
26
Andrew Jefferyd8284082023-10-22 21:43:37 +103027PACKAGECONFIG[transport-mctp-demux] = "-Dtransport-implementation=mctp-demux"
28PACKAGECONFIG[transport-af-mctp] = "-Dtransport-implementation=af-mctp"
George Liu72f95342024-01-04 09:52:52 +080029PACKAGECONFIG[oem-ibm] = "-Doem-ibm=enabled, -Doem-ibm=disabled, , squashfs-tools"
Andrew Jefferyd8284082023-10-22 21:43:37 +103030PACKAGECONFIG ??= ""
31PACKAGECONFIG:append:df-mctp = " transport-af-mctp"
32
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -050033EXTRA_OEMESON = " \
34 -Dtests=disabled \
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -050035 "
Andrew Geissler0c3d0e22020-10-28 16:43:35 -050036
Ed Tanous9936f862022-09-19 09:13:20 -070037pkg_prerm:${PN} () {
38 LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants/pldmSoftPowerOff.service"
39 rm $LINK
40 LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants/pldmSoftPowerOff.service"
41 rm $LINK
42}
Andrew Geissler0c3d0e22020-10-28 16:43:35 -050043# Install pldmSoftPowerOff.service in correct targets
Patrick Williams12fc9392021-08-06 09:16:53 -050044pkg_postinst:${PN} () {
Manojkiran Eda842eb7f2021-09-15 18:47:42 +053045 mkdir -p $D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants
46 LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants/pldmSoftPowerOff.service"
Andrew Geissler0c3d0e22020-10-28 16:43:35 -050047 TARGET="../pldmSoftPowerOff.service"
48 ln -s $TARGET $LINK
Manojkiran Eda842eb7f2021-09-15 18:47:42 +053049 mkdir -p $D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants
50 LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants/pldmSoftPowerOff.service"
Andrew Geissler0c3d0e22020-10-28 16:43:35 -050051 TARGET="../pldmSoftPowerOff.service"
52 ln -s $TARGET $LINK
53}