blob: 78138d15434032e9769f4106bc8dae0623db1cd5 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Very high-quality data compression program"
2DESCRIPTION = "bzip2 compresses files using the Burrows-Wheeler block-sorting text compression algorithm, and \
3Huffman coding. Compression is generally considerably better than that achieved by more conventional \
4LZ77/LZ78-based compressors, and approaches the performance of the PPM family of statistical compressors."
Brad Bishop220d5532018-08-14 00:59:39 +01005HOMEPAGE = "https://sourceware.org/bzip2/"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05006SECTION = "console/utils"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00007LICENSE = "bzip2-1.0.6 & GPL-3.0-or-later & Apache-2.0 & MS-PL & BSD-3-Clause & Zlib"
Patrick Williams213cb262021-08-07 19:21:33 -05008LICENSE:${PN} = "bzip2-1.0.6"
9LICENSE:${PN}-dev = "bzip2-1.0.6"
10LICENSE:${PN}-dbg = "bzip2-1.0.6"
11LICENSE:${PN}-doc = "bzip2-1.0.6"
12LICENSE:${PN}-src = "bzip2-1.0.6"
13LICENSE:libbz2 = "bzip2-1.0.6"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000014LICENSE:${PN}-ptest = "bzip2-1.0.6 & GPL-3.0-or-later & Apache-2.0 & MS-PL & BSD-3-Clause & Zlib"
Andrew Geissler475cb722020-07-10 16:00:51 -050015
16LIC_FILES_CHKSUM = "file://LICENSE;beginline=4;endline=37;md5=600af43c50f1fcb82e32f19b32df4664 \
17 file://${WORKDIR}/git/commons-compress/LICENSE.txt;md5=86d3f3a95c324c9479bd8986968f4327 \
18 file://${WORKDIR}/git/dotnetzip/License.txt;md5=9cb56871eed4e748c3bc7e8ff352a54f \
19 file://${WORKDIR}/git/dotnetzip/License.zlib.txt;md5=cc421ccd22eeb2e5db6b79e6de0a029f \
20 file://${WORKDIR}/git/go/LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707 \
21 file://${WORKDIR}/git/lbzip2/COPYING;md5=d32239bcb673463ab874e80d47fae504 \
22"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050023
Brad Bishop96ff1982019-08-19 13:50:42 -040024SRC_URI = "https://sourceware.org/pub/${BPN}/${BPN}-${PV}.tar.gz \
Andrew Geissler595f6302022-01-24 19:11:47 +000025 git://sourceware.org/git/bzip2-tests.git;name=bzip2-tests;branch=master \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050026 file://configure.ac;subdir=${BP} \
27 file://Makefile.am;subdir=${BP} \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060028 file://run-ptest \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060029 "
Brad Bishop96ff1982019-08-19 13:50:42 -040030SRC_URI[md5sum] = "67e051268d0c475ea773822f7500d0e5"
31SRC_URI[sha256sum] = "ab5a03176ee106d3f0fa90e381da478ddae405918153cca248e682cd0c4a2269"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050032
Andrew Geissler475cb722020-07-10 16:00:51 -050033SRCREV_bzip2-tests = "f9061c030a25de5b6829e1abf373057309c734c0"
34
Brad Bishop96ff1982019-08-19 13:50:42 -040035UPSTREAM_CHECK_URI = "https://www.sourceware.org/pub/bzip2/"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050036
Patrick Williamsc124f4f2015-09-15 14:41:29 -050037PACKAGES =+ "libbz2"
38
Patrick Williams213cb262021-08-07 19:21:33 -050039CFLAGS:append = " -fPIC -fpic -Winline -fno-strength-reduce -D_FILE_OFFSET_BITS=64"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050040
Brad Bishop6e60e8b2018-02-01 10:27:11 -050041inherit autotools update-alternatives ptest relative_symlinks
Patrick Williamsc124f4f2015-09-15 14:41:29 -050042
43ALTERNATIVE_PRIORITY = "100"
Patrick Williams213cb262021-08-07 19:21:33 -050044ALTERNATIVE:${PN} = "bunzip2 bzcat bzip2"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050045
46#install binaries to bzip2-native under sysroot for replacement-native
Patrick Williams213cb262021-08-07 19:21:33 -050047EXTRA_OECONF:append:class-native = " --bindir=${STAGING_BINDIR_NATIVE}/${PN}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050048
Patrick Williams213cb262021-08-07 19:21:33 -050049do_configure:prepend () {
Brad Bishop08902b02019-08-20 09:16:51 -040050 sed -i -e "s|%BZIP2_VERSION%|${PV}|" ${S}/configure.ac
51}
52
Patrick Williamsc124f4f2015-09-15 14:41:29 -050053do_install_ptest () {
Andrew Geissler475cb722020-07-10 16:00:51 -050054 install -d ${D}${PTEST_PATH}/bzip2-tests
55 cp -r ${WORKDIR}/git/commons-compress ${D}${PTEST_PATH}/bzip2-tests/commons-compress
56 cp -r ${WORKDIR}/git/dotnetzip ${D}${PTEST_PATH}/bzip2-tests/dotnetzip
57 cp -r ${WORKDIR}/git/go ${D}${PTEST_PATH}/bzip2-tests/go
58 cp -r ${WORKDIR}/git/lbzip2 ${D}${PTEST_PATH}/bzip2-tests/lbzip2
59 cp -r ${WORKDIR}/git/pyflate ${D}${PTEST_PATH}/bzip2-tests/pyflate
60 cp ${WORKDIR}/git/README ${D}${PTEST_PATH}/bzip2-tests/
61 cp ${WORKDIR}/git/run-tests.sh ${D}${PTEST_PATH}/bzip2-tests/
Patrick Williamsc124f4f2015-09-15 14:41:29 -050062 sed -i -e "s|^Makefile:|_Makefile:|" ${D}${PTEST_PATH}/Makefile
63}
64
Patrick Williams213cb262021-08-07 19:21:33 -050065FILES:libbz2 = "${libdir}/lib*${SOLIBS}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050066
Patrick Williams213cb262021-08-07 19:21:33 -050067RDEPENDS:${PN}-ptest += "make bash"
Brad Bishop393846f2019-05-20 12:24:11 -040068
Patrick Williams213cb262021-08-07 19:21:33 -050069PROVIDES:append:class-native = " bzip2-replacement-native"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050070BBCLASSEXTEND = "native nativesdk"