blob: 5cf12505417d5da120b4b354a5639155722f18ba [file] [log] [blame]
Vijay Khemka66070d32020-07-23 15:22:56 -07001SUMMARY = "BMC Health Monitoring"
2DESCRIPTION = "Daemon to collect and monitor bmc health statistics"
3HOMEPAGE = "https://github.com/openbmc/phosphor-health-monitor"
Vijay Khemka66070d32020-07-23 15:22:56 -07004LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=9e69ba356fa59848ffd865152a3ccc13"
Vijay Khemka66070d32020-07-23 15:22:56 -07006DEPENDS += "sdbusplus"
7DEPENDS += "phosphor-dbus-interfaces"
8DEPENDS += "sdeventplus"
9DEPENDS += "phosphor-logging"
10DEPENDS += "nlohmann-json"
Andrew Geissler7e94bf72024-03-18 12:00:28 -050011SRCREV = "174e5bc9ff37555c54e3b2c8ad043a4f969f03d3"
Patrick Williams454ea362023-08-05 16:56:56 -050012PV = "0.1+git${SRCPV}"
Ed Tanous9936f862022-09-19 09:13:20 -070013PR = "r1"
Vijay Khemka66070d32020-07-23 15:22:56 -070014
Patrick Williamsbb99d222022-01-24 15:55:09 -060015SRC_URI = "git://github.com/openbmc/phosphor-health-monitor.git;protocol=https;branch=master"
Vijay Khemka66070d32020-07-23 15:22:56 -070016
Ed Tanous9936f862022-09-19 09:13:20 -070017S = "${WORKDIR}/git"
Patrick Williams12fc9392021-08-06 09:16:53 -050018SYSTEMD_SERVICE:${PN} = "phosphor-health-monitor.service"
Ed Tanous9936f862022-09-19 09:13:20 -070019
20inherit meson pkgconfig
21inherit systemd
Jayashree Dhanapal1ba4d1b2022-09-30 15:36:13 +053022
23do_install:append() {
24 if [ -e "${WORKDIR}/bmc_health_config.json" ]; then
25 install -d ${D}${sysconfdir}/healthMon
26 install -m 0644 ${WORKDIR}/bmc_health_config.json ${D}${sysconfdir}/healthMon
27 fi
28}