blob: 3279fbee40d7d036323d75f9a93d2396e6aba8ab [file] [log] [blame]
Brad Bishop37653df2017-05-12 13:02:56 -04001SUMMARY = "Phosphor OpenBMC event and error logging"
2DESCRIPTION = "An error and event log daemon application, and \
3 supporting tools for OpenBMC."
Adriana Kobylakb02da7b2016-10-19 14:58:25 -05004HOMEPAGE = "https://github.com/openbmc/phosphor-logging"
5PR = "r1"
Patrick Venture5bce7d72018-10-21 08:22:43 -07006PV = "1.0+git${SRCPV}"
Brad Bishop75f03872018-11-03 09:41:57 -07007LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Adriana Kobylakb02da7b2016-10-19 14:58:25 -05009
10inherit autotools pkgconfig
11inherit pythonnative
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050012inherit obmc-phosphor-dbus-service
Deepak Kodihalli1f09d4a2017-03-16 06:32:12 -050013inherit phosphor-logging
Marri Devender Raobf369d02017-06-06 08:39:39 -050014inherit phosphor-dbus-yaml
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050015
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050016DEPENDS += "autoconf-archive-native"
17DEPENDS += "systemd"
18DEPENDS += "python-mako-native"
19DEPENDS += "python-pyyaml-native"
Patrick Williams845123d2016-12-09 08:56:38 -060020DEPENDS += "sdbusplus sdbusplus-native"
Deepak Kodihalli0ac54522017-03-23 03:52:28 -050021DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
Deepak Kodihalli1f09d4a2017-03-16 06:32:12 -050022DEPENDS += "virtual/phosphor-logging-callouts"
Marri Devender Rao3b1e30e2017-05-14 09:01:35 -050023DEPENDS += "phosphor-logging-error-logs-native"
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050024DEPENDS += "phosphor-logging-native"
Brad Bishop17c08bf2018-10-18 17:07:53 -040025DEPENDS += "libcereal"
Matt Spinlerf319ea62019-07-23 16:04:04 -050026DEPENDS += "sdeventplus"
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050027
Michael Tritz026fbaf2017-03-13 14:54:24 -050028PACKAGE_BEFORE_PN = "${PN}-test"
29FILES_${PN}-test = "${bindir}/*-test"
30
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050031PACKAGE_BEFORE_PN += "${PN}-elog"
32FILES_${PN}-elog += "${elog_dir}"
33
Deepak Kodihalli64464772018-08-24 08:05:14 -050034# Package configuration
35LOGGING_PACKAGES = " \
36 ${PN}-base \
Deepak Kodihalli04aa22f2018-08-28 11:39:41 -050037 phosphor-rsyslog-config \
Deepak Kodihalli64464772018-08-24 08:05:14 -050038"
39
40ALLOW_EMPTY_${PN} = "1"
41PACKAGE_BEFORE_PN += "${LOGGING_PACKAGES}"
42SYSTEMD_PACKAGES = "${LOGGING_PACKAGES}"
43DBUS_PACKAGES = "${LOGGING_PACKAGES}"
44
Deepak Kodihalli64464772018-08-24 08:05:14 -050045FILES_${PN}-base += " \
Patrick Venturecb51ccb2019-04-04 14:49:25 -070046 ${bindir}/phosphor-log-manager \
Deepak Kodihalli64464772018-08-24 08:05:14 -050047 ${libdir}/libphosphor_logging.so.* \
48"
49DBUS_SERVICE_${PN}-base += "xyz.openbmc_project.Logging.service"
50
Deepak Kodihalli04aa22f2018-08-28 11:39:41 -050051DBUS_SERVICE_phosphor-rsyslog-config += "xyz.openbmc_project.Syslog.Config.service"
52FILES_phosphor-rsyslog-config += " \
Patrick Venturecb51ccb2019-04-04 14:49:25 -070053 ${bindir}/phosphor-rsyslog-conf \
Deepak Kodihalli04aa22f2018-08-28 11:39:41 -050054"
55
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050056SRC_URI += "git://github.com/openbmc/phosphor-logging"
Andrew Geissler7fe86542019-08-16 07:01:13 +000057SRCREV = "52a4980c5024e8a812e4c69942a4aeb315904870"
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050058
59S = "${WORKDIR}/git"
60
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050061# Do not DEPEND on the specified packages for native build
62# as they will not be available in host machine
Brad Bishop096e4b42018-01-27 00:27:21 -050063DEPENDS_remove_class-native = " \
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050064 virtual/phosphor-logging-callouts \
Brad Bishop096e4b42018-01-27 00:27:21 -050065 sdbus++ \
66 systemd \
Brad Bishop17c08bf2018-10-18 17:07:53 -040067 libcereal \
Matt Spinlerf319ea62019-07-23 16:04:04 -050068 sdeventplus \
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050069 "
70
71# Do not DEPEND on the specified packages for native SDK build
72# as they will not be available in host machine
73DEPENDS_remove_class-nativesdk = " \
74 virtual/phosphor-logging-callouts \
75 sdbus++-native \
Brad Bishop17c08bf2018-10-18 17:07:53 -040076 libcereal \
Brad Bishop096e4b42018-01-27 00:27:21 -050077 systemd \
78 phosphor-dbus-interfaces \
Matt Spinlerf319ea62019-07-23 16:04:04 -050079 sdeventplus \
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050080 "
81
82PACKAGECONFIG ??= "metadata-processing install_scripts"
83
Deepak Kodihalli430a5062017-03-28 07:47:51 -050084PACKAGECONFIG[metadata-processing] = " \
85 --enable-metadata-processing, \
86 --disable-metadata-processing, , \
87 "
88
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050089# Provide a means to enable/disable install_scripts feature
90PACKAGECONFIG[install_scripts] = " \
91 --enable-install_scripts, \
92 --disable-install_scripts, ,\
93 "
94
Matt Spinlerf8510922019-08-08 13:21:24 -050095PACKAGECONFIG[openpower-pels] = " \
96 --enable-openpower-pel-extension, \
97 --disable-openpower-pel-extension, ,\
98 "
99
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -0500100# Enable install_scripts during native and native SDK build
101PACKAGECONFIG_add_class-native = "install_scripts"
102PACKAGECONFIG_add_class-nativesdk = "install_scripts"
103
104# Disable install_scripts during target build
105PACKAGECONFIG_remove_class-target = "install_scripts"
106
Deepak Kodihalli1f09d4a2017-03-16 06:32:12 -0500107EXTRA_OECONF = " \
108 YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir} \
109 CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
110 "
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -0500111
112BBCLASSEXTEND += "native nativesdk"