blob: 9f245ad7de89b94303dd2f8ad4e7ffddb7102d6c [file] [log] [blame]
Andrew Geissler16bb75a2023-06-09 14:34:42 -04001# Witherspoon system does not support warm reboots
2PACKAGECONFIG:append:witherspoon = " no-warm-reboot"
Andrew Geissler65393532021-01-28 13:17:12 -06003
Andrew Geisslercf6e89a2024-02-27 14:40:22 -06004# p10bmc system do not support forced warm reboots
5PACKAGECONFIG:append:p10bmc = " no-force-warm-reboot"
6
Andrew Geissler3fb738c2023-01-10 14:33:43 -06007# IBM systems only want power restore when AC loss occurred
Andrew Geissler16bb75a2023-06-09 14:34:42 -04008PACKAGECONFIG:append = " only-run-apr-on-power-loss"
Andrew Geissler3fb738c2023-01-10 14:33:43 -06009
Andrew Geisslereabfa8b2023-06-08 14:05:36 -050010# IBM systems only allow boot operations when BMC is Ready
Andrew Geissler16bb75a2023-06-09 14:34:42 -040011PACKAGECONFIG:append = " only-allow-boot-when-bmc-ready"
Andrew Geisslereabfa8b2023-06-08 14:05:36 -050012
Andrew Geissler65393532021-01-28 13:17:12 -060013# The scheduled-host-transition package provides support to
14# schedule power on and off operations for the host at some
15# time in the future. IBM systems will utilize this feature
Andrew Geisslercc4d0852022-04-27 20:55:11 +000016RRECOMMENDS:${PN}-host:append = " ${PN}-scheduled-host-transition"
Andrew Geisslerb2644f82021-02-10 16:11:58 -060017
18# IBM systems track the state of the hypervisor so bring
19# in the needed package when the host state package is
20# included
Andrew Geisslercc4d0852022-04-27 20:55:11 +000021RRECOMMENDS:${PN}-host:append = " ${PN}-hypervisor"
Andrew Geissler192e2862022-02-08 14:23:21 -060022
Andrew Geisslerf0762072022-04-27 18:01:49 +000023# IBM p10 machines want the optional secure-check
24# feature enabled. This will verify all security
25# settings in manufacturing mode.
Andrew Geisslercc4d0852022-04-27 20:55:11 +000026RRECOMMENDS:${PN}-host:append:p10bmc = " ${PN}-secure-check"
Andrew Geisslerf0762072022-04-27 18:01:49 +000027
Andrew Geissler192e2862022-02-08 14:23:21 -060028# IBM systems want the chassis package to not allow a
29# system power on if chassis power is in a bad state
Andrew Geisslercc4d0852022-04-27 20:55:11 +000030RRECOMMENDS:${PN}-chassis:append = " ${PN}-chassis-check-power-status"
Andrew Geissler192e2862022-02-08 14:23:21 -060031
Andrew Geissler80a13f82022-03-02 22:30:35 +000032# Override critical services to monitor with IBM file
33FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
34FILES:${PN}-bmc:append = " ${sysconfdir}/phosphor-service-monitor-default.json"
35SRC_URI:append = " file://phosphor-service-monitor-default.json"
36do_install:append() {
37 install -d ${D}${sysconfdir}/phosphor-systemd-target-monitor
38 install -m 0644 ${WORKDIR}/phosphor-service-monitor-default.json \
39 ${D}${sysconfdir}/phosphor-systemd-target-monitor/
40}