blob: 29cb4111d615b263a040a5c627377ca17118b74e [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "Library provides support for the Tag Image File Format \
3(TIFF), a widely used format for storing image data. This library \
4provide means to easily access and create TIFF image files."
5HOMEPAGE = "http://www.libtiff.org/"
Brad Bishop19323692019-04-05 15:28:33 -04006LICENSE = "BSD-2-Clause"
7LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf"
8
9CVE_PRODUCT = "libtiff"
10
Andrew Geissler615f2f12022-07-15 14:00:58 -050011SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
Patrick Williams92b42cb2022-09-03 06:53:57 -050012 file://0001-fix-the-FPE-in-tiffcrop-415-427-and-428.patch \
13 file://CVE-2022-34526.patch \
Andrew Geissler87f5cff2022-09-30 13:13:31 -050014 file://CVE-2022-2953.patch \
Patrick Williams2390b1b2022-11-03 13:47:49 -050015 file://0001-Revised-handling-of-TIFFTAG_INKNAMES-and-related-TIF.patch \
16 file://0001-tiffcrop-S-option-Make-decision-simpler.patch \
17 file://0001-tiffcrop-disable-incompatibility-of-Z-X-Y-z-options-.patch \
18 file://0001-tiffcrop-subroutines-require-a-larger-buffer-fixes-2.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050019 "
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000020
Andrew Geissler78b72792022-06-14 06:47:25 -050021SRC_URI[sha256sum] = "917223b37538959aca3b790d2d73aa6e626b688e02dcda272aec24c2f498abed"
Brad Bishop19323692019-04-05 15:28:33 -040022
23# exclude betas
24UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
25
William A. Kennington IIIac69b482021-06-02 12:28:27 -070026# Tested with check from https://security-tracker.debian.org/tracker/CVE-2015-7313
27# and 4.3.0 doesn't have the issue
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000028CVE_CHECK_IGNORE += "CVE-2015-7313"
Andrew Geissler78b72792022-06-14 06:47:25 -050029# These issues only affect libtiff post-4.3.0 but before 4.4.0,
30# caused by 3079627e and fixed by b4e79bfa.
31CVE_CHECK_IGNORE += "CVE-2022-1622 CVE-2022-1623"
Andrew Geissler78b72792022-06-14 06:47:25 -050032# Issue is in jbig which we don't enable
33CVE_CHECK_IGNORE += "CVE-2022-1210"
William A. Kennington IIIac69b482021-06-02 12:28:27 -070034
Brad Bishop19323692019-04-05 15:28:33 -040035inherit autotools multilib_header
36
37CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
38
39PACKAGECONFIG ?= "cxx jpeg zlib lzma \
40 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
41
42PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
Andrew Geissler78b72792022-06-14 06:47:25 -050043PACKAGECONFIG[jbig] = "--enable-jbig,--disable-jbig,jbig,"
Brad Bishop19323692019-04-05 15:28:33 -040044PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
45PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
46PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
47
48# Convert single-strip uncompressed images to multiple strips of specified
49# size (default: 8192) to reduce memory usage
50PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
51
52# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
53PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
54
55# Control picking up YCbCr subsample info. Disable to support files lacking
56# the tag
57PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
58
59# Support a mechanism allowing reading large strips (usually one strip files)
60# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
61PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
62
63PACKAGES =+ "tiffxx tiff-utils"
Patrick Williams213cb262021-08-07 19:21:33 -050064FILES:tiffxx = "${libdir}/libtiffxx.so.*"
65FILES:tiff-utils = "${bindir}/*"
Brad Bishop19323692019-04-05 15:28:33 -040066
Patrick Williams213cb262021-08-07 19:21:33 -050067do_install:append() {
Brad Bishop19323692019-04-05 15:28:33 -040068 oe_multilib_header tiffconf.h
69}
70
Andrew Geissler4ed12e12020-06-05 18:00:41 -050071BBCLASSEXTEND = "native nativesdk"