blob: 54c5991d243d5f1e588596791df0acfa50023365 [file] [log] [blame]
Brad Bishop5f9be072016-06-27 14:53:52 -04001SUMMARY = "OpenBMC gdbus library"
2DESCRIPTION = "libopenbmc_intf provides a set of gpio access \
3methods and the GDBUS skeleton code for the org.openbmc DBUS API."
Ed Tanous9936f862022-09-19 09:13:20 -07004DEPENDS += "glib-2.0"
5DEPENDS += "cjson"
Patrick Venture78882612018-10-23 08:59:23 -07006PV = "1.0+git${SRCPV}"
Ed Tanous9936f862022-09-19 09:13:20 -07007PR = "r1"
8
9SRC_URI += "file://gpio_defs.json"
10
11SKELETON_DIR = "libopenbmc_intf"
Brad Bishop5f9be072016-06-27 14:53:52 -040012
13inherit skeleton
Saqib Khan02917df2017-11-13 10:47:54 -060014inherit pkgconfig
Brad Bishop5f9be072016-06-27 14:53:52 -040015
Ed Tanous9936f862022-09-19 09:13:20 -070016do_install() {
17 oe_runmake install DESTDIR=${D}
18 install -d ${D}${sysconfdir}/default/obmc/gpio/
19 install -m 0644 ${WORKDIR}/gpio_defs.json ${D}/${sysconfdir}/default/obmc/gpio/
20}
Brad Bishop5f9be072016-06-27 14:53:52 -040021
Ed Tanous9936f862022-09-19 09:13:20 -070022# Ensure the library is not in the dev package
23FILES_SOLIBSDEV = ""
24# Now add the link to the production package
25FILES:${PN} += "${libdir}/libopenbmc_intf.so"
Matt Spinler71c1c922018-08-07 16:35:19 -050026
Andrew Geisslere3817542020-07-14 13:41:21 -050027# Users of libopenbmc_intf use custom makefiles that do not
28# support the proper library version detection and linking.
29# Because of that, a link must be created within the
30# rootfs for applicaitons to use this library.
31# This next line tells bitbake to skip the check which
32# ensures no links are put in the rootfs
Patrick Williams12fc9392021-08-06 09:16:53 -050033INSANE_SKIP:${PN} += "dev-so"