blob: 9360fbb0ff32ec2d4aa99d9425eb6204ad847138 [file] [log] [blame]
Brad Bishope3278032016-11-09 20:43:11 -05001SUMMARY = "C++ bindings for systemd dbus APIs"
2DESCRIPTION = "C++ bindings for systemd dbus APIs."
3HOMEPAGE = "http://github.com/openbmc/sdbusplus"
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
7
8inherit autotools pkgconfig
Patrick Williams8fc96292016-11-22 07:01:14 -06009inherit obmc-phosphor-python-autotools
Brad Bishope3278032016-11-09 20:43:11 -050010
Nagaraju Goruganti9940d4f2017-08-22 05:24:26 -050011DEPENDS += " \
12 autoconf-archive-native \
13 python-inflection-native \
14 python-mako-native \
15 python-pyyaml-native \
16 "
Brad Bishop13b8afa2017-01-12 14:06:43 -050017RDEPENDS_sdbus++ += " \
Brad Bishope3278032016-11-09 20:43:11 -050018 python-inflection \
19 python-mako \
20 python-pyyaml \
21 "
22
Brad Bishop6b4da622017-01-18 13:59:33 -050023# sdbus++ has a handful of runtime dependencies on other python packages.
24# Bitbake doesn't do anything with RDEPENDS in native context because
25# native context doesn't have packages.
26#
27# While technically sdbus++ doesn't require its runtime dependencies to be
28# installed to build, work around the above native context behavior
29# by adding a build dependency so that clients don't have to DEPEND
30# on sdbus++ runtime dependencies manually.
31
32DEPENDS_append_class-native = " \
33 python-inflection-native \
34 python-mako-native \
35 python-pyyaml-native \
36 "
37
Brad Bishope3278032016-11-09 20:43:11 -050038SRC_URI += "git://github.com/openbmc/sdbusplus"
Patrick Williams4903dc52017-07-18 22:40:03 -050039SRCREV = "a41b3896816e71cc19e8daba6009b3869dfc5207"
Brad Bishope3278032016-11-09 20:43:11 -050040
Adriana Kobylak9bcfdbb2017-02-12 17:40:26 -060041PACKAGECONFIG ??= "libsdbusplus transaction"
Brad Bishope3278032016-11-09 20:43:11 -050042PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd"
Adriana Kobylak9bcfdbb2017-02-12 17:40:26 -060043PACKAGECONFIG[transaction] = "--enable-transaction,--disable-transaction"
Brad Bishope3278032016-11-09 20:43:11 -050044
45S = "${WORKDIR}/git"
46
Patrick Williams592d7982016-11-22 11:05:11 -060047PROVIDES_prepend = "sdbus++ "
48PACKAGES_prepend = "sdbus++ "
49FILES_sdbus++_append = " ${bindir}/sdbus++"
50PYTHON_AUTOTOOLS_PACKAGE = "sdbus++"
51
Brad Bishope3278032016-11-09 20:43:11 -050052PACKAGECONFIG_remove_class-native = "libsdbusplus"
53PACKAGECONFIG_remove_class-nativesdk = "libsdbusplus"
54
Brad Bishope3278032016-11-09 20:43:11 -050055BBCLASSEXTEND += "native nativesdk"