blob: e1583d7a7f532dc45b4b9afb6e128e6382f2f849 [file] [log] [blame]
Cyril Burb73580e2017-01-12 18:13:30 +11001SUMMARY = "Phosphor OpenBMC MBOX Daemon"
2DESCRIPTION = "Phosphor OpenBMC MBOX Daemon"
3PR = "r1"
Patrick Venturecef2b3b2018-10-21 08:26:38 -07004PV = "1.0+git${SRCPV}"
Cyril Burb73580e2017-01-12 18:13:30 +11005LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
7
8inherit autotools pkgconfig
9inherit obmc-phosphor-systemd
10
11DEPENDS += "autoconf-archive-native"
Andrew Jeffery5ade8402017-04-21 10:18:24 +093012DEPENDS += "systemd"
Patrick Williamsf55db882017-06-30 12:01:49 -050013DEPENDS += "phosphor-logging"
Andrew Jeffery2c567ba2017-04-18 16:30:10 +093014RDEPENDS_${PN} += "libsystemd"
Cyril Burb73580e2017-01-12 18:13:30 +110015
16S = "${WORKDIR}/git"
17
Adriana Kobylak87f59c92018-09-10 11:44:29 -050018SRC_URI += "git://github.com/openbmc/mboxbridge.git"
Cyril Burb73580e2017-01-12 18:13:30 +110019
20SRC_URI += "file://99-aspeed-mbox.rules"
Andrew Jeffery2a0cb542017-01-25 13:17:13 +103021SRC_URI += "file://99-aspeed-lpc-ctrl.rules"
Cyril Burb73580e2017-01-12 18:13:30 +110022SRC_URI += "file://aspeed-lpc-ctrl-h.patch"
23
Andrew Geissler5ec11bc2018-10-14 22:50:24 +000024SRCREV="5f86227e1619f60dadc8a053d14b20338d0fbdac"
Andrew Jeffery2c567ba2017-04-18 16:30:10 +093025
26PROVIDES += "mboxctl"
Cyril Burb73580e2017-01-12 18:13:30 +110027
28MBOXD_FLASH_SIZE ??= "32M"
29SYSTEMD_SUBSTITUTIONS += "FLASH_SIZE:${MBOXD_FLASH_SIZE}:${PN}.service"
30
31# Hacks because ${STAGING_KERNEL_DIR} points to the kernel source tree, not the
32# installed, pre-processed headers. Requires the aspeed-lpc-ctrl-h patch above.
Saqib Khanc8afc6a2017-03-09 10:28:09 -060033CFLAGS_append = " -I include"
Cyril Burb73580e2017-01-12 18:13:30 +110034
35do_install_append() {
36 install -d ${D}/lib/udev/rules.d
37 install -m 0644 ${WORKDIR}/99-aspeed-mbox.rules ${D}/lib/udev/rules.d
Andrew Jeffery2a0cb542017-01-25 13:17:13 +103038 install -m 0644 ${WORKDIR}/99-aspeed-lpc-ctrl.rules ${D}/lib/udev/rules.d
Cyril Burb73580e2017-01-12 18:13:30 +110039}
Matt Spinler9f77d282017-01-20 15:32:07 -060040
41TMPL = "mboxd-reload@.service"
Andrew Geissler58041192017-07-25 09:12:37 -050042TGTFMT = "obmc-chassis-poweron@{0}.target"
Matt Spinler9f77d282017-01-20 15:32:07 -060043INSTFMT = "mboxd-reload@{0}.service"
44FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}"
45
46SYSTEMD_SERVICE_${PN} += "mboxd.service"
47SYSTEMD_SERVICE_${PN} += "mboxd-reload@.service"
48SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
Deepak Kodihallidd05b962017-06-29 09:56:24 -050049
Brad Bishop09806a52018-03-09 00:40:41 -050050# Enable virtual-pnor by DISTRO_FEATURE openpower-ubi-fs.
51PACKAGECONFIG_append_df-openpower-ubi-fs = "virtual-pnor"
Patrick Williams74d4dbc2017-08-09 16:36:51 -050052PACKAGECONFIG[virtual-pnor] = "--enable-virtual-pnor,--disable-virtual-pnor"