blob: 737c124933c9cd3f3ac2dd0da446e17941766683 [file] [log] [blame]
Ed Tanous2c2a1c52018-01-29 10:56:52 -08001LICENSE = "Apache-2.0"
Andrew Geisslere11f5e22021-07-20 18:10:59 +00002LIC_FILES_CHKSUM = "file://LICENSE;md5=175792518e4ac015ab6696d16c4f607e"
Ed Tanous07f48cc2021-02-22 10:49:30 -08003DEPENDS = " \
4 openssl \
5 zlib \
6 boost \
Ed Tanous07f48cc2021-02-22 10:49:30 -08007 libpam \
8 sdbusplus \
9 gtest \
10 nlohmann-json \
11 libtinyxml2 \
Ed Tanousa443c542021-02-26 13:28:37 -080012 ${@bb.utils.contains('PTEST_ENABLED', '1', 'gtest', '', d)} \
13 ${@bb.utils.contains('PTEST_ENABLED', '1', 'gmock', '', d)} \
Ed Tanous07f48cc2021-02-22 10:49:30 -080014"
Andrew Geisslerd12a4932023-01-27 12:50:27 -060015SRCREV = "870f3e914882dc1798ec4883472c67403805eed1"
Ed Tanous9936f862022-09-19 09:13:20 -070016PV = "1.0+git${SRCPV}"
Ed Tanous2c2a1c52018-01-29 10:56:52 -080017
Patrick Williams0b73b982023-01-26 10:24:41 -060018SRC_URI = "git://github.com/openbmc/bmcweb.git;branch=master;protocol=https"
Ed Tanous9936f862022-09-19 09:13:20 -070019SRC_URI += " \
20 file://run-ptest \
Ed Tanous07f48cc2021-02-22 10:49:30 -080021"
Adriana Kobylak7e0ff54f2018-12-13 11:01:05 -060022
Ed Tanous9936f862022-09-19 09:13:20 -070023S = "${WORKDIR}/git"
24SYSTEMD_SERVICE:${PN} += "bmcweb.service bmcweb.socket"
Ed Tanousa443c542021-02-26 13:28:37 -080025
Ed Tanous9936f862022-09-19 09:13:20 -070026inherit systemd
27inherit useradd
28inherit pkgconfig meson ptest
Ed Tanous2c2a1c52018-01-29 10:56:52 -080029
Ed Tanousa443c542021-02-26 13:28:37 -080030EXTRA_OEMESON = " \
31 --buildtype=minsize \
32 -Dtests=${@bb.utils.contains('PTEST_ENABLED', '1', 'enabled', 'disabled', d)} \
Ed Tanousa443c542021-02-26 13:28:37 -080033"
Ed Tanous2c2a1c52018-01-29 10:56:52 -080034
Ed Tanous9936f862022-09-19 09:13:20 -070035do_install_ptest() {
36 install -d ${D}${PTEST_PATH}/test
37 cp -rf ${B}/*_test ${D}${PTEST_PATH}/test/
38}
Ed Tanous2c2a1c52018-01-29 10:56:52 -080039
Ed Tanous9936f862022-09-19 09:13:20 -070040RDEPENDS:${PN} += " \
41 jsnbd \
Patrick Williams0450a022022-10-07 21:23:47 -050042 phosphor-objmgr \
Ed Tanous9936f862022-09-19 09:13:20 -070043"
44
45FILES:${PN} += "${datadir}/** "
46
47USERADD_PACKAGES = "${PN}"
48# add a user called httpd for the server to assume
49USERADD_PARAM:${PN} = "-r -s /sbin/nologin bmcweb"
50
51GROUPADD_PARAM:${PN} = "web; redfish"
Manojkiran Edaf1f2e242020-09-02 21:48:12 +053052FULL_OPTIMIZATION = "-Os "