blob: 25fa58249c9e19f6675b15dcbe1ae2d24c2fd680 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Valgrind memory debugger and instrumentation framework"
2HOMEPAGE = "http://valgrind.org/"
3BUGTRACKER = "http://valgrind.org/support/bug_reports.html"
4LICENSE = "GPLv2 & GPLv2+ & BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
Andrew Geissler4ed12e12020-06-05 18:00:41 -05006 file://include/pub_tool_basics.h;beginline=6;endline=29;md5=41c410e8d3f305aee7aaa666b2e4f366 \
Brad Bishopc342db32019-05-15 21:57:59 -04007 file://include/valgrind.h;beginline=1;endline=56;md5=ad3b317f3286b6b704575d9efe6ca5df \
8 file://COPYING.DOCS;md5=24ea4c7092233849b4394699333b5c56"
9
Brad Bishop96ff1982019-08-19 13:50:42 -040010DEPENDS = " \
Brad Bishopc342db32019-05-15 21:57:59 -040011 ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'boost', '', d)} \
12 "
13
14SRC_URI = "https://sourceware.org/pub/valgrind/valgrind-${PV}.tar.bz2 \
15 file://fixed-perl-path.patch \
16 file://Added-support-for-PPC-instructions-mfatbu-mfatbl.patch \
17 file://run-ptest \
Brad Bishopa34c0302019-09-23 22:34:48 -040018 file://remove-for-aarch64 \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060019 file://remove-for-all \
Brad Bishopc342db32019-05-15 21:57:59 -040020 file://0004-Fix-out-of-tree-builds.patch \
21 file://0005-Modify-vg_test-wrapper-to-support-PTEST-formats.patch \
22 file://0001-Remove-tests-that-fail-to-build-on-some-PPC32-config.patch \
23 file://use-appropriate-march-mcpu-mfpu-for-ARM-test-apps.patch \
24 file://avoid-neon-for-targets-which-don-t-support-it.patch \
25 file://valgrind-make-ld-XXX.so-strlen-intercept-optional.patch \
26 file://0001-makefiles-Drop-setting-mcpu-to-cortex-a8-on-arm-arch.patch \
27 file://0001-str_tester.c-Limit-rawmemchr-test-to-glibc.patch \
28 file://0001-sigqueue-Rename-_sifields-to-__si_fields-on-musl.patch \
29 file://0002-context-APIs-are-not-available-on-musl.patch \
30 file://0003-correct-include-directive-path-for-config.h.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040031 file://0005-tc20_verifywrap.c-Fake-__GLIBC_PREREQ-with-musl.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040032 file://0001-memcheck-arm64-Define-__THROW-if-not-already-defined.patch \
33 file://0002-memcheck-x86-Define-__THROW-if-not-defined.patch \
34 file://0003-tests-seg_override-Replace-__modify_ldt-with-syscall.patch \
35 file://0001-fix-opcode-not-supported-on-mips32-linux.patch \
36 file://0001-Guard-against-__GLIBC_PREREQ-for-musl-libc.patch \
37 file://0001-Make-local-functions-static-to-avoid-assembler-error.patch \
38 file://0001-Return-a-valid-exit_code-from-vg_regtest.patch \
39 file://0001-valgrind-filter_xml_frames-do-not-filter-usr.patch \
Andrew Geisslerc9f78652020-09-18 14:11:35 -050040 file://0001-memcheck-vgtests-remove-fullpath-after-flags.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050041 file://s390x_vec_op_t.patch \
42 file://0001-none-tests-fdleak_cmsg.stderr.exp-adjust-tmp-paths.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050043 file://0001-memcheck-tests-Fix-timerfd-syscall-test.patch \
Andrew Geissler4c19ea12020-10-27 13:52:24 -050044 file://0001-drd-Port-to-Fedora-33.patch \
45 file://0001-drd-musl-fix.patch \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060046 file://0001-helgrind-Intercept-libc-functions.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040047 "
Andrew Geisslerd25ed322020-06-27 00:28:28 -050048SRC_URI[md5sum] = "d1b153f1ab17cf1f311705e7a83ef589"
49SRC_URI[sha256sum] = "c91f3a2f7b02db0f3bc99479861656154d241d2fdb265614ba918cc6720a33ca"
Brad Bishopc342db32019-05-15 21:57:59 -040050UPSTREAM_CHECK_REGEX = "valgrind-(?P<pver>\d+(\.\d+)+)\.tar"
51
52COMPATIBLE_HOST = '(i.86|x86_64|arm|aarch64|mips|powerpc|powerpc64).*-linux'
53
Andrew Geisslerc9f78652020-09-18 14:11:35 -050054# patch 0001-memcheck-vgtests-remove-fullpath-after-flags.patch removes relative path
55# argument. Change expected stderr files accordingly.
56do_patch_append() {
57 bb.build.exec_func('do_sed_paths', d)
58}
59
60do_sed_paths() {
61 sed -i -e 's|tests/||' ${S}/memcheck/tests/badfree3.stderr.exp
62 sed -i -e 's|tests/||' ${S}/memcheck/tests/varinfo5.stderr.exp
63}
64
Brad Bishopc342db32019-05-15 21:57:59 -040065# valgrind supports armv7 and above
66COMPATIBLE_HOST_armv4 = 'null'
67COMPATIBLE_HOST_armv5 = 'null'
68COMPATIBLE_HOST_armv6 = 'null'
69
Andrew Geisslerd25ed322020-06-27 00:28:28 -050070# valgrind fails with powerpc soft-float
71COMPATIBLE_HOST_powerpc = "${@bb.utils.contains('TARGET_FPU', 'soft', 'null', '.*-linux', d)}"
72
Brad Bishopc342db32019-05-15 21:57:59 -040073# X32 isn't supported by valgrind at this time
74COMPATIBLE_HOST_linux-gnux32 = 'null'
75COMPATIBLE_HOST_linux-muslx32 = 'null'
76
77# Disable for some MIPS variants
78COMPATIBLE_HOST_mipsarchr6 = 'null'
79COMPATIBLE_HOST_linux-gnun32 = 'null'
80
81# Disable for powerpc64 with musl
82COMPATIBLE_HOST_libc-musl_powerpc64 = 'null'
83
Andrew Geissler82c905d2020-04-13 13:39:40 -050084# brokenseip is unfortunately required by ptests to pass
85inherit autotools-brokensep ptest multilib_header
Brad Bishopc342db32019-05-15 21:57:59 -040086
87EXTRA_OECONF = "--enable-tls --without-mpicc"
88EXTRA_OECONF += "${@['--enable-only32bit','--enable-only64bit'][d.getVar('SITEINFO_BITS') != '32']}"
89
90# valgrind checks host_cpu "armv7*)", so we need to over-ride the autotools.bbclass default --host option
91EXTRA_OECONF_append_arm = " --host=armv7${HOST_VENDOR}-${HOST_OS}"
92
93EXTRA_OEMAKE = "-w"
94
95CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl'"
96
97# valgrind likes to control its own optimisation flags. It generally defaults
98# to -O2 but uses -O0 for some specific test apps etc. Passing our own flags
99# (via CFLAGS) means we interfere with that. Only pass DEBUG_FLAGS to it
100# which fixes build path issue in DWARF.
101SELECTED_OPTIMIZATION = "${DEBUG_FLAGS}"
102
103do_configure_prepend () {
104 rm -rf ${S}/config.h
105 sed -i -e 's:$(abs_top_builddir):$(pkglibdir)/ptest:g' ${S}/none/tests/Makefile.am
106 sed -i -e 's:$(top_builddir):$(pkglibdir)/ptest:g' ${S}/memcheck/tests/Makefile.am
107}
108
109do_install_append () {
110 install -m 644 ${B}/default.supp ${D}/${libdir}/valgrind/
111 oe_multilib_header valgrind/config.h
112}
113
114VALGRINDARCH ?= "${TARGET_ARCH}"
115VALGRINDARCH_aarch64 = "arm64"
116VALGRINDARCH_x86-64 = "amd64"
117VALGRINDARCH_x86 = "x86"
118VALGRINDARCH_mips = "mips32"
119VALGRINDARCH_mipsel = "mips32"
120VALGRINDARCH_mips64el = "mips64"
121VALGRINDARCH_powerpc = "ppc"
122VALGRINDARCH_powerpc64 = "ppc64"
123VALGRINDARCH_powerpc64el = "ppc64le"
124
125INHIBIT_PACKAGE_STRIP_FILES = "${PKGD}${libdir}/valgrind/vgpreload_memcheck-${VALGRINDARCH}-linux.so"
126
127RDEPENDS_${PN} += "perl"
128
129# valgrind needs debug information for ld.so at runtime in order to
130# redirect functions like strlen.
131RRECOMMENDS_${PN} += "${TCLIBC}-dbg"
132
Brad Bishopa34c0302019-09-23 22:34:48 -0400133RDEPENDS_${PN}-ptest += " bash coreutils file \
134 gdb libgomp \
135 perl \
Andrew Geisslerc9f78652020-09-18 14:11:35 -0500136 perl-module-file-basename perl-module-file-glob perl-module-getopt-long \
137 perl-module-overloading \
Andrew Geissler82c905d2020-04-13 13:39:40 -0500138 procps sed ${PN}-dbg ${PN}-src"
Brad Bishopc342db32019-05-15 21:57:59 -0400139RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-utils"
140
141# One of the tests contains a bogus interpreter path on purpose.
142# Skip file dependency check
143SKIP_FILEDEPS_${PN}-ptest = '1'
144INSANE_SKIP_${PN}-ptest = "debug-deps"
145
146do_compile_ptest() {
147 oe_runmake check
148}
149
150do_install_ptest() {
151 chmod +x ${B}/tests/vg_regtest
152
153 # The test application binaries are not automatically installed.
154 # Grab them from the build directory.
155 #
156 # The regression tests require scripts and data files that are not
157 # copied to the build directory. They must be copied from the
158 # source directory.
159 saved_dir=$PWD
160 for parent_dir in ${S} ${B} ; do
161 cd $parent_dir
162
Brad Bishopc342db32019-05-15 21:57:59 -0400163 subdirs=" \
Brad Bishopa34c0302019-09-23 22:34:48 -0400164 .in_place \
Brad Bishopc342db32019-05-15 21:57:59 -0400165 cachegrind/tests \
166 callgrind/tests \
Brad Bishopa34c0302019-09-23 22:34:48 -0400167 dhat/tests \
Brad Bishopc342db32019-05-15 21:57:59 -0400168 drd/tests \
169 gdbserver_tests \
170 helgrind/tests \
Brad Bishopa34c0302019-09-23 22:34:48 -0400171 lackey/tests \
Brad Bishopc342db32019-05-15 21:57:59 -0400172 massif/tests \
173 memcheck/tests \
174 none/tests \
175 tests \
Brad Bishopa34c0302019-09-23 22:34:48 -0400176 exp-bbv/tests \
177 exp-dhat/tests \
178 exp-sgcheck/tests \
Brad Bishopc342db32019-05-15 21:57:59 -0400179 "
Brad Bishopc342db32019-05-15 21:57:59 -0400180 # Get the vg test scripts, filters, and expected files
181 for dir in $subdirs ; do
182 find $dir | cpio -pvdu ${D}${PTEST_PATH}
183 done
184 cd $saved_dir
185 done
186
Brad Bishopa34c0302019-09-23 22:34:48 -0400187 # The scripts reference config.h so add it to the top ptest dir.
188 cp ${B}/config.h ${D}${PTEST_PATH}
189 install -D ${WORKDIR}/remove-for-aarch64 ${D}${PTEST_PATH}
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600190 install -D ${WORKDIR}/remove-for-all ${D}${PTEST_PATH}
Brad Bishopa34c0302019-09-23 22:34:48 -0400191
192 # Add an executable need by none/tests/bigcode
193 mkdir ${D}${PTEST_PATH}/perf
194 cp ${B}/perf/bigcode ${D}${PTEST_PATH}/perf
195
196 # Add an executable needed by memcheck/tests/vcpu_bz2
197 cp ${B}/perf/bz2 ${D}${PTEST_PATH}/perf
198
199 # Make the ptest dir look like the top level valgrind src dir
200 # This is checked by the gdbserver_tests/make_local_links script
201 mkdir ${D}${PTEST_PATH}/coregrind
202 cp ${B}/coregrind/vgdb ${D}${PTEST_PATH}/coregrind
203
204 # Add an executable needed by massif tests
205 cp ${B}/massif/ms_print ${D}${PTEST_PATH}/massif/ms_print
206
Brad Bishopc342db32019-05-15 21:57:59 -0400207 find ${D}${PTEST_PATH} \
Brad Bishopa34c0302019-09-23 22:34:48 -0400208 \( \
209 -name "Makefile*" \
Brad Bishopc342db32019-05-15 21:57:59 -0400210 -o -name "*.o" \
Brad Bishopa34c0302019-09-23 22:34:48 -0400211 \) \
Brad Bishopc342db32019-05-15 21:57:59 -0400212 -exec rm {} \;
Brad Bishopa34c0302019-09-23 22:34:48 -0400213
214 # These files need to be newer so touch them.
Brad Bishop15ae2502019-06-18 21:44:24 -0400215 touch ${D}${PTEST_PATH}/cachegrind/tests/a.c -r ${D}${PTEST_PATH}/cachegrind/tests/cgout-test
Brad Bishopc342db32019-05-15 21:57:59 -0400216
217 # find *_annotate in ${bindir} for yocto build
218 sed -i s:\.\./\.\./cachegrind/cg_annotate:${bindir}/cg_annotate: ${D}${PTEST_PATH}/cachegrind/tests/ann1.vgtest
219 sed -i s:\.\./\.\./cachegrind/cg_annotate:${bindir}/cg_annotate: ${D}${PTEST_PATH}/cachegrind/tests/ann2.vgtest
220
221 sed -i s:\.\./\.\./callgrind/callgrind_annotate:${bindir}/callgrind_annotate: ${D}${PTEST_PATH}/callgrind/tests/ann1.vgtest
222 sed -i s:\.\./\.\./callgrind/callgrind_annotate:${bindir}/callgrind_annotate: ${D}${PTEST_PATH}/callgrind/tests/ann2.vgtest
223
Brad Bishopc342db32019-05-15 21:57:59 -0400224 # handle multilib
225 sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest
Brad Bishopa34c0302019-09-23 22:34:48 -0400226 sed -i s:@bindir@:${bindir}:g ${D}${PTEST_PATH}/run-ptest
Andrew Geissler82c905d2020-04-13 13:39:40 -0500227
228 # This test fails on the host as well, using both 3.15 and git master (as of Jan 24 2020)
229 # https://bugs.kde.org/show_bug.cgi?id=402833
230 rm ${D}${PTEST_PATH}/memcheck/tests/overlap.vgtest
231
232 # As the binary isn't stripped or debug-splitted, the source file isn't fetched
233 # via dwarfsrcfiles either, so it needs to be installed manually.
234 mkdir -p ${D}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/${BP}/none/tests/
235 install ${S}/none/tests/tls.c ${D}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/${BP}/none/tests/
Brad Bishopc342db32019-05-15 21:57:59 -0400236}
Andrew Geissler82c905d2020-04-13 13:39:40 -0500237
238# avoid stripping some generated binaries otherwise some of the tests will fail
239# run-strip-reloc.sh, run-strip-strmerge.sh and so on will fail
240INHIBIT_PACKAGE_STRIP_FILES = "\
241 ${PKGD}${PTEST_PATH}/none/tests/tls \
242 ${PKGD}${PTEST_PATH}/none/tests/tls.so \
243 ${PKGD}${PTEST_PATH}/none/tests/tls2.so \
244 ${PKGD}${PTEST_PATH}/helgrind/tests/tc09_bad_unlock \
245 ${PKGD}${PTEST_PATH}/memcheck/tests/manuel1 \
246 ${PKGD}${PTEST_PATH}/drd/tests/pth_detached3 \
247"