Ed Tanous | 2c2a1c5 | 2018-01-29 10:56:52 -0800 | [diff] [blame] | 1 | LICENSE = "Apache-2.0" |
Andrew Geissler | e11f5e2 | 2021-07-20 18:10:59 +0000 | [diff] [blame] | 2 | LIC_FILES_CHKSUM = "file://LICENSE;md5=175792518e4ac015ab6696d16c4f607e" |
Ed Tanous | 07f48cc | 2021-02-22 10:49:30 -0800 | [diff] [blame] | 3 | DEPENDS = " \ |
| 4 | openssl \ |
| 5 | zlib \ |
| 6 | boost \ |
Ed Tanous | 07f48cc | 2021-02-22 10:49:30 -0800 | [diff] [blame] | 7 | libpam \ |
| 8 | sdbusplus \ |
| 9 | gtest \ |
| 10 | nlohmann-json \ |
| 11 | libtinyxml2 \ |
Ed Tanous | a994d3a | 2021-06-16 12:44:37 -0700 | [diff] [blame] | 12 | nghttp2 \ |
Ed Tanous | a443c54 | 2021-02-26 13:28:37 -0800 | [diff] [blame] | 13 | ${@bb.utils.contains('PTEST_ENABLED', '1', 'gtest', '', d)} \ |
| 14 | ${@bb.utils.contains('PTEST_ENABLED', '1', 'gmock', '', d)} \ |
Ed Tanous | 07f48cc | 2021-02-22 10:49:30 -0800 | [diff] [blame] | 15 | " |
Andrew Geissler | 35364bb | 2024-02-23 15:50:27 -0600 | [diff] [blame] | 16 | SRCREV = "6b9ac4f23ed00c3905c9b99f1d0831930acdbb1c" |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 17 | PV = "1.0+git${SRCPV}" |
Ed Tanous | 2c2a1c5 | 2018-01-29 10:56:52 -0800 | [diff] [blame] | 18 | |
Patrick Williams | 0b73b98 | 2023-01-26 10:24:41 -0600 | [diff] [blame] | 19 | SRC_URI = "git://github.com/openbmc/bmcweb.git;branch=master;protocol=https" |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 20 | SRC_URI += " \ |
| 21 | file://run-ptest \ |
Ed Tanous | 07f48cc | 2021-02-22 10:49:30 -0800 | [diff] [blame] | 22 | " |
Adriana Kobylak | 7e0ff54f | 2018-12-13 11:01:05 -0600 | [diff] [blame] | 23 | |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 24 | S = "${WORKDIR}/git" |
| 25 | SYSTEMD_SERVICE:${PN} += "bmcweb.service bmcweb.socket" |
Ed Tanous | a443c54 | 2021-02-26 13:28:37 -0800 | [diff] [blame] | 26 | |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 27 | inherit systemd |
| 28 | inherit useradd |
| 29 | inherit pkgconfig meson ptest |
Ed Tanous | 2c2a1c5 | 2018-01-29 10:56:52 -0800 | [diff] [blame] | 30 | |
Patrick Williams | 4b5fdfa | 2024-02-23 09:35:19 -0600 | [diff] [blame^] | 31 | PACKAGECONFIG ??= "mutual-tls-auth" |
Patrick Williams | a758752 | 2023-06-13 14:43:24 -0500 | [diff] [blame] | 32 | PACKAGECONFIG[insecure-redfish-expand]="-Dinsecure-enable-redfish-query=enabled" |
Patrick Williams | 4b5fdfa | 2024-02-23 09:35:19 -0600 | [diff] [blame^] | 33 | PACKAGECONFIG[mutual-tls-auth]="-Dmutual-tls-auth=enabled,-Dmutual-tls-auth=disabled" |
Patrick Williams | a758752 | 2023-06-13 14:43:24 -0500 | [diff] [blame] | 34 | |
Ed Tanous | a443c54 | 2021-02-26 13:28:37 -0800 | [diff] [blame] | 35 | EXTRA_OEMESON = " \ |
| 36 | --buildtype=minsize \ |
| 37 | -Dtests=${@bb.utils.contains('PTEST_ENABLED', '1', 'enabled', 'disabled', d)} \ |
Ed Tanous | a443c54 | 2021-02-26 13:28:37 -0800 | [diff] [blame] | 38 | " |
Ed Tanous | 2c2a1c5 | 2018-01-29 10:56:52 -0800 | [diff] [blame] | 39 | |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 40 | do_install_ptest() { |
| 41 | install -d ${D}${PTEST_PATH}/test |
| 42 | cp -rf ${B}/*_test ${D}${PTEST_PATH}/test/ |
| 43 | } |
Ed Tanous | 2c2a1c5 | 2018-01-29 10:56:52 -0800 | [diff] [blame] | 44 | |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 45 | RDEPENDS:${PN} += " \ |
| 46 | jsnbd \ |
Patrick Williams | 0450a02 | 2022-10-07 21:23:47 -0500 | [diff] [blame] | 47 | phosphor-objmgr \ |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 48 | " |
| 49 | |
| 50 | FILES:${PN} += "${datadir}/** " |
| 51 | |
| 52 | USERADD_PACKAGES = "${PN}" |
| 53 | # add a user called httpd for the server to assume |
| 54 | USERADD_PARAM:${PN} = "-r -s /sbin/nologin bmcweb" |
| 55 | |
Ninad Palsule | 34d2144 | 2023-03-09 10:20:38 -0600 | [diff] [blame] | 56 | GROUPADD_PARAM:${PN} = "web; redfish; hostconsole" |
Andrew Jeffery | 224f26f | 2023-03-10 12:38:57 +1030 | [diff] [blame] | 57 | FULL_OPTIMIZATION:append = " -Os" |