blob: 7805c9cacd785126ad1b7071924f3881e4ca58a0 [file] [log] [blame]
Brad Bishopea02e472017-05-12 13:02:56 -04001SUMMARY = "Phosphor OpenBMC event and error logging"
2DESCRIPTION = "An error and event log daemon application, and \
3 supporting tools for OpenBMC."
Adriana Kobylak172fe102016-10-19 14:58:25 -05004HOMEPAGE = "https://github.com/openbmc/phosphor-logging"
5PR = "r1"
Patrick Venturef6dd86b2018-10-21 08:22:43 -07006PV = "1.0+git${SRCPV}"
Adriana Kobylak172fe102016-10-19 14:58:25 -05007
8inherit autotools pkgconfig
9inherit pythonnative
10inherit obmc-phosphor-license
11inherit obmc-phosphor-dbus-service
Deepak Kodihalli44b1c522017-03-16 06:32:12 -050012inherit phosphor-logging
Marri Devender Rao56eae0a2017-06-06 08:39:39 -050013inherit phosphor-dbus-yaml
Adriana Kobylak172fe102016-10-19 14:58:25 -050014
Adriana Kobylak172fe102016-10-19 14:58:25 -050015DEPENDS += "autoconf-archive-native"
16DEPENDS += "systemd"
17DEPENDS += "python-mako-native"
18DEPENDS += "python-pyyaml-native"
Patrick Williams57b17812016-12-09 08:56:38 -060019DEPENDS += "sdbusplus sdbusplus-native"
Deepak Kodihallic8d92052017-03-23 03:52:28 -050020DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
Deepak Kodihalli44b1c522017-03-16 06:32:12 -050021DEPENDS += "virtual/phosphor-logging-callouts"
Marri Devender Raof2ea35d2017-05-14 09:01:35 -050022DEPENDS += "phosphor-logging-error-logs-native"
Marri Devender Rao6675eac2017-09-27 10:56:40 -050023DEPENDS += "phosphor-logging-native"
Brad Bishopcc51cd92018-10-18 17:07:53 -040024DEPENDS += "libcereal"
Adriana Kobylak172fe102016-10-19 14:58:25 -050025
Michael Tritzccc0d0f2017-03-13 14:54:24 -050026PACKAGE_BEFORE_PN = "${PN}-test"
27FILES_${PN}-test = "${bindir}/*-test"
28
Marri Devender Rao6675eac2017-09-27 10:56:40 -050029PACKAGE_BEFORE_PN += "${PN}-elog"
30FILES_${PN}-elog += "${elog_dir}"
31
Deepak Kodihalli38af2c02018-08-24 08:05:14 -050032# Package configuration
33LOGGING_PACKAGES = " \
34 ${PN}-base \
Deepak Kodihallif99f3c82018-08-28 11:39:41 -050035 phosphor-rsyslog-config \
Deepak Kodihalli38af2c02018-08-24 08:05:14 -050036"
37
38ALLOW_EMPTY_${PN} = "1"
39PACKAGE_BEFORE_PN += "${LOGGING_PACKAGES}"
40SYSTEMD_PACKAGES = "${LOGGING_PACKAGES}"
41DBUS_PACKAGES = "${LOGGING_PACKAGES}"
42
43RDEPENDS_${PN}-base += "sdbusplus phosphor-dbus-interfaces"
44FILES_${PN}-base += " \
45 ${sbindir}/phosphor-log-manager \
46 ${libdir}/libphosphor_logging.so.* \
47"
48DBUS_SERVICE_${PN}-base += "xyz.openbmc_project.Logging.service"
49
Deepak Kodihallif99f3c82018-08-28 11:39:41 -050050RDEPENDS_phosphor-rsyslog-config += "sdbusplus phosphor-dbus-interfaces"
51DBUS_SERVICE_phosphor-rsyslog-config += "xyz.openbmc_project.Syslog.Config.service"
52FILES_phosphor-rsyslog-config += " \
53 ${sbindir}/phosphor-rsyslog-conf \
54"
55
Adriana Kobylak172fe102016-10-19 14:58:25 -050056SRC_URI += "git://github.com/openbmc/phosphor-logging"
Andrew Geisslerc78fde72018-10-18 07:00:36 +000057SRCREV = "aabb92ef56c4faa8f05487e9fcdf83f1053f1a22"
Adriana Kobylak172fe102016-10-19 14:58:25 -050058
59S = "${WORKDIR}/git"
60
Marri Devender Rao6675eac2017-09-27 10:56:40 -050061# Do not DEPEND on the specified packages for native build
62# as they will not be available in host machine
Brad Bishopefeb13a2018-01-27 00:27:21 -050063DEPENDS_remove_class-native = " \
Marri Devender Rao6675eac2017-09-27 10:56:40 -050064 virtual/phosphor-logging-callouts \
Brad Bishopefeb13a2018-01-27 00:27:21 -050065 sdbus++ \
66 systemd \
Brad Bishopcc51cd92018-10-18 17:07:53 -040067 libcereal \
Marri Devender Rao6675eac2017-09-27 10:56:40 -050068 "
69
70# Do not DEPEND on the specified packages for native SDK build
71# as they will not be available in host machine
72DEPENDS_remove_class-nativesdk = " \
73 virtual/phosphor-logging-callouts \
74 sdbus++-native \
Brad Bishopcc51cd92018-10-18 17:07:53 -040075 libcereal \
Brad Bishopefeb13a2018-01-27 00:27:21 -050076 systemd \
77 phosphor-dbus-interfaces \
Marri Devender Rao6675eac2017-09-27 10:56:40 -050078 "
79
80PACKAGECONFIG ??= "metadata-processing install_scripts"
81
Deepak Kodihalli2551ece2017-03-28 07:47:51 -050082PACKAGECONFIG[metadata-processing] = " \
83 --enable-metadata-processing, \
84 --disable-metadata-processing, , \
85 "
86
Marri Devender Rao6675eac2017-09-27 10:56:40 -050087# Provide a means to enable/disable install_scripts feature
88PACKAGECONFIG[install_scripts] = " \
89 --enable-install_scripts, \
90 --disable-install_scripts, ,\
91 "
92
93# Enable install_scripts during native and native SDK build
94PACKAGECONFIG_add_class-native = "install_scripts"
95PACKAGECONFIG_add_class-nativesdk = "install_scripts"
96
97# Disable install_scripts during target build
98PACKAGECONFIG_remove_class-target = "install_scripts"
99
Deepak Kodihalli44b1c522017-03-16 06:32:12 -0500100EXTRA_OECONF = " \
101 YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir} \
102 CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
103 "
Marri Devender Rao6675eac2017-09-27 10:56:40 -0500104
105BBCLASSEXTEND += "native nativesdk"