blob: b33df921d953e77fd3b67452a97ac0dfbebba12a [file] [log] [blame]
Cyril Burb73580e2017-01-12 18:13:30 +11001SUMMARY = "Phosphor OpenBMC MBOX Daemon"
2DESCRIPTION = "Phosphor OpenBMC MBOX Daemon"
3PR = "r1"
Patrick Venturecef2b3b2018-10-21 08:26:38 -07004PV = "1.0+git${SRCPV}"
Cyril Burb73580e2017-01-12 18:13:30 +11005LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
7
8inherit autotools pkgconfig
9inherit obmc-phosphor-systemd
10
11DEPENDS += "autoconf-archive-native"
Andrew Jeffery5ade8402017-04-21 10:18:24 +093012DEPENDS += "systemd"
Patrick Williamsf55db882017-06-30 12:01:49 -050013DEPENDS += "phosphor-logging"
Cyril Burb73580e2017-01-12 18:13:30 +110014
15S = "${WORKDIR}/git"
16
Adriana Kobylak87f59c92018-09-10 11:44:29 -050017SRC_URI += "git://github.com/openbmc/mboxbridge.git"
Cyril Burb73580e2017-01-12 18:13:30 +110018
Andrew Jeffery2a0cb542017-01-25 13:17:13 +103019SRC_URI += "file://99-aspeed-lpc-ctrl.rules"
Cyril Burb73580e2017-01-12 18:13:30 +110020SRC_URI += "file://aspeed-lpc-ctrl-h.patch"
21
Andrew Geissler744b7792019-10-13 22:51:20 +000022SRCREV="0acc669979cc5b1b66c2c4e5d975c60779bedd81"
Andrew Jeffery2c567ba2017-04-18 16:30:10 +093023
24PROVIDES += "mboxctl"
Cyril Burb73580e2017-01-12 18:13:30 +110025
26MBOXD_FLASH_SIZE ??= "32M"
27SYSTEMD_SUBSTITUTIONS += "FLASH_SIZE:${MBOXD_FLASH_SIZE}:${PN}.service"
28
29# Hacks because ${STAGING_KERNEL_DIR} points to the kernel source tree, not the
30# installed, pre-processed headers. Requires the aspeed-lpc-ctrl-h patch above.
Saqib Khanc8afc6a2017-03-09 10:28:09 -060031CFLAGS_append = " -I include"
Cyril Burb73580e2017-01-12 18:13:30 +110032
33do_install_append() {
34 install -d ${D}/lib/udev/rules.d
Andrew Jeffery2a0cb542017-01-25 13:17:13 +103035 install -m 0644 ${WORKDIR}/99-aspeed-lpc-ctrl.rules ${D}/lib/udev/rules.d
Cyril Burb73580e2017-01-12 18:13:30 +110036}
Matt Spinler9f77d282017-01-20 15:32:07 -060037
38TMPL = "mboxd-reload@.service"
Andrew Geissler58041192017-07-25 09:12:37 -050039TGTFMT = "obmc-chassis-poweron@{0}.target"
Matt Spinler9f77d282017-01-20 15:32:07 -060040INSTFMT = "mboxd-reload@{0}.service"
41FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}"
42
43SYSTEMD_SERVICE_${PN} += "mboxd.service"
44SYSTEMD_SERVICE_${PN} += "mboxd-reload@.service"
45SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
Deepak Kodihallidd05b962017-06-29 09:56:24 -050046
Brad Bishop09806a52018-03-09 00:40:41 -050047# Enable virtual-pnor by DISTRO_FEATURE openpower-ubi-fs.
48PACKAGECONFIG_append_df-openpower-ubi-fs = "virtual-pnor"
Patrick Williams74d4dbc2017-08-09 16:36:51 -050049PACKAGECONFIG[virtual-pnor] = "--enable-virtual-pnor,--disable-virtual-pnor"