blob: 31bc04635d8afe9f6b33e8ead23a510614c9db48 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Performance analysis tools for Linux"
2DESCRIPTION = "Performance counters for Linux are a new kernel-based \
3subsystem that provide a framework for all things \
4performance analysis. It covers hardware level \
5(CPU/PMU, Performance Monitoring Unit) features \
6and software features (software counters, tracepoints) \
7as well."
Joel Stanleye252c312017-12-14 15:11:12 +10308HOMEPAGE = "https://perf.wiki.kernel.org/index.php/Main_Page"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05009
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000010LICENSE = "GPL-2.0-only"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050011
12PR = "r9"
13
Joel Stanleye252c312017-12-14 15:11:12 +103014PACKAGECONFIG ??= "scripting tui libunwind"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015PACKAGECONFIG[dwarf] = ",NO_DWARF=1"
Brad Bishop79641f22019-09-10 07:20:22 -040016PACKAGECONFIG[scripting] = ",NO_LIBPERL=1 NO_LIBPYTHON=1,perl python3"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050017# gui support was added with kernel 3.6.35
18# since 3.10 libnewt was replaced by slang
19# to cover a wide range of kernel we add both dependencies
Joel Stanleye252c312017-12-14 15:11:12 +103020PACKAGECONFIG[tui] = ",NO_NEWT=1,libnewt slang"
21PACKAGECONFIG[libunwind] = ",NO_LIBUNWIND=1 NO_LIBDW_DWARF_UNWIND=1,libunwind"
22PACKAGECONFIG[libnuma] = ",NO_LIBNUMA=1"
Patrick Williams92b42cb2022-09-03 06:53:57 -050023PACKAGECONFIG[bfd] = ",NO_LIBBFD=1"
Joel Stanleye252c312017-12-14 15:11:12 +103024PACKAGECONFIG[systemtap] = ",NO_SDT=1,systemtap"
25PACKAGECONFIG[jvmti] = ",NO_JVMTI=1"
Brad Bishop316dfdd2018-06-25 12:45:53 -040026# libaudit support would need scripting to be enabled
27PACKAGECONFIG[audit] = ",NO_LIBAUDIT=1,audit"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028PACKAGECONFIG[manpages] = ",,xmlto-native asciidoc-native"
Brad Bishop64c979e2019-11-04 13:55:29 -050029PACKAGECONFIG[cap] = ",,libcap"
Andrew Geisslerb7d28612020-07-24 16:15:54 -050030# Arm CoreSight
31PACKAGECONFIG[coresight] = "CORESIGHT=1,,opencsd"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080032
33# libunwind is not yet ported for some architectures
Patrick Williams213cb262021-08-07 19:21:33 -050034PACKAGECONFIG:remove:arc = "libunwind"
Patrick Williams213cb262021-08-07 19:21:33 -050035PACKAGECONFIG:remove:riscv32 = "libunwind"
Brad Bishop316dfdd2018-06-25 12:45:53 -040036
Patrick Williamsc124f4f2015-09-15 14:41:29 -050037DEPENDS = " \
38 virtual/${MLPREFIX}libc \
39 ${MLPREFIX}elfutils \
40 ${MLPREFIX}binutils \
Brad Bishop316dfdd2018-06-25 12:45:53 -040041 bison-native flex-native xz \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050042"
43
44do_configure[depends] += "virtual/kernel:do_shared_workdir"
45
46PROVIDES = "virtual/perf"
47
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080048inherit linux-kernel-base kernel-arch manpages
Patrick Williamsc124f4f2015-09-15 14:41:29 -050049
50# needed for building the tools/perf Python bindings
Andrew Geissler09036742021-06-25 14:25:14 -050051inherit ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'python3targetconfig', '', d)}
Brad Bishop79641f22019-09-10 07:20:22 -040052inherit python3-dir
Patrick Williamsc124f4f2015-09-15 14:41:29 -050053export PYTHON_SITEPACKAGES_DIR
54
55#kernel 3.1+ supports WERROR to disable warnings as errors
56export WERROR = "0"
57
Andrew Geissler82c905d2020-04-13 13:39:40 -050058do_populate_lic[depends] += "virtual/kernel:do_shared_workdir"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050059
60# needed for building the tools/perf Perl binding
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080061include ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'perf-perl.inc', '', d)}
Patrick Williamsc124f4f2015-09-15 14:41:29 -050062
63inherit kernelsrc
64
Brad Bishop316dfdd2018-06-25 12:45:53 -040065S = "${WORKDIR}/${BP}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050066SPDX_S = "${S}/tools/perf"
67
Patrick Williamsc124f4f2015-09-15 14:41:29 -050068# The LDFLAGS is required or some old kernels fails due missing
69# symbols and this is preferred than requiring patches to every old
70# supported kernel.
71LDFLAGS="-ldl -lutil"
72
73EXTRA_OEMAKE = '\
Andrew Geissler635e0e42020-08-21 15:58:33 -050074 V=1 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050075 -C ${S}/tools/perf \
76 O=${B} \
77 CROSS_COMPILE=${TARGET_PREFIX} \
78 ARCH=${ARCH} \
79 CC="${CC}" \
Andrew Geissler82c905d2020-04-13 13:39:40 -050080 CCLD="${CC}" \
81 LDSHARED="${CC} -shared" \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050082 AR="${AR}" \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060083 LD="${LD}" \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050084 EXTRA_CFLAGS="-ldw" \
Andrew Geissler95ac1b82021-03-31 14:34:31 -050085 YFLAGS='-y --file-prefix-map=${WORKDIR}=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}' \
Joel Stanleye252c312017-12-14 15:11:12 +103086 EXTRA_LDFLAGS="${PERF_EXTRA_LDFLAGS}" \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050087 perfexecdir=${libexecdir} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080088 NO_GTK2=1 \
Joel Stanleye252c312017-12-14 15:11:12 +103089 ${PACKAGECONFIG_CONFARGS} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080090 TMPDIR="${B}" \
Brad Bishop19323692019-04-05 15:28:33 -040091 LIBUNWIND_DIR=${STAGING_EXECPREFIXDIR} \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050092'
93
94EXTRA_OEMAKE += "\
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050095 'DESTDIR=${D}' \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050096 'prefix=${prefix}' \
97 'bindir=${bindir}' \
98 'sharedir=${datadir}' \
99 'sysconfdir=${sysconfdir}' \
100 'perfexecdir=${libexecdir}/perf-core' \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500101 'ETC_PERFCONFIG=${@os.path.relpath(sysconfdir, prefix)}' \
102 'sharedir=${@os.path.relpath(datadir, prefix)}' \
103 'mandir=${@os.path.relpath(mandir, prefix)}' \
104 'infodir=${@os.path.relpath(infodir, prefix)}' \
Brad Bishop79641f22019-09-10 07:20:22 -0400105 ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'PYTHON=python3 PYTHON_CONFIG=python3-config', '', d)} \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500106"
107
Brad Bishopd5ae7d92018-06-14 09:52:03 -0700108# During do_configure, we might run a 'make clean'. That often breaks
109# when done in parallel, so disable parallelism for do_configure. Note
110# that it has to be done this way rather than by passing -j1, since
111# perf's build system by default ignores any -j argument, but does
112# honour a JOBS variable.
Patrick Williams213cb262021-08-07 19:21:33 -0500113EXTRA_OEMAKE:append:task-configure = " JOBS=1"
Brad Bishopd5ae7d92018-06-14 09:52:03 -0700114
Brad Bishop316dfdd2018-06-25 12:45:53 -0400115PERF_SRC ?= "Makefile \
Brad Bishop316dfdd2018-06-25 12:45:53 -0400116 tools/arch \
117 tools/build \
118 tools/include \
119 tools/lib \
120 tools/Makefile \
121 tools/perf \
122 tools/scripts \
Brad Bishop64c979e2019-11-04 13:55:29 -0500123 scripts/ \
124 arch/${ARCH}/Makefile \
Brad Bishop316dfdd2018-06-25 12:45:53 -0400125"
126
Joel Stanleye252c312017-12-14 15:11:12 +1030127PERF_EXTRA_LDFLAGS = ""
128
Andrew Geissler595f6302022-01-24 19:11:47 +0000129# MIPS N32/N64
Patrick Williams213cb262021-08-07 19:21:33 -0500130PERF_EXTRA_LDFLAGS:mipsarchn32eb = "-m elf32btsmipn32"
131PERF_EXTRA_LDFLAGS:mipsarchn32el = "-m elf32ltsmipn32"
Andrew Geissler595f6302022-01-24 19:11:47 +0000132PERF_EXTRA_LDFLAGS:mipsarchn64eb = "-m elf64btsmip"
133PERF_EXTRA_LDFLAGS:mipsarchn64el = "-m elf64ltsmip"
Joel Stanleye252c312017-12-14 15:11:12 +1030134
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500135do_compile() {
136 # Linux kernel build system is expected to do the right thing
137 unset CFLAGS
138 oe_runmake all
139}
140
141do_install() {
142 # Linux kernel build system is expected to do the right thing
143 unset CFLAGS
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500144 oe_runmake install
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500145 # we are checking for this make target to be compatible with older perf versions
Joel Stanleye252c312017-12-14 15:11:12 +1030146 if ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'true', 'false', d)} && grep -q install-python_ext ${S}/tools/perf/Makefile*; then
Brad Bishop79641f22019-09-10 07:20:22 -0400147 oe_runmake DESTDIR=${D} install-python_ext
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500148 if [ -e ${D}${libdir}/python*/site-packages/perf-*/SOURCES.txt ]; then
149 sed -i -e 's#${WORKDIR}##g' ${D}${libdir}/python*/site-packages/perf-*/SOURCES.txt
150 fi
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500151 fi
152}
153
Brad Bishop316dfdd2018-06-25 12:45:53 -0400154do_configure[prefuncs] += "copy_perf_source_from_kernel"
155python copy_perf_source_from_kernel() {
156 sources = (d.getVar("PERF_SRC") or "").split()
157 src_dir = d.getVar("STAGING_KERNEL_DIR")
158 dest_dir = d.getVar("S")
159 bb.utils.mkdirhier(dest_dir)
Andrew Geissler82c905d2020-04-13 13:39:40 -0500160 bb.utils.prunedir(dest_dir)
Brad Bishop316dfdd2018-06-25 12:45:53 -0400161 for s in sources:
162 src = oe.path.join(src_dir, s)
163 dest = oe.path.join(dest_dir, s)
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800164 if not os.path.exists(src):
165 bb.fatal("Path does not exist: %s. Maybe PERF_SRC does not match the kernel version." % src)
Brad Bishop316dfdd2018-06-25 12:45:53 -0400166 if os.path.isdir(src):
167 oe.path.copyhardlinktree(src, dest)
168 else:
Brad Bishop64c979e2019-11-04 13:55:29 -0500169 src_path = os.path.dirname(s)
170 os.makedirs(os.path.join(dest_dir,src_path),exist_ok=True)
Brad Bishop316dfdd2018-06-25 12:45:53 -0400171 bb.utils.copyfile(src, dest)
172}
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500173
Patrick Williams213cb262021-08-07 19:21:33 -0500174do_configure:prepend () {
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500175 # If building a multlib based perf, the incorrect library path will be
176 # detected by perf, since it triggers via: ifeq ($(ARCH),x86_64). In a 32 bit
William A. Kennington IIIac69b482021-06-02 12:28:27 -0700177 # build, with a 64 bit multilib, the arch won't match and the detection of a
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500178 # 64 bit build (and library) are not exected. To ensure that libraries are
179 # installed to the correct location, we can use the weak assignment in the
180 # config/Makefile.
181 #
182 # Also need to relocate .config-detected to $(OUTPUT)/config-detected
183 # for kernel sources that do not already do this
184 # as two builds (e.g. perf and lib32-perf from mutlilib can conflict
185 # with each other if its in the shared source directory
186 #
187 if [ -e "${S}/tools/perf/config/Makefile" ]; then
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600188 perfconfig="${S}/tools/perf/config/Makefile"
189 fi
190 if [ -e "${S}/tools/perf/Makefile.config" ]; then
191 perfconfig="${S}/tools/perf/Makefile.config"
192 fi
193 if [ -n "${perfconfig}" ]; then
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500194 # Match $(prefix)/$(lib) and $(prefix)/lib
195 sed -i -e 's,^libdir = \($(prefix)/.*lib\),libdir ?= \1,' \
196 -e 's,^perfexecdir = \(.*\),perfexecdir ?= \1,' \
197 -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600198 ${perfconfig}
199 fi
200 # The man pages installation is "$(INSTALL) -d -m 755 $(DESTDIR)$(man1dir)"
201 # in ${S}/tools/perf/Documentation/Makefile, if the mandir set to '?=', it
202 # will use the relative path 'share/man', in the way it will resulting in
203 # incorrect installation for man pages.
204 if [ -e "${S}/tools/perf/Documentation/Makefile" ]; then
205 sed -i 's,^mandir?=,mandir:=,' ${S}/tools/perf/Documentation/Makefile
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500206 fi
207 if [ -e "${S}/tools/perf/Makefile.perf" ]; then
208 sed -i -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
209 ${S}/tools/perf/Makefile.perf
Patrick Williams92b42cb2022-09-03 06:53:57 -0500210 sed -i -e "s,prefix='\$(DESTDIR_SQ)/usr'$,prefix='\$(DESTDIR_SQ)/usr' --install-lib='\$(PYTHON_SITEPACKAGES_DIR)' --root='\$(DESTDIR)',g" \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500211 ${S}/tools/perf/Makefile.perf
Andrew Geissler635e0e42020-08-21 15:58:33 -0500212 # backport https://github.com/torvalds/linux/commit/e4ffd066ff440a57097e9140fa9e16ceef905de8
213 sed -i -e 's,\($(Q)$(SHELL) .$(arch_errno_tbl).\) $(CC) $(arch_errno_hdr_dir),\1 $(firstword $(CC)) $(arch_errno_hdr_dir),g' \
214 ${S}/tools/perf/Makefile.perf
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500215 fi
216 sed -i -e "s,--root='/\$(DESTDIR_SQ)',--prefix='\$(DESTDIR_SQ)/usr' --install-lib='\$(DESTDIR)\$(PYTHON_SITEPACKAGES_DIR)',g" \
Patrick Williamsd7e96312015-09-22 08:09:05 -0500217 ${S}/tools/perf/Makefile*
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500218
219 if [ -e "${S}/tools/build/Makefile.build" ]; then
220 sed -i -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
221 ${S}/tools/build/Makefile.build
222 fi
223
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500224 # start reproducibility substitutions
225 if [ -e "${S}/tools/perf/Makefile.config" ]; then
226 # The following line in the Makefle:
227 # override PYTHON := $(call get-executable-or-default,PYTHON,$(PYTHON_AUTO))
228 # "PYTHON" / "PYTHON_AUTO" have the full path as part of the variable. We've
229 # ensure that the environment is setup and we do not need the full path to be
230 # captured, since the symbol gets built into the executable, making it not
231 # reproducible.
232 sed -i -e 's,$(call get-executable-or-default\,PYTHON\,$(PYTHON_AUTO)),$(notdir $(call get-executable-or-default\,PYTHON\,$(PYTHON_AUTO))),g' \
233 ${S}/tools/perf/Makefile.config
Patrick Williamsdb4c27e2022-08-05 08:10:29 -0500234 # The same line is in older releases, but looking explicitly for Python 2
235 sed -i -e 's,$(call get-executable-or-default\,PYTHON\,$(PYTHON2)),$(notdir $(call get-executable-or-default\,PYTHON\,$(PYTHON2))),g' \
236 ${S}/tools/perf/Makefile.config
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500237
Andrew Geissler615f2f12022-07-15 14:00:58 -0500238 # likewise with this substitution. Kernels with commit 18f2967418d031a39
239 # [perf tools: Use Python devtools for version autodetection rather than runtime]
240 # need this substitution for reproducibility.
241 sed -i -e 's,$(call get-executable-or-default\,PYTHON\,$(subst -config\,\,$(PYTHON_AUTO))),$(notdir $(call get-executable-or-default\,PYTHON\,$(subst -config\,\,$(PYTHON_AUTO)))),g' \
242 ${S}/tools/perf/Makefile.config
243
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500244 # The following line:
245 # srcdir_SQ = $(patsubst %tools/perf,tools/perf,$(subst ','\'',$(srcdir))),
246 # Captures the full src path of perf, which of course makes it not
247 # reproducible. We really only need the relative location 'tools/perf', so we
248 # change the Makefile line to remove everything before 'tools/perf'
249 sed -i -e "s%srcdir_SQ = \$(subst ','\\\'',\$(srcdir))%srcdir_SQ = \$(patsubst \%tools/perf,tools/perf,\$(subst ','\\\'',\$(srcdir)))%g" \
250 ${S}/tools/perf/Makefile.config
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500251 # Avoid hardcoded path to python-native
252 sed -i -e 's#\(PYTHON_WORD := \)$(call shell-wordify,$(PYTHON))#\1 python3#g' \
253 ${S}/tools/perf/Makefile.config
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500254 fi
255 if [ -e "${S}/tools/perf/tests/Build" ]; then
256 # OUTPUT is the full path, we have python on the path so we remove it from the
257 # definition. This is captured in the perf binary, so breaks reproducibility
258 sed -i -e 's,PYTHONPATH="BUILD_STR($(OUTPUT)python)",PYTHONPATH="BUILD_STR(python)",g' \
259 ${S}/tools/perf/tests/Build
260 fi
261 if [ -e "${S}/tools/perf/util/Build" ]; then
262 # To avoid bison generating #ifdefs that have captured paths, we make sure
263 # all the calls have YFLAGS, which contains prefix mapping information.
264 sed -i -e 's,$(BISON),$(BISON) $(YFLAGS),g' ${S}/tools/perf/util/Build
265 fi
266 if [ -e "${S}/scripts/Makefile.host" ]; then
267 # To avoid yacc (bison) generating #ifdefs that have captured paths, we make sure
268 # all the calls have YFLAGS, which contains prefix mapping information.
269 sed -i -e 's,$(YACC),$(YACC) $(YFLAGS),g' ${S}/scripts/Makefile.host
270 fi
271 if [ -e "${S}/tools/perf/pmu-events/Build" ]; then
272 target='$(OUTPUT)pmu-events/pmu-events.c $(V)'
273 replacement1='$(OUTPUT)pmu-events/pmu-events.c $(V)\n'
274 replacement2='\t$(srctree)/sort-pmuevents.py $(OUTPUT)pmu-events/pmu-events.c $(OUTPUT)pmu-events/pmu-events.c.new\n'
275 replacement3='\tcp $(OUTPUT)pmu-events/pmu-events.c.new $(OUTPUT)pmu-events/pmu-events.c'
276 sed -i -e "s,$target,$replacement1$replacement2$replacement3,g" \
277 "${S}/tools/perf/pmu-events/Build"
278 fi
279 # end reproducibility substitutions
280
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500281 # We need to ensure the --sysroot option in CC is preserved
282 if [ -e "${S}/tools/perf/Makefile.perf" ]; then
283 sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/perf/Makefile.perf
284 sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/perf/Makefile.perf
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600285 sed -i 's,LD = $(CROSS_COMPILE)ld,#LD,' ${S}/tools/perf/Makefile.perf
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500286 fi
287 if [ -e "${S}/tools/lib/api/Makefile" ]; then
288 sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/lib/api/Makefile
289 sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/lib/api/Makefile
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600290 sed -i 's,LD = $(CROSS_COMPILE)ld,#LD,' ${S}/tools/lib/api/Makefile
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500291 fi
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500292 if [ -e "${S}/tools/lib/subcmd/Makefile" ]; then
293 sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/lib/subcmd/Makefile
294 sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/lib/subcmd/Makefile
295 fi
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500296 if [ -e "${S}/tools/perf/config/feature-checks/Makefile" ]; then
297 sed -i 's,CC := $(CROSS_COMPILE)gcc -MD,CC += -MD,' ${S}/tools/perf/config/feature-checks/Makefile
298 fi
299 if [ -e "${S}/tools/build/Makefile.feature" ]; then
300 sed -i 's,CFLAGS=,CC="\$(CC)" CFLAGS=,' ${S}/tools/build/Makefile.feature
301 fi
302
303 # 3.17-rc1+ has a include issue for arm/powerpc. Temporarily sed in the appropriate include
304 if [ -e "${S}/tools/perf/arch/$ARCH/util/skip-callchain-idx.c" ]; then
305 sed -i 's,#include "util/callchain.h",#include "util/callchain.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/$ARCH/util/skip-callchain-idx.c
306 fi
307 if [ -e "${S}/tools/perf/arch/arm/util/unwind-libunwind.c" ] && [ -e "${S}/tools/perf/arch/arm/tests/dwarf-unwind.c" ]; then
308 sed -i 's,#include "tests/tests.h",#include "tests/tests.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/arm/tests/dwarf-unwind.c
309 sed -i 's,#include "perf_regs.h",#include "perf_regs.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/arm/util/unwind-libunwind.c
310 fi
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500311
312 # use /usr/bin/env instead of version specific python
Andrew Geissler82c905d2020-04-13 13:39:40 -0500313 for s in `find ${S}/tools/perf/ -name '*.py'` `find ${S}/scripts/ -name 'bpf_helpers_doc.py'`; do
314 sed -i -e "s,#!.*python.*,#!${USRBINPATH}/env python3," ${s}
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500315 done
Brad Bishop19323692019-04-05 15:28:33 -0400316
317 # unistd.h can be out of sync between libc-headers and the captured version in the perf source
318 # so we copy it from the sysroot unistd.h to the perf unistd.h
Brad Bishopc342db32019-05-15 21:57:59 -0400319 install -D -m0644 ${STAGING_INCDIR}/asm-generic/unistd.h ${S}/tools/include/uapi/asm-generic/unistd.h
Brad Bishop79641f22019-09-10 07:20:22 -0400320 install -D -m0644 ${STAGING_INCDIR}/asm-generic/unistd.h ${S}/include/uapi/asm-generic/unistd.h
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500321
322 # the fetcher is inhibited by the 'inherit kernelsrc', so we do a quick check and
323 # copy for a helper script we need
324 for p in $(echo ${FILESPATH} | tr ':' '\n'); do
325 if [ -e $p/sort-pmuevents.py ]; then
326 cp $p/sort-pmuevents.py ${S}
327 fi
328 done
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500329}
330
Patrick Williams213cb262021-08-07 19:21:33 -0500331python do_package:prepend() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500332 d.setVar('PKGV', d.getVar("KERNEL_VERSION").split("-")[0])
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500333}
334
335PACKAGE_ARCH = "${MACHINE_ARCH}"
336
337
338PACKAGES =+ "${PN}-archive ${PN}-tests ${PN}-perl ${PN}-python"
339
Patrick Williams213cb262021-08-07 19:21:33 -0500340RDEPENDS:${PN} += "elfutils bash"
341RDEPENDS:${PN}-archive =+ "bash"
342RDEPENDS:${PN}-python =+ "bash python3 python3-modules ${@bb.utils.contains('PACKAGECONFIG', 'audit', 'audit-python', '', d)}"
343RDEPENDS:${PN}-perl =+ "bash perl perl-modules"
344RDEPENDS:${PN}-tests =+ "python3 bash"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500345
Joel Stanleye252c312017-12-14 15:11:12 +1030346RSUGGESTS_SCRIPTING = "${@bb.utils.contains('PACKAGECONFIG', 'scripting', '${PN}-perl ${PN}-python', '',d)}"
Patrick Williams213cb262021-08-07 19:21:33 -0500347RSUGGESTS:${PN} += "${PN}-archive ${PN}-tests ${RSUGGESTS_SCRIPTING}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500348
Brad Bishop19323692019-04-05 15:28:33 -0400349FILES_SOLIBSDEV = ""
Patrick Williams213cb262021-08-07 19:21:33 -0500350FILES:${PN} += "${libexecdir}/perf-core ${exec_prefix}/libexec/perf-core ${libdir}/traceevent ${libdir}/libperf-jvmti.so"
351FILES:${PN}-archive = "${libdir}/perf/perf-core/perf-archive"
352FILES:${PN}-tests = "${libdir}/perf/perf-core/tests ${libexecdir}/perf-core/tests"
353FILES:${PN}-python = " \
Brad Bishop316dfdd2018-06-25 12:45:53 -0400354 ${PYTHON_SITEPACKAGES_DIR} \
355 ${libexecdir}/perf-core/scripts/python \
356 "
Patrick Williams213cb262021-08-07 19:21:33 -0500357FILES:${PN}-perl = "${libexecdir}/perf-core/scripts/perl"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500358
359
360INHIBIT_PACKAGE_DEBUG_SPLIT="1"
Patrick Williams213cb262021-08-07 19:21:33 -0500361DEBUG_OPTIMIZATION:append = " -Wno-error=maybe-uninitialized"