Brad Bishop | 5f9be07 | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 1 | SUMMARY = "OpenBMC gdbus library" |
| 2 | DESCRIPTION = "libopenbmc_intf provides a set of gpio access \ |
| 3 | methods and the GDBUS skeleton code for the org.openbmc DBUS API." |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 4 | DEPENDS += "glib-2.0" |
| 5 | DEPENDS += "cjson" |
Patrick Venture | 7888261 | 2018-10-23 08:59:23 -0700 | [diff] [blame] | 6 | PV = "1.0+git${SRCPV}" |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 7 | PR = "r1" |
| 8 | |
| 9 | SRC_URI += "file://gpio_defs.json" |
| 10 | |
| 11 | SKELETON_DIR = "libopenbmc_intf" |
Brad Bishop | 5f9be07 | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 12 | |
| 13 | inherit skeleton |
Saqib Khan | 02917df | 2017-11-13 10:47:54 -0600 | [diff] [blame] | 14 | inherit pkgconfig |
Brad Bishop | 5f9be07 | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 15 | |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 16 | do_install() { |
| 17 | oe_runmake install DESTDIR=${D} |
| 18 | install -d ${D}${sysconfdir}/default/obmc/gpio/ |
| 19 | install -m 0644 ${WORKDIR}/gpio_defs.json ${D}/${sysconfdir}/default/obmc/gpio/ |
| 20 | } |
Brad Bishop | 5f9be07 | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 21 | |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 22 | # Ensure the library is not in the dev package |
| 23 | FILES_SOLIBSDEV = "" |
| 24 | # Now add the link to the production package |
| 25 | FILES:${PN} += "${libdir}/libopenbmc_intf.so" |
Matt Spinler | 71c1c92 | 2018-08-07 16:35:19 -0500 | [diff] [blame] | 26 | |
Andrew Geissler | e381754 | 2020-07-14 13:41:21 -0500 | [diff] [blame] | 27 | # Users of libopenbmc_intf use custom makefiles that do not |
| 28 | # support the proper library version detection and linking. |
| 29 | # Because of that, a link must be created within the |
| 30 | # rootfs for applicaitons to use this library. |
| 31 | # This next line tells bitbake to skip the check which |
| 32 | # ensures no links are put in the rootfs |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 33 | INSANE_SKIP:${PN} += "dev-so" |