blob: b6542a191cfb4832f880c0d41e9513e9ddf14fe8 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "OpenGL driver testing framework"
2LICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
4
5SRC_URI = "git://anongit.freedesktop.org/piglit \
Patrick Williamsc0f7c042017-02-23 20:41:17 -06006 file://0001-cmake-install-bash-completions-in-the-right-place.patch \
7 file://0001-tests-Use-FE_UPWARD-only-if-its-defined-in-fenv.h.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008 file://0001-cmake-use-proper-WAYLAND_INCLUDE_DIRS-variable.patch \
Brad Bishop19323692019-04-05 15:28:33 -04009 file://format-fix.patch \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060010 "
Brad Bishop316dfdd2018-06-25 12:45:53 -040011UPSTREAM_CHECK_COMMITS = "1"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050012
Brad Bishop19323692019-04-05 15:28:33 -040013# From 2018-10-26
14SRCREV = "b9066c7717af1d169a616c9e61706b99ff8515b5"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050015# (when PV goes above 1.0 remove the trailing r)
16PV = "1.0+gitr${SRCPV}"
17
18S = "${WORKDIR}/git"
19
Brad Bishopc342db32019-05-15 21:57:59 -040020X11_DEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxrender libglu', '', d)}"
21X11_RDEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'mesa-demos', '', d)}"
22
23DEPENDS = "libpng waffle libxkbcommon virtual/libgl python3-mako-native python3-numpy-native python3-six-native virtual/egl"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050024
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080025inherit cmake pkgconfig python3native distro_features_check bash-completion
Patrick Williamsc124f4f2015-09-15 14:41:29 -050026
Brad Bishop6e60e8b2018-02-01 10:27:11 -050027# depends on virtual/libgl
28REQUIRED_DISTRO_FEATURES += "opengl"
29
Patrick Williamsf1e5d692016-03-30 15:21:19 -050030# The built scripts go into the temporary directory according to tempfile
31# (typically /tmp) which can race if multiple builds happen on the same machine,
32# so tell it to use a directory in ${B} to avoid overwriting.
33export TEMP = "${B}/temp/"
34do_compile[dirs] =+ "${B}/temp/"
35
Brad Bishopc342db32019-05-15 21:57:59 -040036PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050037PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
Brad Bishopc342db32019-05-15 21:57:59 -040038PACKAGECONFIG[x11] = "-DPIGLIT_BUILD_GL_TESTS=ON,-DPIGLIT_BUILD_GL_TESTS=OFF,${X11_DEPS}, ${X11_RDEPS}"
39
Patrick Williamsc124f4f2015-09-15 14:41:29 -050040
41do_configure_prepend() {
42 if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
43 sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
44 sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h
45 fi
46}
47
Brad Bishop316dfdd2018-06-25 12:45:53 -040048OECMAKE_TARGET_INSTALL = "install/strip"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060049
Brad Bishopa5c52ff2018-11-23 10:55:50 +130050RDEPENDS_${PN} = "waffle waffle-bin python3 python3-mako python3-json \
Brad Bishop316dfdd2018-06-25 12:45:53 -040051 python3-misc \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060052 python3-unixadmin python3-xml python3-multiprocessing \
Brad Bishop316dfdd2018-06-25 12:45:53 -040053 python3-six python3-shell python3-io \
Brad Bishopc342db32019-05-15 21:57:59 -040054 python3-netserver bash \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050055 "
56
Patrick Williamsc0f7c042017-02-23 20:41:17 -060057INSANE_SKIP_${PN} += "dev-so already-stripped"
Brad Bishop19323692019-04-05 15:28:33 -040058
59# Can't be built with ccache
60CCACHE_DISABLE = "1"