Brad Bishop | ea02e47 | 2017-05-12 13:02:56 -0400 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC event and error logging" |
| 2 | DESCRIPTION = "An error and event log daemon application, and \ |
| 3 | supporting tools for OpenBMC." |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 4 | HOMEPAGE = "https://github.com/openbmc/phosphor-logging" |
| 5 | PR = "r1" |
Patrick Venture | f6dd86b | 2018-10-21 08:22:43 -0700 | [diff] [blame] | 6 | PV = "1.0+git${SRCPV}" |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 7 | |
| 8 | inherit autotools pkgconfig |
| 9 | inherit pythonnative |
| 10 | inherit obmc-phosphor-license |
| 11 | inherit obmc-phosphor-dbus-service |
Deepak Kodihalli | 44b1c52 | 2017-03-16 06:32:12 -0500 | [diff] [blame] | 12 | inherit phosphor-logging |
Marri Devender Rao | 56eae0a | 2017-06-06 08:39:39 -0500 | [diff] [blame] | 13 | inherit phosphor-dbus-yaml |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 14 | |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 15 | DEPENDS += "autoconf-archive-native" |
| 16 | DEPENDS += "systemd" |
| 17 | DEPENDS += "python-mako-native" |
| 18 | DEPENDS += "python-pyyaml-native" |
Patrick Williams | 57b1781 | 2016-12-09 08:56:38 -0600 | [diff] [blame] | 19 | DEPENDS += "sdbusplus sdbusplus-native" |
Deepak Kodihalli | c8d9205 | 2017-03-23 03:52:28 -0500 | [diff] [blame] | 20 | DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native" |
Deepak Kodihalli | 44b1c52 | 2017-03-16 06:32:12 -0500 | [diff] [blame] | 21 | DEPENDS += "virtual/phosphor-logging-callouts" |
Marri Devender Rao | f2ea35d | 2017-05-14 09:01:35 -0500 | [diff] [blame] | 22 | DEPENDS += "phosphor-logging-error-logs-native" |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 23 | DEPENDS += "phosphor-logging-native" |
Brad Bishop | cc51cd9 | 2018-10-18 17:07:53 -0400 | [diff] [blame] | 24 | DEPENDS += "libcereal" |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 25 | |
Michael Tritz | ccc0d0f | 2017-03-13 14:54:24 -0500 | [diff] [blame] | 26 | PACKAGE_BEFORE_PN = "${PN}-test" |
| 27 | FILES_${PN}-test = "${bindir}/*-test" |
| 28 | |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 29 | PACKAGE_BEFORE_PN += "${PN}-elog" |
| 30 | FILES_${PN}-elog += "${elog_dir}" |
| 31 | |
Deepak Kodihalli | 38af2c0 | 2018-08-24 08:05:14 -0500 | [diff] [blame] | 32 | # Package configuration |
| 33 | LOGGING_PACKAGES = " \ |
| 34 | ${PN}-base \ |
Deepak Kodihalli | f99f3c8 | 2018-08-28 11:39:41 -0500 | [diff] [blame] | 35 | phosphor-rsyslog-config \ |
Deepak Kodihalli | 38af2c0 | 2018-08-24 08:05:14 -0500 | [diff] [blame] | 36 | " |
| 37 | |
| 38 | ALLOW_EMPTY_${PN} = "1" |
| 39 | PACKAGE_BEFORE_PN += "${LOGGING_PACKAGES}" |
| 40 | SYSTEMD_PACKAGES = "${LOGGING_PACKAGES}" |
| 41 | DBUS_PACKAGES = "${LOGGING_PACKAGES}" |
| 42 | |
| 43 | RDEPENDS_${PN}-base += "sdbusplus phosphor-dbus-interfaces" |
| 44 | FILES_${PN}-base += " \ |
| 45 | ${sbindir}/phosphor-log-manager \ |
| 46 | ${libdir}/libphosphor_logging.so.* \ |
| 47 | " |
| 48 | DBUS_SERVICE_${PN}-base += "xyz.openbmc_project.Logging.service" |
| 49 | |
Deepak Kodihalli | f99f3c8 | 2018-08-28 11:39:41 -0500 | [diff] [blame] | 50 | RDEPENDS_phosphor-rsyslog-config += "sdbusplus phosphor-dbus-interfaces" |
| 51 | DBUS_SERVICE_phosphor-rsyslog-config += "xyz.openbmc_project.Syslog.Config.service" |
| 52 | FILES_phosphor-rsyslog-config += " \ |
| 53 | ${sbindir}/phosphor-rsyslog-conf \ |
| 54 | " |
| 55 | |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 56 | SRC_URI += "git://github.com/openbmc/phosphor-logging" |
Andrew Geissler | c78fde7 | 2018-10-18 07:00:36 +0000 | [diff] [blame] | 57 | SRCREV = "aabb92ef56c4faa8f05487e9fcdf83f1053f1a22" |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 58 | |
| 59 | S = "${WORKDIR}/git" |
| 60 | |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 61 | # Do not DEPEND on the specified packages for native build |
| 62 | # as they will not be available in host machine |
Brad Bishop | efeb13a | 2018-01-27 00:27:21 -0500 | [diff] [blame] | 63 | DEPENDS_remove_class-native = " \ |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 64 | virtual/phosphor-logging-callouts \ |
Brad Bishop | efeb13a | 2018-01-27 00:27:21 -0500 | [diff] [blame] | 65 | sdbus++ \ |
| 66 | systemd \ |
Brad Bishop | cc51cd9 | 2018-10-18 17:07:53 -0400 | [diff] [blame] | 67 | libcereal \ |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 68 | " |
| 69 | |
| 70 | # Do not DEPEND on the specified packages for native SDK build |
| 71 | # as they will not be available in host machine |
| 72 | DEPENDS_remove_class-nativesdk = " \ |
| 73 | virtual/phosphor-logging-callouts \ |
| 74 | sdbus++-native \ |
Brad Bishop | cc51cd9 | 2018-10-18 17:07:53 -0400 | [diff] [blame] | 75 | libcereal \ |
Brad Bishop | efeb13a | 2018-01-27 00:27:21 -0500 | [diff] [blame] | 76 | systemd \ |
| 77 | phosphor-dbus-interfaces \ |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 78 | " |
| 79 | |
| 80 | PACKAGECONFIG ??= "metadata-processing install_scripts" |
| 81 | |
Deepak Kodihalli | 2551ece | 2017-03-28 07:47:51 -0500 | [diff] [blame] | 82 | PACKAGECONFIG[metadata-processing] = " \ |
| 83 | --enable-metadata-processing, \ |
| 84 | --disable-metadata-processing, , \ |
| 85 | " |
| 86 | |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 87 | # Provide a means to enable/disable install_scripts feature |
| 88 | PACKAGECONFIG[install_scripts] = " \ |
| 89 | --enable-install_scripts, \ |
| 90 | --disable-install_scripts, ,\ |
| 91 | " |
| 92 | |
| 93 | # Enable install_scripts during native and native SDK build |
| 94 | PACKAGECONFIG_add_class-native = "install_scripts" |
| 95 | PACKAGECONFIG_add_class-nativesdk = "install_scripts" |
| 96 | |
| 97 | # Disable install_scripts during target build |
| 98 | PACKAGECONFIG_remove_class-target = "install_scripts" |
| 99 | |
Deepak Kodihalli | 44b1c52 | 2017-03-16 06:32:12 -0500 | [diff] [blame] | 100 | EXTRA_OECONF = " \ |
| 101 | YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir} \ |
| 102 | CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \ |
| 103 | " |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 104 | |
| 105 | BBCLASSEXTEND += "native nativesdk" |