blob: 2f212d10c14dba56cf463405a02025eba975fb54 [file] [log] [blame]
Brad Bishopea02e472017-05-12 13:02:56 -04001SUMMARY = "Phosphor OpenBMC event and error logging"
2DESCRIPTION = "An error and event log daemon application, and \
3 supporting tools for OpenBMC."
Adriana Kobylak172fe102016-10-19 14:58:25 -05004HOMEPAGE = "https://github.com/openbmc/phosphor-logging"
5PR = "r1"
Patrick Venturef6dd86b2018-10-21 08:22:43 -07006PV = "1.0+git${SRCPV}"
Patrick Venturef66d71e2018-11-03 09:44:15 -07007LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Adriana Kobylak172fe102016-10-19 14:58:25 -05009
10inherit autotools pkgconfig
11inherit pythonnative
Adriana Kobylak172fe102016-10-19 14:58:25 -050012inherit obmc-phosphor-dbus-service
Deepak Kodihalli44b1c522017-03-16 06:32:12 -050013inherit phosphor-logging
Marri Devender Rao56eae0a2017-06-06 08:39:39 -050014inherit phosphor-dbus-yaml
Adriana Kobylak172fe102016-10-19 14:58:25 -050015
Adriana Kobylak172fe102016-10-19 14:58:25 -050016DEPENDS += "autoconf-archive-native"
17DEPENDS += "systemd"
18DEPENDS += "python-mako-native"
19DEPENDS += "python-pyyaml-native"
Patrick Williams57b17812016-12-09 08:56:38 -060020DEPENDS += "sdbusplus sdbusplus-native"
Deepak Kodihallic8d92052017-03-23 03:52:28 -050021DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
Deepak Kodihalli44b1c522017-03-16 06:32:12 -050022DEPENDS += "virtual/phosphor-logging-callouts"
Marri Devender Raof2ea35d2017-05-14 09:01:35 -050023DEPENDS += "phosphor-logging-error-logs-native"
Marri Devender Rao6675eac2017-09-27 10:56:40 -050024DEPENDS += "phosphor-logging-native"
Brad Bishopcc51cd92018-10-18 17:07:53 -040025DEPENDS += "libcereal"
Adriana Kobylak172fe102016-10-19 14:58:25 -050026
Michael Tritzccc0d0f2017-03-13 14:54:24 -050027PACKAGE_BEFORE_PN = "${PN}-test"
28FILES_${PN}-test = "${bindir}/*-test"
29
Marri Devender Rao6675eac2017-09-27 10:56:40 -050030PACKAGE_BEFORE_PN += "${PN}-elog"
31FILES_${PN}-elog += "${elog_dir}"
32
Deepak Kodihalli38af2c02018-08-24 08:05:14 -050033# Package configuration
34LOGGING_PACKAGES = " \
35 ${PN}-base \
Deepak Kodihallif99f3c82018-08-28 11:39:41 -050036 phosphor-rsyslog-config \
Deepak Kodihalli38af2c02018-08-24 08:05:14 -050037"
38
39ALLOW_EMPTY_${PN} = "1"
40PACKAGE_BEFORE_PN += "${LOGGING_PACKAGES}"
41SYSTEMD_PACKAGES = "${LOGGING_PACKAGES}"
42DBUS_PACKAGES = "${LOGGING_PACKAGES}"
43
44RDEPENDS_${PN}-base += "sdbusplus phosphor-dbus-interfaces"
45FILES_${PN}-base += " \
46 ${sbindir}/phosphor-log-manager \
47 ${libdir}/libphosphor_logging.so.* \
48"
49DBUS_SERVICE_${PN}-base += "xyz.openbmc_project.Logging.service"
50
Deepak Kodihallif99f3c82018-08-28 11:39:41 -050051RDEPENDS_phosphor-rsyslog-config += "sdbusplus phosphor-dbus-interfaces"
52DBUS_SERVICE_phosphor-rsyslog-config += "xyz.openbmc_project.Syslog.Config.service"
53FILES_phosphor-rsyslog-config += " \
54 ${sbindir}/phosphor-rsyslog-conf \
55"
56
Adriana Kobylak172fe102016-10-19 14:58:25 -050057SRC_URI += "git://github.com/openbmc/phosphor-logging"
Andrew Geissler46723732018-11-02 07:30:29 +000058SRCREV = "3922d1bbdabd82c95758c6f8b9675c9dcefb75d2"
Adriana Kobylak172fe102016-10-19 14:58:25 -050059
60S = "${WORKDIR}/git"
61
Marri Devender Rao6675eac2017-09-27 10:56:40 -050062# Do not DEPEND on the specified packages for native build
63# as they will not be available in host machine
Brad Bishopefeb13a2018-01-27 00:27:21 -050064DEPENDS_remove_class-native = " \
Marri Devender Rao6675eac2017-09-27 10:56:40 -050065 virtual/phosphor-logging-callouts \
Brad Bishopefeb13a2018-01-27 00:27:21 -050066 sdbus++ \
67 systemd \
Brad Bishopcc51cd92018-10-18 17:07:53 -040068 libcereal \
Marri Devender Rao6675eac2017-09-27 10:56:40 -050069 "
70
71# Do not DEPEND on the specified packages for native SDK build
72# as they will not be available in host machine
73DEPENDS_remove_class-nativesdk = " \
74 virtual/phosphor-logging-callouts \
75 sdbus++-native \
Brad Bishopcc51cd92018-10-18 17:07:53 -040076 libcereal \
Brad Bishopefeb13a2018-01-27 00:27:21 -050077 systemd \
78 phosphor-dbus-interfaces \
Marri Devender Rao6675eac2017-09-27 10:56:40 -050079 "
80
81PACKAGECONFIG ??= "metadata-processing install_scripts"
82
Deepak Kodihalli2551ece2017-03-28 07:47:51 -050083PACKAGECONFIG[metadata-processing] = " \
84 --enable-metadata-processing, \
85 --disable-metadata-processing, , \
86 "
87
Marri Devender Rao6675eac2017-09-27 10:56:40 -050088# Provide a means to enable/disable install_scripts feature
89PACKAGECONFIG[install_scripts] = " \
90 --enable-install_scripts, \
91 --disable-install_scripts, ,\
92 "
93
94# Enable install_scripts during native and native SDK build
95PACKAGECONFIG_add_class-native = "install_scripts"
96PACKAGECONFIG_add_class-nativesdk = "install_scripts"
97
98# Disable install_scripts during target build
99PACKAGECONFIG_remove_class-target = "install_scripts"
100
Deepak Kodihalli44b1c522017-03-16 06:32:12 -0500101EXTRA_OECONF = " \
102 YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir} \
103 CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
104 "
Marri Devender Rao6675eac2017-09-27 10:56:40 -0500105
106BBCLASSEXTEND += "native nativesdk"