blob: 180d70dbb7e80ea9220e62e5663c85f87c3405c7 [file] [log] [blame]
vishwabmc2ac6f932015-10-09 15:51:50 +05301SUMMARY = "Phosphor OpenBMC IPMI daemon"
2DESCRIPTION = "Phosphor OpenBMC IPMI router and plugin libraries"
vishwabmc2ac6f932015-10-09 15:51:50 +05303PR = "r1"
4
Brad Bishop8fffc162016-08-19 09:02:54 -05005RRECOMMENDS_${PN} += "packagegroup-obmc-ipmid-providers-libs"
Chris Austen9d3325a2015-10-24 19:34:11 -05006
Matthew Barth6b136a42016-08-16 16:51:35 -05007inherit autotools pkgconfig
Patrick Venturecb675692017-12-22 14:36:07 -08008inherit obmc-phosphor-ipmiprovider-symlink
vishwabmc2ac6f932015-10-09 15:51:50 +05309inherit obmc-phosphor-license
Patrick Williams89b11a12015-10-15 15:20:20 -050010inherit obmc-phosphor-sdbus-service
Patrick Venturecb675692017-12-22 14:36:07 -080011inherit obmc-phosphor-systemd
Ratan Gupta3aa591f2017-03-06 17:05:11 +053012inherit phosphor-ipmi-host
13inherit pythonnative
vishwabmc2ac6f932015-10-09 15:51:50 +053014
Brad Bishop01e6b172018-01-26 22:11:36 -050015def ipmi_whitelists(d):
16 whitelists = d.getVar(
17 'VIRTUAL-RUNTIME_phosphor-ipmi-providers', True) or ''
18 whitelists = whitelists.split()
19 whitelists = [ '{}-whitelist-native'.format(x) for x in whitelists ]
20 return ' '.join(whitelists)
21
22
Patrick Venturecb675692017-12-22 14:36:07 -080023DEPENDS += "autoconf-archive-native"
David Cobbleyf9236522017-11-21 16:17:40 -080024DEPENDS += "nlohmann-json"
Patrick Venturecb675692017-12-22 14:36:07 -080025DEPENDS += "obmc-targets"
Brad Bishop01e6b172018-01-26 22:11:36 -050026DEPENDS += "${@ipmi_whitelists(d)}"
Patrick Venturecb675692017-12-22 14:36:07 -080027DEPENDS += "phosphor-dbus-interfaces"
Adriana Kobylakc009f892017-02-17 08:21:42 -060028DEPENDS += "phosphor-logging"
Brad Bishop12e3d602016-10-05 20:10:23 -040029DEPENDS += "phosphor-mapper"
Ratan Guptaca8fd9d2017-03-20 18:20:47 +053030DEPENDS += "sdbusplus"
Patrick Venturecb675692017-12-22 14:36:07 -080031DEPENDS += "sdbus++-native"
Tom Josephcf7e8492017-05-08 11:49:10 +053032DEPENDS += "virtual/phosphor-ipmi-inventory-sel"
Marri Devender Rao53c55032017-07-26 02:11:32 -050033DEPENDS += "virtual/phosphor-ipmi-fru-merge-config"
Patrick Venturecb675692017-12-22 14:36:07 -080034DEPENDS += "virtual/phosphor-ipmi-sensor-inventory"
Patrick Venture0b2b1652018-01-18 18:01:29 -080035DEPENDS += "virtual/phosphor-ipmi-channel-config"
Ratan Gupta3aa591f2017-03-06 17:05:11 +053036
Adriana Kobylakc009f892017-02-17 08:21:42 -060037RDEPENDS_${PN}-dev += "phosphor-logging"
Brad Bishop12e3d602016-10-05 20:10:23 -040038RDEPENDS_${PN}-dev += "phosphor-mapper-dev"
Milton D. Miller IIb8c51742016-03-04 15:29:29 -060039RDEPENDS_${PN} += "clear-once"
Brad Bishopea4022a2016-07-26 15:52:01 -040040RDEPENDS_${PN} += "libmapper"
Patrick Venturecb675692017-12-22 14:36:07 -080041RDEPENDS_${PN} += "network"
42RDEPENDS_${PN} += "phosphor-dbus-interfaces"
43RDEPENDS_${PN} += "phosphor-mapper"
Vishwanatha Subbannab1c39e02016-11-10 21:52:46 +053044RDEPENDS_${PN} += "phosphor-time-manager"
Patrick Venturecb675692017-12-22 14:36:07 -080045RDEPENDS_${PN} += "sdbusplus"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053046RDEPENDS_${PN} += "virtual/obmc-watchdog"
Ratan Guptaca8fd9d2017-03-20 18:20:47 +053047
Vishwanatha Subbannacaff3fa2017-03-31 14:41:11 +053048SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service phosphor-ipmi-host.service"
49
Adriana Kobylak1ffadd92016-08-25 10:07:34 -050050RRECOMMENDS_${PN} += "virtual-obmc-settings-mgmt"
vishwabmc2ac6f932015-10-09 15:51:50 +053051
Marri Devender Rao2ba514e2017-06-08 00:47:54 -050052require ${PN}.inc
Chris Austen9d3325a2015-10-24 19:34:11 -050053
Tom Joseph1562bbc2017-02-20 12:01:43 +053054# Setup IPMI Whitelist Conf files
55WHITELIST_CONF = " \
Patrick Williams43b61b72017-02-24 13:04:06 -060056 ${STAGING_DATADIR_NATIVE}/phosphor-ipmi-host/*.conf \
Tom Joseph1562bbc2017-02-20 12:01:43 +053057 ${S}/host-ipmid-whitelist.conf \
58 "
59EXTRA_OECONF = " \
60 WHITELIST_CONF="${WHITELIST_CONF}" \
Ratan Gupta3aa591f2017-03-06 17:05:11 +053061 SENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/sensor.yaml \
Tom Josephcf7e8492017-05-08 11:49:10 +053062 INVSENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/invsensor.yaml \
Marri Devender Rao53c55032017-07-26 02:11:32 -050063 FRU_YAML_GEN=${STAGING_DIR_NATIVE}${config_datadir}/fru_config.yaml \
Patrick Venture0b2b1652018-01-18 18:01:29 -080064 CHANNEL_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/channel.yaml \
Marri Devender Rao95eaf492018-01-18 11:21:19 -060065 POWER_READING_SENSOR=${datadir}/ipmi-providers/power_reading.json\
Tom Joseph1562bbc2017-02-20 12:01:43 +053066 "
67
vishwabmc2ac6f932015-10-09 15:51:50 +053068S = "${WORKDIR}/git"
69
David Cobbleyf9236522017-11-21 16:17:40 -080070SRC_URI += "file://merge_yamls.py \
71 file://dev_id.json \
Dhruvaraj Subhashchandran7a37ba12018-01-09 03:44:39 -060072 file://dcmi_cap.json \
Marri Devender Rao95eaf492018-01-18 11:21:19 -060073 file://power_reading.json \
Deepak Kodihallifb6dc462018-01-24 05:35:11 -060074 file://dcmi_temp_readings.json \
David Cobbleyf9236522017-11-21 16:17:40 -080075 "
Dhruvaraj Subhashchandran12352762017-08-04 16:09:15 -050076
Tom Josephdcdc8ea2017-02-01 19:47:27 +053077HOSTIPMI_PROVIDER_LIBRARY += "libapphandler.so"
Tom Josephdcdc8ea2017-02-01 19:47:27 +053078HOSTIPMI_PROVIDER_LIBRARY += "libsysintfcmds.so"
79
80NETIPMI_PROVIDER_LIBRARY += "libapphandler.so"
81
Matthew Barth6b136a42016-08-16 16:51:35 -050082FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
Patrick Venturecb675692017-12-22 14:36:07 -080083FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
Tom Josephdcdc8ea2017-02-01 19:47:27 +053084FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
David Cobbleyf9236522017-11-21 16:17:40 -080085FILES_${PN}_append = " ${datadir}/ipmi-providers/dev_id.json"
Dhruvaraj Subhashchandran7a37ba12018-01-09 03:44:39 -060086FILES_${PN}_append = " ${datadir}/ipmi-providers/dcmi_cap.json"
Marri Devender Rao95eaf492018-01-18 11:21:19 -060087FILES_${PN}_append = " ${datadir}/ipmi-providers/power_reading.json"
Deepak Kodihallifb6dc462018-01-24 05:35:11 -060088FILES_${PN}_append = " ${datadir}/ipmi-providers/dcmi_temp_readings.json"
Tom Josephdcdc8ea2017-02-01 19:47:27 +053089FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
Brad Bishop6371e702016-09-06 13:03:39 -040090
Andrew Geissler41e3cb32017-01-04 11:11:50 -060091# Soft Power Off
Andrew Geisslerecfa6622017-05-11 16:16:27 -050092# install the soft power off service in the host shutdown target
93SOFT_SVC = "xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service"
94SOFT_TGTFMT = "obmc-host-shutdown@{0}.target"
95SOFT_FMT = "../${SOFT_SVC}:${SOFT_TGTFMT}.requires/${SOFT_SVC}"
96SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'SOFT_FMT', 'OBMC_HOST_INSTANCES')}"
Dhruvaraj Subhashchandran12352762017-08-04 16:09:15 -050097
98#Collect all hardcoded sensor yamls from different recipes and
99#merge all of them with sensor.yaml.
100python do_merge_sensors () {
101 import subprocess
102
103 # TODO: Perform the merge in a temporary directory?
104 workdir = d.getVar('WORKDIR', True)
105 nativedir = d.getVar('STAGING_DIR_NATIVE', True)
106 sensorsdir = d.getVar('sensor_datadir', True)
107 sensorsdir = sensorsdir[1:]
108 sensorsdir = os.path.join(nativedir, sensorsdir)
109 cmd = []
110 cmd.append(os.path.join(workdir, 'merge_yamls.py'))
111 cmd.append(os.path.join(sensorsdir, 'sensor.yaml'))
112
113 if os.stat(os.path.join(sensorsdir, 'sensor.yaml')).st_size == 0:
114 return
115 fetch = bb.fetch2.Fetch([], d)
Kun Yicdc3b232017-10-09 23:17:08 -0700116 override_urls = [url for url in fetch.urls if url.endswith('.hardcoded.yaml')]
Dhruvaraj Subhashchandran12352762017-08-04 16:09:15 -0500117 for url in override_urls:
118 bb.debug(2, 'Overriding with source: ' + url)
119 local_base = os.path.basename(fetch.localpath(url))
120 filename = os.path.join(workdir, local_base)
121 cmd.append(filename)
122
123 # Invoke the script and don't catch any resulting exception.
124 subprocess.check_call(cmd)
125}
David Cobbleyf9236522017-11-21 16:17:40 -0800126do_install_append(){
127 install -d ${D}${datadir}/ipmi-providers
128 install -m 0644 -D ${WORKDIR}/dev_id.json \
129 ${D}${datadir}/ipmi-providers/dev_id.json
Dhruvaraj Subhashchandran7a37ba12018-01-09 03:44:39 -0600130 install -m 0644 -D ${WORKDIR}/dcmi_cap.json \
131 ${D}${datadir}/ipmi-providers/dcmi_cap.json
Marri Devender Rao95eaf492018-01-18 11:21:19 -0600132 install -m 0644 -D ${WORKDIR}/power_reading.json \
133 ${D}${datadir}/ipmi-providers/power_reading.json
Deepak Kodihallifb6dc462018-01-24 05:35:11 -0600134 install -m 0644 -D ${WORKDIR}/dcmi_temp_readings.json \
135 ${D}${datadir}/ipmi-providers/dcmi_temp_readings.json
David Cobbleyf9236522017-11-21 16:17:40 -0800136}
Dhruvaraj Subhashchandran12352762017-08-04 16:09:15 -0500137# python-pyyaml-native is installed by do_configure, so put this task after
138addtask merge_sensors after do_configure before do_compile