blob: a54ba6e49b0436b35fb2ed2a90dc3b090a8acb0d [file] [log] [blame]
Brad Bishope3278032016-11-09 20:43:11 -05001SUMMARY = "C++ bindings for systemd dbus APIs"
2DESCRIPTION = "C++ bindings for systemd dbus APIs."
3HOMEPAGE = "http://github.com/openbmc/sdbusplus"
4PR = "r1"
Patrick Venture9691cba2018-10-17 07:19:55 -07005PV = "1.0+git${SRCPV}"
Brad Bishope3278032016-11-09 20:43:11 -05006LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
8
9inherit autotools pkgconfig
Patrick Williams8fc96292016-11-22 07:01:14 -060010inherit obmc-phosphor-python-autotools
Brad Bishope3278032016-11-09 20:43:11 -050011
Nagaraju Goruganti9940d4f2017-08-22 05:24:26 -050012DEPENDS += " \
13 autoconf-archive-native \
Patrick Williams853ff1b2020-02-24 16:27:10 -060014 ${PYTHON_PN}-inflection-native \
15 ${PYTHON_PN}-mako-native \
16 ${PYTHON_PN}-pyyaml-native \
Nagaraju Goruganti9940d4f2017-08-22 05:24:26 -050017 "
Brad Bishop13b8afa2017-01-12 14:06:43 -050018RDEPENDS_sdbus++ += " \
Patrick Williams853ff1b2020-02-24 16:27:10 -060019 ${PYTHON_PN} \
20 ${PYTHON_PN}-inflection \
21 ${PYTHON_PN}-mako \
22 ${PYTHON_PN}-pyyaml \
Brad Bishope3278032016-11-09 20:43:11 -050023 "
24
Brad Bishop6b4da622017-01-18 13:59:33 -050025# sdbus++ has a handful of runtime dependencies on other python packages.
26# Bitbake doesn't do anything with RDEPENDS in native context because
27# native context doesn't have packages.
28#
29# While technically sdbus++ doesn't require its runtime dependencies to be
30# installed to build, work around the above native context behavior
31# by adding a build dependency so that clients don't have to DEPEND
32# on sdbus++ runtime dependencies manually.
33
34DEPENDS_append_class-native = " \
Patrick Williams853ff1b2020-02-24 16:27:10 -060035 ${PYTHON_PN}-inflection-native \
36 ${PYTHON_PN}-mako-native \
37 ${PYTHON_PN}-pyyaml-native \
Brad Bishop6b4da622017-01-18 13:59:33 -050038 "
39
Brad Bishope3278032016-11-09 20:43:11 -050040SRC_URI += "git://github.com/openbmc/sdbusplus"
Andrew Geissler5b7e8b72020-02-24 20:50:54 +000041SRCREV = "67c79b0ca6e013c8621dd2cff95e367dbb75bb2a"
Brad Bishope3278032016-11-09 20:43:11 -050042
Adriana Kobylak9bcfdbb2017-02-12 17:40:26 -060043PACKAGECONFIG ??= "libsdbusplus transaction"
Brad Bishope3278032016-11-09 20:43:11 -050044PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd"
Adriana Kobylak9bcfdbb2017-02-12 17:40:26 -060045PACKAGECONFIG[transaction] = "--enable-transaction,--disable-transaction"
Brad Bishope3278032016-11-09 20:43:11 -050046
47S = "${WORKDIR}/git"
48
Patrick Williams592d7982016-11-22 11:05:11 -060049PROVIDES_prepend = "sdbus++ "
Brad Bishop50a5dc12018-02-27 00:30:06 -050050PACKAGE_BEFORE_PN = "sdbus++"
Patrick Williams592d7982016-11-22 11:05:11 -060051FILES_sdbus++_append = " ${bindir}/sdbus++"
52PYTHON_AUTOTOOLS_PACKAGE = "sdbus++"
53
Brad Bishope3278032016-11-09 20:43:11 -050054PACKAGECONFIG_remove_class-native = "libsdbusplus"
55PACKAGECONFIG_remove_class-nativesdk = "libsdbusplus"
56
Brad Bishope3278032016-11-09 20:43:11 -050057BBCLASSEXTEND += "native nativesdk"