blob: 580cf433db01d74e80bd36f846ce029d4c59d71c [file] [log] [blame]
Patrick Williams9e206392017-01-19 21:20:46 -06001SUMMARY = "Phosphor State Management"
2DESCRIPTION = "Phosphor State Manager provides a set of system state \
3management daemons. It is suitable for use on a wide variety of OpenBMC \
4platforms."
5HOMEPAGE = "https://github.com/openbmc/phosphor-state-manager"
6PR = "r1"
Patrick Venturedcb29962018-10-21 08:23:40 -07007PV = "1.0+git${SRCPV}"
Patrick Williams9e206392017-01-19 21:20:46 -06008LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
10
Andrew Geissler20cff702020-03-09 16:51:27 -050011include phosphor-state-manager-systemd-links.inc
12
Patrick Williams9e206392017-01-19 21:20:46 -060013STATE_MGR_PACKAGES = " \
14 ${PN}-host \
15 ${PN}-chassis \
Josh Kingd2b95c72017-01-19 14:04:03 -060016 ${PN}-bmc \
Michael Tritzb6e965c2017-04-18 17:01:12 -050017 ${PN}-discover \
Andrew Geisslerb1afecc2017-05-08 15:58:01 -050018 ${PN}-host-check \
Dhruvaraj Subhashchandranef07e6f2017-12-17 12:06:23 -060019 ${PN}-reset-sensor-states \
Andrew Geissler44cadef2019-09-23 19:11:20 +000020 ${PN}-systemd-target-monitor \
Andrew Geissler024c25d2020-01-14 14:21:24 -060021 ${PN}-obmc-targets \
Andrew Geissler98d98042020-04-15 16:02:17 +000022 ${PN}-scheduled-host-transition \
Patrick Williams9e206392017-01-19 21:20:46 -060023"
Brad Bishop7f9102c2018-04-11 11:44:15 -040024PACKAGE_BEFORE_PN += "${STATE_MGR_PACKAGES}"
25ALLOW_EMPTY_${PN} = "1"
Brad Bishop1a5a5972017-03-01 16:08:45 -050026
Patrick Williams9e206392017-01-19 21:20:46 -060027DBUS_PACKAGES = "${STATE_MGR_PACKAGES}"
28
Dhruvaraj Subhashchandranef07e6f2017-12-17 12:06:23 -060029SYSTEMD_PACKAGES = "${PN}-discover \
30 ${PN}-reset-sensor-states \
Andrew Geissler44cadef2019-09-23 19:11:20 +000031 ${PN}-systemd-target-monitor \
Dhruvaraj Subhashchandranef07e6f2017-12-17 12:06:23 -060032"
Andrew Geissler6bc2f022018-03-13 11:46:27 -070033
34# The host-check function will check if the host is running
35# after a BMC reset.
Dhruvaraj Subhashchandranef07e6f2017-12-17 12:06:23 -060036# The reset-sensor-states function will reset the host
Andrew Geissler6bc2f022018-03-13 11:46:27 -070037# sensors on a BMC reset or system power loss.
38# Neither is required for host state function but are
39# recommended to deal properly with these reset scenarios.
40RRECOMMENDS_${PN}-host = "${PN}-host-check ${PN}-reset-sensor-states"
Patrick Williams9e206392017-01-19 21:20:46 -060041
Andrew Geissler024c25d2020-01-14 14:21:24 -060042# The obmc-targets are the base targets required to boot a computer system
43RRECOMMENDS_${PN}-host += "${PN}-obmc-targets"
44
Andrew Geisslerae3fe4a2019-12-11 14:51:20 -060045inherit meson pkgconfig
Patrick Williams9e206392017-01-19 21:20:46 -060046inherit obmc-phosphor-dbus-service
Andrew Geissler15834fd2020-03-09 16:59:22 -050047inherit obmc-phosphor-systemd
Patrick Williams9e206392017-01-19 21:20:46 -060048
Patrick Williams9e206392017-01-19 21:20:46 -060049DEPENDS += "sdbusplus"
William A. Kennington IIIfa391f22018-10-18 01:34:43 -070050DEPENDS += "sdeventplus"
Patrick Williams9e206392017-01-19 21:20:46 -060051DEPENDS += "phosphor-logging"
Patrick Williams1815f6b2017-01-30 11:06:16 -060052DEPENDS += "phosphor-dbus-interfaces"
Brad Bishop17c08bf2018-10-18 17:07:53 -040053DEPENDS += "libcereal"
Andrew Geissler44cadef2019-09-23 19:11:20 +000054DEPENDS += "nlohmann-json"
55DEPENDS += "cli11"
Patrick Williams9e206392017-01-19 21:20:46 -060056
Anthony Wilsoncd800c82019-03-30 08:11:32 -070057FILES_${PN}-host = "${bindir}/phosphor-host-state-manager"
Patrick Williams9e206392017-01-19 21:20:46 -060058DBUS_SERVICE_${PN}-host += "xyz.openbmc_project.State.Host.service"
Andrew Geissler4ec27742017-07-26 17:53:04 -050059DBUS_SERVICE_${PN}-host += "phosphor-reboot-host@.service"
Andrew Geisslerec7f9202018-03-27 19:39:05 -070060SYSTEMD_SERVICE_${PN}-host += "phosphor-reset-host-reboot-attempts@.service"
Andrew Geisslerb05ebce2020-11-04 16:41:45 +000061SYSTEMD_SERVICE_${PN}-host += "phosphor-clear-one-time@.service"
Andrew Geissler4ef0e112021-01-05 16:51:58 -060062SYSTEMD_SERVICE_${PN}-host += "phosphor-set-host-transition-to-running@.service"
63SYSTEMD_SERVICE_${PN}-host += "phosphor-set-host-transition-to-off@.service"
Patrick Williams9e206392017-01-19 21:20:46 -060064
Anthony Wilsoncd800c82019-03-30 08:11:32 -070065FILES_${PN}-chassis = "${bindir}/phosphor-chassis-state-manager"
Patrick Williams9e206392017-01-19 21:20:46 -060066DBUS_SERVICE_${PN}-chassis += "xyz.openbmc_project.State.Chassis.service"
67
Anthony Wilsoncd800c82019-03-30 08:11:32 -070068FILES_${PN}-chassis += "${bindir}/obmcutil"
69
70FILES_${PN}-bmc = "${bindir}/phosphor-bmc-state-manager"
Josh Kingd2b95c72017-01-19 14:04:03 -060071DBUS_SERVICE_${PN}-bmc += "xyz.openbmc_project.State.BMC.service"
72
Anthony Wilsoncd800c82019-03-30 08:11:32 -070073FILES_${PN}-discover = "${bindir}/phosphor-discover-system-state"
Michael Tritzb3b58992017-03-31 12:04:32 -050074SYSTEMD_SERVICE_${PN}-discover += "phosphor-discover-system-state@.service"
75
Anthony Wilsoncd800c82019-03-30 08:11:32 -070076FILES_${PN}-host-check = "${bindir}/phosphor-host-check"
Andrew Geisslerb1afecc2017-05-08 15:58:01 -050077SYSTEMD_SERVICE_${PN}-host-check += "phosphor-reset-host-check@.service"
78SYSTEMD_SERVICE_${PN}-host-check += "phosphor-reset-host-running@.service"
79
Dhruvaraj Subhashchandranef07e6f2017-12-17 12:06:23 -060080SYSTEMD_SERVICE_${PN}-reset-sensor-states += "phosphor-reset-sensor-states@.service"
81
Andrew Geissler44cadef2019-09-23 19:11:20 +000082FILES_${PN}-systemd-target-monitor = " \
83 ${bindir}/phosphor-systemd-target-monitor \
84 ${sysconfdir}/phosphor-systemd-target-monitor/phosphor-target-monitor-default.json \
85 "
86SYSTEMD_SERVICE_${PN}-systemd-target-monitor += "phosphor-systemd-target-monitor.service"
87
Andrew Geissler98d98042020-04-15 16:02:17 +000088FILES_${PN}-scheduled-host-transition = "${bindir}/phosphor-scheduled-host-transition"
89DBUS_SERVICE_${PN}-scheduled-host-transition += "xyz.openbmc_project.State.ScheduledHostTransition.service"
90
Andrew Geissler024c25d2020-01-14 14:21:24 -060091# Chassis power synchronization targets
92# - start-pre: Services to run before we start power on process
93# - start: Services to run to do the chassis power on
94# - on: Services to run once power is on
95# - stop-pre,stop,off: Same as above but applied to powering off
96# - reset-on: Services to check if chassis power is on after bmc reset
97CHASSIS_SYNCH_TARGETS = "start-pre start on stop-pre stop off reset-on"
98
99# Chassis action power targets
100# - on: Services to run to power on the chassis
101# - off: Services to run to power off the chassis
102# - powered-off: Services to run once chassis power is off
103# - reset: Services to check chassis power state and update chassis "on" target
104# - hard-off: Services to force an immediate power off of the chassis
105CHASSIS_ACTION_TARGETS = "poweron poweroff powered-off powerreset hard-poweroff"
106
107# Track all host synchronization point targets
108# - start-pre: Services to run before we start host boot
109# - starting: Services to run to do the host boot
110# - started: Services to run once the host is booted
111# - stop-pre,stopping,stopped: Same as above but applied to shutting down the host
112# - reset-running: Services to check if host is running after bmc reset
113HOST_SYNCH_TARGETS = "start-pre starting started stop-pre stopping stopped reset-running"
114
115# Track all host action targets
116# - start: Will run startmin target, this target used for any additional
117# services that user needs for an initial power on of host.
118# For example, resetting the host reboot count could be put in
119# this target so on any fresh power on, this count is reset.
120# - startmin: Minimum services required to start the host. This target will
121# be called by reboot and start target.
122# - stop: Services to run to shutdown the host
123# - quiesce: Target to enter on host boot failure
124# - shutdown: Tell host to shutdown, then stop system
125# - reset: Services to check if host is running and update host "start" target
126# - crash: Target to run when host crashes. it is very much similar to
127# quiesce target but the only delta is that this target contains
128# multiple services and one of them is the quiesce target.
129# - timeout: Target to run when host watchdog times out
Andrew Geisslerbbe378e2020-02-10 13:47:12 -0600130# - reboot: Reboot the host with a chassis power cycle included
131# - warm-reboot: Reboot the host without a chassis power cycle.
132# - force-warm-reboot: Reboot the host without a chassis power cycle and without
133# notifying the host.
134# - diagnostic-mode: This will be entered when the host is collecting diagnostic
135# data for itself.
136HOST_ACTION_TARGETS = "start startmin stop quiesce reset shutdown crash timeout "
137HOST_ACTION_TARGETS += "reboot warm-reboot force-warm-reboot diagnostic-mode"
Andrew Geissler024c25d2020-01-14 14:21:24 -0600138
139CHASSIS_SYNCH_FMT = "obmc-power-{0}@.target"
140CHASSIS_ACTION_FMT = "obmc-chassis-{0}@.target"
141HOST_SYNCH_FMT = "obmc-host-{0}@.target"
142HOST_ACTION_FMT = "obmc-host-{0}@.target"
143
144CHASSIS_LINK_SYNCH_FMT = "${CHASSIS_SYNCH_FMT}:obmc-power-{0}@{1}.target"
145CHASSIS_LINK_ACTION_FMT = "${CHASSIS_ACTION_FMT}:obmc-chassis-{0}@{1}.target"
146HOST_LINK_SYNCH_FMT = "${HOST_SYNCH_FMT}:obmc-host-{0}@{1}.target"
147HOST_LINK_ACTION_FMT = "${HOST_ACTION_FMT}:obmc-host-{0}@{1}.target"
148FAN_LINK_FMT = "obmc-fan-control-ready@.target:obmc-fan-control-ready@{0}.target"
149
150# Targets to be executed on checkstop and watchdog timeout
Andrew Geissler91685cd2020-12-17 14:23:10 -0600151HOST_ERROR_TARGETS = "timeout"
Andrew Geissler024c25d2020-01-14 14:21:24 -0600152
153QUIESCE_TMPL = "obmc-host-quiesce@.target"
154CRASH_TIMEOUT_TGTFMT = "obmc-host-{0}@{1}.target"
155QUIESCE_INSTFMT = "obmc-host-quiesce@{1}.target"
156QUIESCE_FMT = "../${QUIESCE_TMPL}:${CRASH_TIMEOUT_TGTFMT}.wants/${QUIESCE_INSTFMT}"
157
158SYSTEMD_SERVICE_${PN}-obmc-targets += " \
159 obmc-mapper.target \
160 obmc-fans-ready.target \
161 obmc-fan-control.target \
162 obmc-fan-control-ready@.target \
163 obmc-fan-watchdog-takeover.target \
164 "
165
166SYSTEMD_SERVICE_${PN}-obmc-targets += "${@compose_list(d, 'CHASSIS_SYNCH_FMT', 'CHASSIS_SYNCH_TARGETS')}"
167SYSTEMD_SERVICE_${PN}-obmc-targets += "${@compose_list(d, 'CHASSIS_ACTION_FMT', 'CHASSIS_ACTION_TARGETS')}"
168SYSTEMD_SERVICE_${PN}-obmc-targets += "${@compose_list(d, 'HOST_SYNCH_FMT', 'HOST_SYNCH_TARGETS')}"
169SYSTEMD_SERVICE_${PN}-obmc-targets += "${@compose_list(d, 'HOST_ACTION_FMT', 'HOST_ACTION_TARGETS')}"
170
171SYSTEMD_LINK_${PN}-obmc-targets += "${@compose_list(d, 'CHASSIS_LINK_SYNCH_FMT', 'CHASSIS_SYNCH_TARGETS', 'OBMC_CHASSIS_INSTANCES')}"
172SYSTEMD_LINK_${PN}-obmc-targets += "${@compose_list(d, 'CHASSIS_LINK_ACTION_FMT', 'CHASSIS_ACTION_TARGETS', 'OBMC_CHASSIS_INSTANCES')}"
173SYSTEMD_LINK_${PN}-obmc-targets += "${@compose_list(d, 'HOST_LINK_SYNCH_FMT', 'HOST_SYNCH_TARGETS', 'OBMC_HOST_INSTANCES')}"
174SYSTEMD_LINK_${PN}-obmc-targets += "${@compose_list(d, 'HOST_LINK_ACTION_FMT', 'HOST_ACTION_TARGETS', 'OBMC_HOST_INSTANCES')}"
175SYSTEMD_LINK_${PN}-obmc-targets += "${@compose_list(d, 'FAN_LINK_FMT', 'OBMC_CHASSIS_INSTANCES')}"
176SYSTEMD_LINK_${PN}-obmc-targets += "${@compose_list(d, 'QUIESCE_FMT', 'HOST_ERROR_TARGETS', 'OBMC_HOST_INSTANCES')}"
177
Patrick Williams9e206392017-01-19 21:20:46 -0600178SRC_URI += "git://github.com/openbmc/phosphor-state-manager"
Andrew Geissler4ef0e112021-01-05 16:51:58 -0600179SRCREV = "1e8b164f7b575f9728dd7f46d7b2d27e6081ee3f"
Patrick Williams9e206392017-01-19 21:20:46 -0600180
181S = "${WORKDIR}/git"