Brad Bishop | ea02e47 | 2017-05-12 13:02:56 -0400 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC event and error logging" |
| 2 | DESCRIPTION = "An error and event log daemon application, and \ |
| 3 | supporting tools for OpenBMC." |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 4 | HOMEPAGE = "https://github.com/openbmc/phosphor-logging" |
| 5 | PR = "r1" |
Patrick Venture | f6dd86b | 2018-10-21 08:22:43 -0700 | [diff] [blame] | 6 | PV = "1.0+git${SRCPV}" |
Patrick Venture | f66d71e | 2018-11-03 09:44:15 -0700 | [diff] [blame] | 7 | LICENSE = "Apache-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 9 | |
| 10 | inherit autotools pkgconfig |
| 11 | inherit pythonnative |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 12 | inherit obmc-phosphor-dbus-service |
Deepak Kodihalli | 44b1c52 | 2017-03-16 06:32:12 -0500 | [diff] [blame] | 13 | inherit phosphor-logging |
Marri Devender Rao | 56eae0a | 2017-06-06 08:39:39 -0500 | [diff] [blame] | 14 | inherit phosphor-dbus-yaml |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 15 | |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 16 | DEPENDS += "autoconf-archive-native" |
| 17 | DEPENDS += "systemd" |
| 18 | DEPENDS += "python-mako-native" |
| 19 | DEPENDS += "python-pyyaml-native" |
Patrick Williams | 57b1781 | 2016-12-09 08:56:38 -0600 | [diff] [blame] | 20 | DEPENDS += "sdbusplus sdbusplus-native" |
Deepak Kodihalli | c8d9205 | 2017-03-23 03:52:28 -0500 | [diff] [blame] | 21 | DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native" |
Deepak Kodihalli | 44b1c52 | 2017-03-16 06:32:12 -0500 | [diff] [blame] | 22 | DEPENDS += "virtual/phosphor-logging-callouts" |
Marri Devender Rao | f2ea35d | 2017-05-14 09:01:35 -0500 | [diff] [blame] | 23 | DEPENDS += "phosphor-logging-error-logs-native" |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 24 | DEPENDS += "phosphor-logging-native" |
Brad Bishop | cc51cd9 | 2018-10-18 17:07:53 -0400 | [diff] [blame] | 25 | DEPENDS += "libcereal" |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 26 | |
Michael Tritz | ccc0d0f | 2017-03-13 14:54:24 -0500 | [diff] [blame] | 27 | PACKAGE_BEFORE_PN = "${PN}-test" |
| 28 | FILES_${PN}-test = "${bindir}/*-test" |
| 29 | |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 30 | PACKAGE_BEFORE_PN += "${PN}-elog" |
| 31 | FILES_${PN}-elog += "${elog_dir}" |
| 32 | |
Deepak Kodihalli | 38af2c0 | 2018-08-24 08:05:14 -0500 | [diff] [blame] | 33 | # Package configuration |
| 34 | LOGGING_PACKAGES = " \ |
| 35 | ${PN}-base \ |
Deepak Kodihalli | f99f3c8 | 2018-08-28 11:39:41 -0500 | [diff] [blame] | 36 | phosphor-rsyslog-config \ |
Deepak Kodihalli | 38af2c0 | 2018-08-24 08:05:14 -0500 | [diff] [blame] | 37 | " |
| 38 | |
| 39 | ALLOW_EMPTY_${PN} = "1" |
| 40 | PACKAGE_BEFORE_PN += "${LOGGING_PACKAGES}" |
| 41 | SYSTEMD_PACKAGES = "${LOGGING_PACKAGES}" |
| 42 | DBUS_PACKAGES = "${LOGGING_PACKAGES}" |
| 43 | |
| 44 | RDEPENDS_${PN}-base += "sdbusplus phosphor-dbus-interfaces" |
| 45 | FILES_${PN}-base += " \ |
| 46 | ${sbindir}/phosphor-log-manager \ |
| 47 | ${libdir}/libphosphor_logging.so.* \ |
| 48 | " |
| 49 | DBUS_SERVICE_${PN}-base += "xyz.openbmc_project.Logging.service" |
| 50 | |
Deepak Kodihalli | f99f3c8 | 2018-08-28 11:39:41 -0500 | [diff] [blame] | 51 | RDEPENDS_phosphor-rsyslog-config += "sdbusplus phosphor-dbus-interfaces" |
| 52 | DBUS_SERVICE_phosphor-rsyslog-config += "xyz.openbmc_project.Syslog.Config.service" |
| 53 | FILES_phosphor-rsyslog-config += " \ |
| 54 | ${sbindir}/phosphor-rsyslog-conf \ |
| 55 | " |
| 56 | |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 57 | SRC_URI += "git://github.com/openbmc/phosphor-logging" |
Andrew Geissler | 19f4115 | 2019-01-14 14:32:01 +0000 | [diff] [blame] | 58 | SRCREV = "40a7406097c0b5b0670c5987f6fe8c902d65562d" |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 59 | |
| 60 | S = "${WORKDIR}/git" |
| 61 | |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 62 | # Do not DEPEND on the specified packages for native build |
| 63 | # as they will not be available in host machine |
Brad Bishop | efeb13a | 2018-01-27 00:27:21 -0500 | [diff] [blame] | 64 | DEPENDS_remove_class-native = " \ |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 65 | virtual/phosphor-logging-callouts \ |
Brad Bishop | efeb13a | 2018-01-27 00:27:21 -0500 | [diff] [blame] | 66 | sdbus++ \ |
| 67 | systemd \ |
Brad Bishop | cc51cd9 | 2018-10-18 17:07:53 -0400 | [diff] [blame] | 68 | libcereal \ |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 69 | " |
| 70 | |
| 71 | # Do not DEPEND on the specified packages for native SDK build |
| 72 | # as they will not be available in host machine |
| 73 | DEPENDS_remove_class-nativesdk = " \ |
| 74 | virtual/phosphor-logging-callouts \ |
| 75 | sdbus++-native \ |
Brad Bishop | cc51cd9 | 2018-10-18 17:07:53 -0400 | [diff] [blame] | 76 | libcereal \ |
Brad Bishop | efeb13a | 2018-01-27 00:27:21 -0500 | [diff] [blame] | 77 | systemd \ |
| 78 | phosphor-dbus-interfaces \ |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 79 | " |
| 80 | |
| 81 | PACKAGECONFIG ??= "metadata-processing install_scripts" |
| 82 | |
Deepak Kodihalli | 2551ece | 2017-03-28 07:47:51 -0500 | [diff] [blame] | 83 | PACKAGECONFIG[metadata-processing] = " \ |
| 84 | --enable-metadata-processing, \ |
| 85 | --disable-metadata-processing, , \ |
| 86 | " |
| 87 | |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 88 | # Provide a means to enable/disable install_scripts feature |
| 89 | PACKAGECONFIG[install_scripts] = " \ |
| 90 | --enable-install_scripts, \ |
| 91 | --disable-install_scripts, ,\ |
| 92 | " |
| 93 | |
| 94 | # Enable install_scripts during native and native SDK build |
| 95 | PACKAGECONFIG_add_class-native = "install_scripts" |
| 96 | PACKAGECONFIG_add_class-nativesdk = "install_scripts" |
| 97 | |
| 98 | # Disable install_scripts during target build |
| 99 | PACKAGECONFIG_remove_class-target = "install_scripts" |
| 100 | |
Deepak Kodihalli | 44b1c52 | 2017-03-16 06:32:12 -0500 | [diff] [blame] | 101 | EXTRA_OECONF = " \ |
| 102 | YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir} \ |
| 103 | CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \ |
| 104 | " |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 105 | |
| 106 | BBCLASSEXTEND += "native nativesdk" |