blob: 6c73320eaab4c93a67d45aa386f811792029500c [file] [log] [blame]
Patrick Venture7ebe0262018-03-30 11:23:16 -07001SUMMARY = "Phosphor OpenBMC Post Code Daemon"
2DESCRIPTION = "Phosphor OpenBMC Post Code Daemon"
Patrick Venture6b91f732018-09-28 19:21:26 -07003HOMEPAGE = "http://github.com/openbmc/phosphor-host-postd"
Patrick Venture7ebe0262018-03-30 11:23:16 -07004PR = "r1"
Patrick Venture6b91f732018-09-28 19:21:26 -07005PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Patrick Venture7ebe0262018-03-30 11:23:16 -07008
Kun Yi556e23b2020-05-02 22:13:53 -07009inherit meson
10inherit pkgconfig
Patrick Venture20b4af62018-10-23 11:57:36 -070011inherit systemd
Patrick Venture7ebe0262018-03-30 11:23:16 -070012
Benjamin Fair14f1b6a2020-04-07 11:48:40 -070013PACKAGECONFIG ?= ""
Kun Yi556e23b2020-05-02 22:13:53 -070014PACKAGECONFIG[7seg] = "-D7seg=enabled,-D7seg=disabled,,udev"
Benjamin Fair14f1b6a2020-04-07 11:48:40 -070015
Patrick Venture7ebe0262018-03-30 11:23:16 -070016DEPENDS += "sdbusplus"
Kun Yi41d3e4d2018-09-12 11:01:33 -070017DEPENDS += "sdeventplus"
Patrick Venture7ebe0262018-03-30 11:23:16 -070018DEPENDS += "phosphor-dbus-interfaces"
19DEPENDS += "systemd"
Kumar Thangavel18fa3832021-08-18 18:04:45 +053020DEPENDS += "libgpiod"
Patrick Venture7ebe0262018-03-30 11:23:16 -070021
Patrick Venture6b91f732018-09-28 19:21:26 -070022S = "${WORKDIR}/git"
Patrick Williamsbb99d222022-01-24 15:55:09 -060023SRC_URI = "git://github.com/openbmc/phosphor-host-postd;branch=master;protocol=https"
Andrew Geissler719d3132022-04-10 00:40:08 +000024SRCREV = "80be5d8335f31c12edae7edd2fc32a0583d765f9"
Patrick Venture6b91f732018-09-28 19:21:26 -070025
Benjamin Fair89e86cd2018-06-29 13:00:14 -070026SNOOP_DEVICE ?= "aspeed-lpc-snoop0"
27POST_CODE_BYTES ?= "1"
Kumar Thangavel18fa3832021-08-18 18:04:45 +0530287SEG_GPIO ?= "0"
Benjamin Fair89e86cd2018-06-29 13:00:14 -070029
30SERVICE_FILE = "lpcsnoop.service"
Patrick Venture20b4af62018-10-23 11:57:36 -070031SYSTEMD_PACKAGES = "${PN}"
Patrick Williams12fc9392021-08-06 09:16:53 -050032SYSTEMD_SERVICE:${PN} += "${SERVICE_FILE}"
Patrick Venture20b4af62018-10-23 11:57:36 -070033
Patrick Williamsed104d42021-08-31 13:19:27 -050034EXTRA_OEMESON:append = " \
35 -Dsnoop-device=${SNOOP_DEVICE} \
36 -Dpost-code-bytes=${POST_CODE_BYTES} \
37 -Dsystemd-target=multi-user.target \
Zev Weiss9aa92482022-04-05 17:40:10 -070038 -Dtests=disabled \
Patrick Williamsed104d42021-08-31 13:19:27 -050039"
Benjamin Fair14f1b6a2020-04-07 11:48:40 -070040
41POSTCODE_SEVENSEG_DEVICE ?= "seven_seg_disp_val"
42SERVICE_FILE_7SEG = " \
43 postcode-7seg@.service \
44 postcode-7seg@${POSTCODE_SEVENSEG_DEVICE}.service \
45"
Patrick Williams12fc9392021-08-06 09:16:53 -050046SYSTEMD_SERVICE:${PN} += "${@bb.utils.contains('PACKAGECONFIG', '7seg', '${SERVICE_FILE_7SEG}', '', d)}"