blob: edbca69413ac9437198efca7505754796631678b [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "OpenGL driver testing framework"
Brad Bishop1d80a2e2019-11-15 16:35:03 -05002DESCRIPTION = "Piglit is an open-source test suite for OpenGL and OpenCL \
3implementations."
Andrew Geissler90fd73c2021-03-05 15:25:55 -06004HOMEPAGE = "https://gitlab.freedesktop.org/mesa/piglit"
5BUGTRACKER = "https://gitlab.freedesktop.org/mesa/piglit/-/issues"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00006LICENSE = "MIT & LGPL-2.0-or-later & GPL-3.0-only & GPL-2.0-or-later & BSD-3-Clause"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05007LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
8
Andrew Geisslereff27472021-10-29 15:35:00 -05009SRC_URI = "git://gitlab.freedesktop.org/mesa/piglit.git;protocol=https;branch=main \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060010 file://0001-cmake-install-bash-completions-in-the-right-place.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050011 file://0002-cmake-use-proper-WAYLAND_INCLUDE_DIRS-variable.patch \
12 file://0003-tests-util-piglit-shader.c-do-not-hardcode-build-pat.patch \
Andrew Geissler87f5cff2022-09-30 13:13:31 -050013 "
Brad Bishop316dfdd2018-06-25 12:45:53 -040014UPSTREAM_CHECK_COMMITS = "1"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050015
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060016SRCREV = "590d81bb5fa219353104980108e9f1aa2b1d1b6b"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050017# (when PV goes above 1.0 remove the trailing r)
18PV = "1.0+gitr${SRCPV}"
19
20S = "${WORKDIR}/git"
21
Brad Bishopc342db32019-05-15 21:57:59 -040022X11_DEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxrender libglu', '', d)}"
23X11_RDEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'mesa-demos', '', d)}"
24
Andrew Geissler9aee5002022-03-30 16:27:02 +000025DEPENDS = "libpng waffle libxkbcommon python3-mako-native python3-numpy-native python3-six-native virtual/egl"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050026
Brad Bishop6dbb3162019-11-25 09:41:34 -050027inherit cmake pkgconfig python3native features_check bash-completion
Patrick Williamsc124f4f2015-09-15 14:41:29 -050028
Brad Bishop6e60e8b2018-02-01 10:27:11 -050029# depends on virtual/libgl
30REQUIRED_DISTRO_FEATURES += "opengl"
31
Patrick Williamsf1e5d692016-03-30 15:21:19 -050032# The built scripts go into the temporary directory according to tempfile
33# (typically /tmp) which can race if multiple builds happen on the same machine,
34# so tell it to use a directory in ${B} to avoid overwriting.
35export TEMP = "${B}/temp/"
36do_compile[dirs] =+ "${B}/temp/"
37
Patrick Williams92b42cb2022-09-03 06:53:57 -050038PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 glx', '', d)}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050039PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
Patrick Williams92b42cb2022-09-03 06:53:57 -050040PACKAGECONFIG[glx] = "-DPIGLIT_BUILD_GLX_TESTS=ON,-DPIGLIT_BUILD_GLX_TESTS=OFF"
41PACKAGECONFIG[opencl] = "-DPIGLIT_BUILD_CL_TESTS=ON,-DPIGLIT_BUILD_CL_TESTS=OFF,opencl-icd-loader"
Brad Bishopc342db32019-05-15 21:57:59 -040042PACKAGECONFIG[x11] = "-DPIGLIT_BUILD_GL_TESTS=ON,-DPIGLIT_BUILD_GL_TESTS=OFF,${X11_DEPS}, ${X11_RDEPS}"
Andrew Geisslereff27472021-10-29 15:35:00 -050043PACKAGECONFIG[vulkan] = "-DPIGLIT_BUILD_VK_TESTS=ON,-DPIGLIT_BUILD_VK_TESTS=OFF,vulkan-loader"
Brad Bishopc342db32019-05-15 21:57:59 -040044
Andrew Geissler09209ee2020-12-13 08:44:15 -060045export PIGLIT_BUILD_DIR = "../../../../git"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050046
Patrick Williams213cb262021-08-07 19:21:33 -050047do_configure:prepend() {
Patrick Williamsc124f4f2015-09-15 14:41:29 -050048 if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
49 sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
50 sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h
51 fi
52}
53
Patrick Williams2390b1b2022-11-03 13:47:49 -050054# Forcibly strip because Piglit is *huge*, and don't bother trying to split/strip the result.
Brad Bishop316dfdd2018-06-25 12:45:53 -040055OECMAKE_TARGET_INSTALL = "install/strip"
Patrick Williams2390b1b2022-11-03 13:47:49 -050056INHIBIT_PACKAGE_STRIP = "1"
57INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060058
Patrick Williams213cb262021-08-07 19:21:33 -050059RDEPENDS:${PN} = "waffle waffle-bin python3 python3-mako python3-json \
Brad Bishop316dfdd2018-06-25 12:45:53 -040060 python3-misc \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060061 python3-unixadmin python3-xml python3-multiprocessing \
Brad Bishop316dfdd2018-06-25 12:45:53 -040062 python3-six python3-shell python3-io \
Brad Bishopc342db32019-05-15 21:57:59 -040063 python3-netserver bash \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050064 "
65
Patrick Williams213cb262021-08-07 19:21:33 -050066INSANE_SKIP:${PN} += "dev-so already-stripped"
Brad Bishop19323692019-04-05 15:28:33 -040067
Andrew Geissler82c905d2020-04-13 13:39:40 -050068# As nothing builds against Piglit we don't need to have anything in the
69# sysroot, especially when this is ~2GB of test suite
Patrick Williams213cb262021-08-07 19:21:33 -050070SYSROOT_DIRS:remove = "${libdir}"
Andrew Geissler82c905d2020-04-13 13:39:40 -050071
Brad Bishop19323692019-04-05 15:28:33 -040072# Can't be built with ccache
73CCACHE_DISABLE = "1"