blob: 28a52cfeee97320ef6942996eae102ca41fdc2c1 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "OpenGL driver testing framework"
Brad Bishop1d80a2e2019-11-15 16:35:03 -05002DESCRIPTION = "Piglit is an open-source test suite for OpenGL and OpenCL \
3implementations."
Patrick Williamsc124f4f2015-09-15 14:41:29 -05004LICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
6
Brad Bishop96ff1982019-08-19 13:50:42 -04007SRC_URI = "git://gitlab.freedesktop.org/mesa/piglit.git;protocol=https \
Patrick Williamsc0f7c042017-02-23 20:41:17 -06008 file://0001-cmake-install-bash-completions-in-the-right-place.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009 file://0001-cmake-use-proper-WAYLAND_INCLUDE_DIRS-variable.patch \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060010 "
Brad Bishop316dfdd2018-06-25 12:45:53 -040011UPSTREAM_CHECK_COMMITS = "1"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050012
Brad Bishopa34c0302019-09-23 22:34:48 -040013SRCREV = "0d1a47a4c10d4dd7225bd6510f8191684b31235e"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050014# (when PV goes above 1.0 remove the trailing r)
15PV = "1.0+gitr${SRCPV}"
16
17S = "${WORKDIR}/git"
18
Brad Bishopc342db32019-05-15 21:57:59 -040019X11_DEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxrender libglu', '', d)}"
20X11_RDEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'mesa-demos', '', d)}"
21
22DEPENDS = "libpng waffle libxkbcommon virtual/libgl python3-mako-native python3-numpy-native python3-six-native virtual/egl"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050023
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080024inherit cmake pkgconfig python3native distro_features_check bash-completion
Patrick Williamsc124f4f2015-09-15 14:41:29 -050025
Brad Bishop6e60e8b2018-02-01 10:27:11 -050026# depends on virtual/libgl
27REQUIRED_DISTRO_FEATURES += "opengl"
28
Patrick Williamsf1e5d692016-03-30 15:21:19 -050029# The built scripts go into the temporary directory according to tempfile
30# (typically /tmp) which can race if multiple builds happen on the same machine,
31# so tell it to use a directory in ${B} to avoid overwriting.
32export TEMP = "${B}/temp/"
33do_compile[dirs] =+ "${B}/temp/"
34
Brad Bishopc342db32019-05-15 21:57:59 -040035PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050036PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
Brad Bishopc342db32019-05-15 21:57:59 -040037PACKAGECONFIG[x11] = "-DPIGLIT_BUILD_GL_TESTS=ON,-DPIGLIT_BUILD_GL_TESTS=OFF,${X11_DEPS}, ${X11_RDEPS}"
38
Patrick Williamsc124f4f2015-09-15 14:41:29 -050039
40do_configure_prepend() {
41 if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
42 sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
43 sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h
44 fi
45}
46
Brad Bishop316dfdd2018-06-25 12:45:53 -040047OECMAKE_TARGET_INSTALL = "install/strip"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060048
Brad Bishopa5c52ff2018-11-23 10:55:50 +130049RDEPENDS_${PN} = "waffle waffle-bin python3 python3-mako python3-json \
Brad Bishop316dfdd2018-06-25 12:45:53 -040050 python3-misc \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060051 python3-unixadmin python3-xml python3-multiprocessing \
Brad Bishop316dfdd2018-06-25 12:45:53 -040052 python3-six python3-shell python3-io \
Brad Bishopc342db32019-05-15 21:57:59 -040053 python3-netserver bash \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050054 "
55
Patrick Williamsc0f7c042017-02-23 20:41:17 -060056INSANE_SKIP_${PN} += "dev-so already-stripped"
Brad Bishop19323692019-04-05 15:28:33 -040057
58# Can't be built with ccache
59CCACHE_DISABLE = "1"