blob: 0a3de466c738657667495f2ce0f2682452c964df [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "OpenGL driver testing framework"
Brad Bishop1d80a2e2019-11-15 16:35:03 -05002DESCRIPTION = "Piglit is an open-source test suite for OpenGL and OpenCL \
3implementations."
Andrew Geissler90fd73c2021-03-05 15:25:55 -06004HOMEPAGE = "https://gitlab.freedesktop.org/mesa/piglit"
5BUGTRACKER = "https://gitlab.freedesktop.org/mesa/piglit/-/issues"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05006LICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
8
Andrew Geisslereff27472021-10-29 15:35:00 -05009SRC_URI = "git://gitlab.freedesktop.org/mesa/piglit.git;protocol=https;branch=main \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060010 file://0001-cmake-install-bash-completions-in-the-right-place.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011 file://0001-cmake-use-proper-WAYLAND_INCLUDE_DIRS-variable.patch \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060012 file://0001-Add-a-missing-include-for-htobe32-definition.patch \
Andrew Geissler09209ee2020-12-13 08:44:15 -060013 file://0001-generated_tests-gen_tcs-tes_input_tests.py-do-not-ha.patch \
14 file://0002-tests-util-piglit-shader.c-do-not-hardcode-build-pat.patch \
15 file://0001-serializer.py-make-.gz-files-reproducible.patch \
16 file://0001-framework-profile.py-make-test-lists-reproducible.patch \
17 file://0001-tests-shader.py-sort-the-file-list-before-working-on.patch \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060018 "
Brad Bishop316dfdd2018-06-25 12:45:53 -040019UPSTREAM_CHECK_COMMITS = "1"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050020
Andrew Geisslereff27472021-10-29 15:35:00 -050021SRCREV = "83bc56abf2686e2cd9024a152e121ca4aa524985"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050022# (when PV goes above 1.0 remove the trailing r)
23PV = "1.0+gitr${SRCPV}"
24
25S = "${WORKDIR}/git"
26
Brad Bishopc342db32019-05-15 21:57:59 -040027X11_DEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxrender libglu', '', d)}"
28X11_RDEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'mesa-demos', '', d)}"
29
30DEPENDS = "libpng waffle libxkbcommon virtual/libgl python3-mako-native python3-numpy-native python3-six-native virtual/egl"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050031
Brad Bishop6dbb3162019-11-25 09:41:34 -050032inherit cmake pkgconfig python3native features_check bash-completion
Patrick Williamsc124f4f2015-09-15 14:41:29 -050033
Brad Bishop6e60e8b2018-02-01 10:27:11 -050034# depends on virtual/libgl
35REQUIRED_DISTRO_FEATURES += "opengl"
36
Patrick Williamsf1e5d692016-03-30 15:21:19 -050037# The built scripts go into the temporary directory according to tempfile
38# (typically /tmp) which can race if multiple builds happen on the same machine,
39# so tell it to use a directory in ${B} to avoid overwriting.
40export TEMP = "${B}/temp/"
41do_compile[dirs] =+ "${B}/temp/"
42
Brad Bishopc342db32019-05-15 21:57:59 -040043PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050044PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
Brad Bishopc342db32019-05-15 21:57:59 -040045PACKAGECONFIG[x11] = "-DPIGLIT_BUILD_GL_TESTS=ON,-DPIGLIT_BUILD_GL_TESTS=OFF,${X11_DEPS}, ${X11_RDEPS}"
Andrew Geisslereff27472021-10-29 15:35:00 -050046PACKAGECONFIG[vulkan] = "-DPIGLIT_BUILD_VK_TESTS=ON,-DPIGLIT_BUILD_VK_TESTS=OFF,vulkan-loader"
Brad Bishopc342db32019-05-15 21:57:59 -040047
Andrew Geissler09209ee2020-12-13 08:44:15 -060048export PIGLIT_BUILD_DIR = "../../../../git"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050049
Patrick Williams213cb262021-08-07 19:21:33 -050050do_configure:prepend() {
Patrick Williamsc124f4f2015-09-15 14:41:29 -050051 if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
52 sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
53 sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h
54 fi
55}
56
Andrew Geissler82c905d2020-04-13 13:39:40 -050057# Forcibly strip because Piglit is *huge*
Brad Bishop316dfdd2018-06-25 12:45:53 -040058OECMAKE_TARGET_INSTALL = "install/strip"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060059
Patrick Williams213cb262021-08-07 19:21:33 -050060RDEPENDS:${PN} = "waffle waffle-bin python3 python3-mako python3-json \
Brad Bishop316dfdd2018-06-25 12:45:53 -040061 python3-misc \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060062 python3-unixadmin python3-xml python3-multiprocessing \
Brad Bishop316dfdd2018-06-25 12:45:53 -040063 python3-six python3-shell python3-io \
Brad Bishopc342db32019-05-15 21:57:59 -040064 python3-netserver bash \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050065 "
66
Patrick Williams213cb262021-08-07 19:21:33 -050067INSANE_SKIP:${PN} += "dev-so already-stripped"
Brad Bishop19323692019-04-05 15:28:33 -040068
Andrew Geissler82c905d2020-04-13 13:39:40 -050069# As nothing builds against Piglit we don't need to have anything in the
70# sysroot, especially when this is ~2GB of test suite
Patrick Williams213cb262021-08-07 19:21:33 -050071SYSROOT_DIRS:remove = "${libdir}"
Andrew Geissler82c905d2020-04-13 13:39:40 -050072
Brad Bishop19323692019-04-05 15:28:33 -040073# Can't be built with ccache
74CCACHE_DISABLE = "1"