blob: a9d1d39dfee137a8615062f89f491807b36038b3 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "OpenGL driver testing framework"
Brad Bishop1d80a2e2019-11-15 16:35:03 -05002DESCRIPTION = "Piglit is an open-source test suite for OpenGL and OpenCL \
3implementations."
Patrick Williamsc124f4f2015-09-15 14:41:29 -05004LICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
6
Brad Bishop96ff1982019-08-19 13:50:42 -04007SRC_URI = "git://gitlab.freedesktop.org/mesa/piglit.git;protocol=https \
Patrick Williamsc0f7c042017-02-23 20:41:17 -06008 file://0001-cmake-install-bash-completions-in-the-right-place.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009 file://0001-cmake-use-proper-WAYLAND_INCLUDE_DIRS-variable.patch \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060010 file://0001-Add-a-missing-include-for-htobe32-definition.patch \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060011 "
Brad Bishop316dfdd2018-06-25 12:45:53 -040012UPSTREAM_CHECK_COMMITS = "1"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050013
Andrew Geissler6ce62a22020-11-30 19:58:47 -060014SRCREV = "59e695c16fdcdd4ea4f16365f0e397a93cef7b80"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050015# (when PV goes above 1.0 remove the trailing r)
16PV = "1.0+gitr${SRCPV}"
17
18S = "${WORKDIR}/git"
19
Brad Bishopc342db32019-05-15 21:57:59 -040020X11_DEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxrender libglu', '', d)}"
21X11_RDEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'mesa-demos', '', d)}"
22
23DEPENDS = "libpng waffle libxkbcommon virtual/libgl python3-mako-native python3-numpy-native python3-six-native virtual/egl"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050024
Brad Bishop6dbb3162019-11-25 09:41:34 -050025inherit cmake pkgconfig python3native features_check bash-completion
Patrick Williamsc124f4f2015-09-15 14:41:29 -050026
Brad Bishop6e60e8b2018-02-01 10:27:11 -050027# depends on virtual/libgl
28REQUIRED_DISTRO_FEATURES += "opengl"
29
Patrick Williamsf1e5d692016-03-30 15:21:19 -050030# The built scripts go into the temporary directory according to tempfile
31# (typically /tmp) which can race if multiple builds happen on the same machine,
32# so tell it to use a directory in ${B} to avoid overwriting.
33export TEMP = "${B}/temp/"
34do_compile[dirs] =+ "${B}/temp/"
35
Brad Bishopc342db32019-05-15 21:57:59 -040036PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050037PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
Brad Bishopc342db32019-05-15 21:57:59 -040038PACKAGECONFIG[x11] = "-DPIGLIT_BUILD_GL_TESTS=ON,-DPIGLIT_BUILD_GL_TESTS=OFF,${X11_DEPS}, ${X11_RDEPS}"
39
Patrick Williamsc124f4f2015-09-15 14:41:29 -050040
41do_configure_prepend() {
42 if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
43 sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
44 sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h
45 fi
46}
47
Andrew Geissler82c905d2020-04-13 13:39:40 -050048# Forcibly strip because Piglit is *huge*
Brad Bishop316dfdd2018-06-25 12:45:53 -040049OECMAKE_TARGET_INSTALL = "install/strip"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060050
Brad Bishopa5c52ff2018-11-23 10:55:50 +130051RDEPENDS_${PN} = "waffle waffle-bin python3 python3-mako python3-json \
Brad Bishop316dfdd2018-06-25 12:45:53 -040052 python3-misc \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060053 python3-unixadmin python3-xml python3-multiprocessing \
Brad Bishop316dfdd2018-06-25 12:45:53 -040054 python3-six python3-shell python3-io \
Brad Bishopc342db32019-05-15 21:57:59 -040055 python3-netserver bash \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050056 "
57
Patrick Williamsc0f7c042017-02-23 20:41:17 -060058INSANE_SKIP_${PN} += "dev-so already-stripped"
Brad Bishop19323692019-04-05 15:28:33 -040059
Andrew Geissler82c905d2020-04-13 13:39:40 -050060# As nothing builds against Piglit we don't need to have anything in the
61# sysroot, especially when this is ~2GB of test suite
62SYSROOT_DIRS_remove = "${libdir}"
63
Brad Bishop19323692019-04-05 15:28:33 -040064# Can't be built with ccache
65CCACHE_DISABLE = "1"